【已解决】ADT中去安装4.2.2的Eclipse时挂在Calculating requirements and dependencies

【问题】

折腾:

【已解决】ADT中打开文件尤其是xml文件时加载很慢而且会在Reload Dependencies和Turn Grammar Constraints Off来回切换和闪烁

期间,出现:

去选择了和4.2.2相关的Eclipse后,结果却挂在了Calculating requirements and dependencies的界面:

hang on calculating requirements and dependencies

【解决过程】

1.参考:

Installing the ADT Plugin for Eclipse

去试试:

先中断当前的安装:

cancle current installation for adt eclipse

然后取消:Contact all update sites during install to find required software

unselect Contact all update sites during install to find required software

结果却出现了点问题:

Your original request has been modified.
  "Eclipse Platform" is already installed, so an update will be performed instead.
  "Eclipse RCP" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Platform 4.2.2.M20130204-1200 (org.eclipse.platform.ide 4.2.2.M20130204-1200)
  Software currently installed: Android Developer Tools 21.0.0.201210310022 (com.android.ide.eclipse.adt.package.product 21.0.0.201210310022)
  Only one of the following can be installed at once:
    Equinox Launcher Win32 X86_64 Fragment 1.1.200.v20120522-1813 (org.eclipse.equinox.launcher.win32.win32.x86_64 1.1.200.v20120522-1813)
    Equinox Launcher Win32 X86_64 Fragment 1.1.200.v20120913-144807 (org.eclipse.equinox.launcher.win32.win32.x86_64 1.1.200.v20120913-144807)
  Cannot satisfy dependency:
    From: Android Developer Tools 21.0.0.201210310022 (com.android.ide.eclipse.adt.package.product 21.0.0.201210310022)
    To: org.eclipse.equinox.launcher.win32.win32.x86_64 [1.1.200.v20120522-1813]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.2.2.M20130204-1200 (org.eclipse.platform.ide 4.2.2.M20130204-1200)
    To: org.eclipse.rcp.configuration.feature.group [1.0.0.M20130204-1200]
  Cannot satisfy dependency:
    From: Eclipse Product Configuration 1.0.0.M20130204-1200 (org.eclipse.rcp.configuration.feature.group 1.0.0.M20130204-1200)
    To: org.eclipse.equinox.launcher.win32.win32.x86_64 [1.1.200.v20120913-144807]

如图:

Your original request has been modified for adt

2.然后去取消哪些RCP之类的东西,再试试:

unselect rcp related then next

结果还是出错:

Your original request has been modified.
  "Eclipse Platform" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Platform SDK 4.2.2.M20130204-1200 (org.eclipse.platform.sdk 4.2.2.M20130204-1200)
  Software currently installed: Android Developer Tools 21.0.0.201210310022 (com.android.ide.eclipse.adt.package.product 21.0.0.201210310022)
  Only one of the following can be installed at once:
    Equinox Launcher Win32 X86_64 Fragment 1.1.200.v20120522-1813 (org.eclipse.equinox.launcher.win32.win32.x86_64 1.1.200.v20120522-1813)
    Equinox Launcher Win32 X86_64 Fragment 1.1.200.v20120913-144807 (org.eclipse.equinox.launcher.win32.win32.x86_64 1.1.200.v20120913-144807)
  Cannot satisfy dependency:
    From: Android Developer Tools 21.0.0.201210310022 (com.android.ide.eclipse.adt.package.product 21.0.0.201210310022)
    To: org.eclipse.equinox.launcher.win32.win32.x86_64 [1.1.200.v20120522-1813]
  Cannot satisfy dependency:
    From: Eclipse Platform SDK 4.2.2.M20130204-1200 (org.eclipse.platform.sdk 4.2.2.M20130204-1200)
    To: org.eclipse.rcp.configuration.feature.group [1.0.0.M20130204-1200]
  Cannot satisfy dependency:
    From: Eclipse Product Configuration 1.0.0.M20130204-1200 (org.eclipse.rcp.configuration.feature.group 1.0.0.M20130204-1200)
    To: org.eclipse.equinox.launcher.win32.win32.x86_64 [1.1.200.v20120913-144807]

3.那就只选择那个Eclipse的Platform,其他都不选,再试试:

only select eclipse platform next

结果仍有错误:

Your original request has been modified.
  "Eclipse Platform" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Platform 4.2.2.M20130204-1200 (org.eclipse.platform.ide 4.2.2.M20130204-1200)
  Software currently installed: Android Developer Tools 21.0.0.201210310022 (com.android.ide.eclipse.adt.package.product 21.0.0.201210310022)
  Only one of the following can be installed at once:
    Equinox Launcher Win32 X86_64 Fragment 1.1.200.v20120522-1813 (org.eclipse.equinox.launcher.win32.win32.x86_64 1.1.200.v20120522-1813)
    Equinox Launcher Win32 X86_64 Fragment 1.1.200.v20120913-144807 (org.eclipse.equinox.launcher.win32.win32.x86_64 1.1.200.v20120913-144807)
  Cannot satisfy dependency:
    From: Android Developer Tools 21.0.0.201210310022 (com.android.ide.eclipse.adt.package.product 21.0.0.201210310022)
    To: org.eclipse.equinox.launcher.win32.win32.x86_64 [1.1.200.v20120522-1813]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.2.2.M20130204-1200 (org.eclipse.platform.ide 4.2.2.M20130204-1200)
    To: org.eclipse.rcp.configuration.feature.group [1.0.0.M20130204-1200]
  Cannot satisfy dependency:
    From: Eclipse Product Configuration 1.0.0.M20130204-1200 (org.eclipse.rcp.configuration.feature.group 1.0.0.M20130204-1200)
    To: org.eclipse.equinox.launcher.win32.win32.x86_64 [1.1.200.v20120913-144807]

看起来是:

目前的是ADT(Android Developer Tools ),然后要装的是Eclipse(Eclipse Platform)

所以不给安装。

所以再去想办法去:

【已解决】在已有基于Eclipse的ADT的情况下,如何升级Eclipse本身的版本(而非ADT的版本)

 

【总结】

最后是:

还是重新装了了最新版本的4.3.1的Eclipse和ADT 22.3.0而解决了最初的问题。。。

 

而此处的问题是:

最终是:

通过取消选择“Contact all update sites during install to find required software”

而避免过长时间的加载和检测。

(只不过,此处后续出现了,和当前问题无关的,其他的,关于安装ADT时冲突的问题。)



发表评论

电子邮件地址不会被公开。 必填项已用*标注

无觅相关文章插件,快速提升流量