【已解决】在已有基于Eclipse的ADT的情况下,如何升级Eclipse本身的版本(而非ADT的版本)

【问题】

在折腾:

【未解决】ADT中去安装4.2.2的Eclipse时挂在Calculating requirements and dependencies

期间,出现错误:

Your original request has been modified.
  "Eclipse Platform" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Platform 4.2.2.M20130204-1200 (org.eclipse.platform.ide 4.2.2.M20130204-1200)
  Software currently installed: Android Developer Tools 21.0.0.201210310022 (com.android.ide.eclipse.adt.package.product 21.0.0.201210310022)
  Only one of the following can be installed at once:
    Equinox Launcher Win32 X86_64 Fragment 1.1.200.v20120522-1813 (org.eclipse.equinox.launcher.win32.win32.x86_64 1.1.200.v20120522-1813)
    Equinox Launcher Win32 X86_64 Fragment 1.1.200.v20120913-144807 (org.eclipse.equinox.launcher.win32.win32.x86_64 1.1.200.v20120913-144807)
  Cannot satisfy dependency:
    From: Android Developer Tools 21.0.0.201210310022 (com.android.ide.eclipse.adt.package.product 21.0.0.201210310022)
    To: org.eclipse.equinox.launcher.win32.win32.x86_64 [1.1.200.v20120522-1813]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.2.2.M20130204-1200 (org.eclipse.platform.ide 4.2.2.M20130204-1200)
    To: org.eclipse.rcp.configuration.feature.group [1.0.0.M20130204-1200]
  Cannot satisfy dependency:
    From: Eclipse Product Configuration 1.0.0.M20130204-1200 (org.eclipse.rcp.configuration.feature.group 1.0.0.M20130204-1200)
    To: org.eclipse.equinox.launcher.win32.win32.x86_64 [1.1.200.v20120913-144807]

此时,基本明白了错误的含义:

目前的是ADT(Android Developer Tools ),然后要装的是Eclipse(Eclipse Platform)

所以不给安装。

所以,现在是:

基于现在已有的

21.0.0.201210310022 的ADT

去更新Eclipse的版本,从

【已解决】ADT中打开文件尤其是xml文件时加载很慢而且会在Reload Dependencies和Turn Grammar Constraints Off来回切换和闪烁

中遇到的有问题的4.2.1,升级到4.2.2

【解决过程】

1.参考:

Can’t install Android ADT to Eclipse Helios (Windows)

貌似是可以直接去:

下载最新的Eclipse

然后解压

然后再重新安装ADT。

或许就可以了。

2.尝试上述办法之前,先去参考:

Numerous error messages when attempting to install ADT in Eclipse

去看看:

结果是:

adt about adt installation details installed software not found upgrade eclipse

在Installation Details中,还是没有找到:

哪里可以直接升级Eclipse版本本身的选项。(只能找到去升级ADT版本的选项)

3.所以,貌似还是必须:

用上面提到的方法,手动下载新版本的Eclipse,再安装ADT。。

不过还是打算先参考:

解决有关Eclipse 升级已安装的Android SDK 和 ADT 插件问题

看看能否从install new software中,给定那个Eclipse的地址,看看能否直接升级Eclipse。。。

然后先去看看最新的Eclipse的版本:

http://www.eclipse.org/downloads/

是4.3.1.

4.算了,还是去:

重新下载最新的Eclipse,然后集成最新的ADT,然后再去安装一堆的东西:

HAXM的硬件加速

TFS的插件

等等东西吧。。。

详见:

【记录】安装最新版本的Eclipse 4.3.1然后再安装最新的ADT 22.3.0

 

【总结】

最终是重新安装4.3.1的Eclipse和22.3.0的ADT而解决了问题。



发表评论

电子邮件地址不会被公开。 必填项已用*标注

无觅相关文章插件,快速提升流量