【记录】更换cygwin中某个模块的版本:再次将make从3.82换成3.81

【背景】

折腾:

【已解决】cygwin下编译buildroot在Installing kernel headers期间出错:Makefile:1444: *** mixed implicit and normal rules.  Stop.

期间,再次需要重新将cygwin中的3.82换成3.81的。

【折腾过程】

1.此处,由于之前就安装过,所以本地是已经有了下载好了的文件,

所以此处选择从Local安装:

here choose install from local

2.然后注意到,此处,正常的话,大部分的模块,都是Keep:

note here all module is keep

即,保持不变。

3.然后搜make,找到make,然后点击Keep,直到变为3.81:

click keep until become to 3.81 version

4.接着就可以去安装了:

then install make 3.81 checking md5

期间,由于之前降级了gcc,所以此处,也会自动升级gcc的:

during install will process some gcc related

5.很快,就安装完毕了:

cygwin make 3.81 install done

 

【总结】

cygwin中,如果是同样的setup.exe

且各个模块的版本,没啥变化的话,只安装单个模块,还是很快的。



发表评论

电子邮件地址不会被公开。 必填项已用*标注

无觅相关文章插件,快速提升流量