建设网站详细教程

版本：v1.0

Crifan Li

摘要

本文主要介绍建站之前需要了解的基本概念，以及如何建立一个自己的个人网站的详尽步骤，以及建站完成后，如何管理自己的网站

[提示] 本文提供多种格式供：
在线阅读 | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP
下载（7zip压缩包） | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP

HTML版本的在线地址为：

http://www.crifan.com/files/doc/docbook/build_website/release/html/build_website.html

有任何意见，建议，提交bug等，都欢迎去讨论组发帖讨论：

http://www.crifan.com/bbs/categories/build_website/

2013-08-01

修订历史
修订 1.0 2013-08-01 crl
  1. 把之前教程的地址整理过来

版权 © 2013 Crifan, http://crifan.com

本文章遵从：署名-非商业性使用 2.5 中国大陆(CC BY-NC 2.5)

目录

前言
1. 本文目的
1. 建站之前需要了解的概念
2. 如何建立自己的网站
3. 如何管理自己的网站
参考书目


前言

目录

1. 本文目的

1. 本文目的

本文目的在于，介绍建站之前需要了解的基本概念，以及如何建站。

希望看完此教程后，自己可以懂得如何去靠自己建立一个自己的网站。


第 1 章 建站之前需要了解的概念

[提示] 相关旧帖

【整理】关于建立网站的基本背景知识，基本概念和大概建站流程


第 2 章 如何建立自己的网站

此处，以wordpress为例，教你如何，一步步的，建立自己的wordpress网站。

[提示] 相关旧帖

如何搭建在线的WordPress网站

建站之前，需要去买虚拟主机。买虚拟主机之前，最好测试一下，你的网络，连接到你要购买的虚拟主机的实际速度如何。具体如何测试，可参考：

【记录】寻找国内访问速度比较快的美国的虚拟主机

确定了要买哪家的虚拟主机后，为了省钱，可以去找找一些优惠码等促销方式。

网上多搜搜，基本都可以找到优惠码之类的。

也可以参考我搜集的一些：

【整理】GoDaddy优惠码，最新可用的

【记录】寻找Bluehost优惠码

关于购买虚拟主机，可供参考的有：

【记录】购买BlueHost虚拟主机

【记录】购买hawk虚拟主机

买了之后，关于如何续费，可参考：

【教程】如何续费/续租（HostMonster上的）虚拟主机


第 3 章 如何管理自己的网站

此处教你，在建站后，如何管理自己的网站。

[提示] 相关旧帖

【整理】如何管理远程（HostMonster上的）虚拟主机上的在线WordPress网站

【整理】什么是Cpanel，以及如何通过Cpanel管理远程主机

有些虚拟主机商的服务，做的不是足够好，比如hawk，连如何进入cpanel，都不够显眼，所以有时候还需要花点时间，才能找到登陆cpanel的入口：

【已解决】hawk虚拟主机如何登陆进入Cpanel

有时候，遇到特殊的情况，无法登陆cpanel的话，可以参考：

【完全解决】hawk虚拟主机的cpanel登陆超时失败

如果觉得虚拟主机不够好，很多时候，也是可以退费的，具体可参考：

【记录】bluehost退费的过程

如果网站访问速度慢，可以自己用工具去分析，详见：

【记录】用tracert等工具分析网站访问速度慢的原因

关于加速网站访问速度方面，还有一种加速技术：

【整理】使用CloudFlare心得

如果使用网站期间，遇到问题，可以去客服反映。供参考的有：

【记录】向HostMonster反映虚拟主机的服务不稳定的问题


参考书目

[1] 【整理】关于建立网站的基本背景知识，基本概念和大概建站流程

[2] 【记录】在本地测试wordpress已成功后去实现在线的wordpress网站搬家(换主机)