Buildroot详解

版本：v0.2.0

Crifan Li

摘要

本文主要介绍了什么是Buildroot，如何用Buildroot去制作自己的交叉编译器，如何用Buildroot去制作自己的根文件系统，如何在Cygwin下编译Buildroot。

[提示] 本文提供多种格式供：
在线阅读 | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP
下载（7zip压缩包） | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP

HTML版本的在线地址为：

http://www.crifan.com/files/doc/docbook/buildroot_intro/release/html/buildroot_intro.html

有任何意见，建议，提交bug等，都欢迎去讨论组发帖讨论：

http://www.crifan.com/bbs/categories/buildroot_intro/

2015-05-24

修订历史
修订 0.2.0 2015-05-24 crl
  1. 把基本的内容整理架进来

版权 © 2015 Crifan, http://crifan.com

本文章遵从：署名-非商业性使用 2.5 中国大陆(CC BY-NC 2.5)

目录

前言
1. 本文目的
1. 联系方式
1. Buildroot简介
2. 用Buildroot制作交叉编译器
3. 用Buildroot制作根文件系统
4. 在Cygwin下编译Buildroot
参考书目


前言

目录

1. 本文目的
1. 联系方式

1. 本文目的

网上可以找到，全套的，介绍Buildroot，和如何使用Buildroot制作交叉编译器，根文件系统等方面的内容，很少，不全。

自己旨在编写并逐渐完善出一整套关于Buildroot方面的内容，供参考。

1. 联系方式

有任何意见、建议，都欢迎联系我Crifan


第 1 章 Buildroot简介

摘要

Buildroot，是个嵌入式开发领域内的，一个成套的嵌入式开发环境。

与Buildroot对应的，还有其他一些嵌入式开发环境，详见：各种制作交叉编译器的工具

Buildroot可以用来，制作自己的交叉编译器，制作自己的根文件系统，把uboot，Linux kernel集成到Buildroot中一起编译。

TODO：

合并http://www.crifan.com/summary_about_toolchain_cross_compiler/中的buildroot的内容。

use buildroot to create your own root file system


第 2 章 用Buildroot制作交叉编译器

摘要

可以用Buildroot去编译自己的交叉编译器，交叉工具链。


第 3 章 用Buildroot制作根文件系统

摘要

也可以用Buildroot去制作根文件系统。

一般来说，编译Buildroot完成后，默认的就可以编译出一套根文件系统了。然后就可以根据自己的需要，稍加修改，即可制作出自己需要的根文件系统。


第 4 章 在Cygwin下编译Buildroot

摘要

平时我们所说的编译Buildroot，都是在Linux类的系统里面操作的，比如在Ubuntu中编译Buildroot。

而在基于Windows的平台下，想要去编译Buildroot，一般来说没有好的选择。

其中一个勉为其难的选择是，Windows下安装Cygwin，然后在Cygwin下编译Buildroot。

但是Buildroot官网并没有说其支持Cygwin，所以，如果在Cygwin下面编译Buildroot则会遇到很多意想不到的问题，也未必能成功编译。

不过，我后来是专门花时间折腾过，最终是可以成功的在Cygwin下面编译Buildroot的。

详细过程如下：

TODO：整理帖子

【记录】在Cygwin上用Buildroot为xscale建立交叉工具链

其中包括了：

【已解决】cygwin下make编译buildroot时在libtool-2.2.10时出错：configure: error: C compiler cannot create executables

【已 解决】再次研究：Cygwin下编译Buildroot时在编译libtool-2.2.10时出错：/usr/lib/gcc/i686-pc- cygwin/4.7.3/cc1.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory

【记录】第三次去研究：Cygwin下编译Buildroot时在编译libtool-2.2.10时出错：/usr/lib/gcc/i686-pc- cygwin/4.7.3/cc1.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory

【记录】第四次去研究：cygwin下编译buildroot在编译libtool时出错：configure: error: C compiler cannot create executables


参考书目

[1] 各种制作交叉编译器的工具