电脑基础知识教程

版本：v1.0

Crifan Li

摘要

本文主要介绍了电脑使用方面的基础知识，包括软件方面的基础知识和硬件方面的基础知识。

[提示] 本文提供多种格式供：
在线阅读 | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP
下载（7zip压缩包） | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP

HTML版本的在线地址为：

http://www.crifan.com/files/doc/docbook/compute_basic/release/html/compute_basic.html

有任何意见，建议，提交bug等，都欢迎去讨论组发帖讨论：

http://www.crifan.com/bbs/categories/compute_basic/

2013-07-27

修订历史
修订 1.0 2013-07-27 crl
  1. 把之前的各种帖子整理过来

版权 © 2013 Crifan, http://crifan.com

本文章遵从：署名-非商业性使用 2.5 中国大陆(CC BY-NC 2.5)

目录

正文之前
1. 目的
2. 声明
1. 电脑基础知识简介
1.1. 电脑基础知识分类
2. 电脑基础知识之硬件基础知识
2.1. 常见的电脑的类型
2.2. 电脑的硬盘
3. 电脑基础知识之软件基础知识
3.1. 操作系统类型
3.1.1. Windows操作系统
3.1.2. Linux操作系统
3.1.3. Mac操作系统
3.2. 正版系统与盗版系统
3.3. 安装操作系统
3.3.1. 安装Windows操作系统
3.3.2. 安装Linux操作系统
3.3.3. 安装Mac操作系统
3.4. 安装驱动
3.5. 操作系统启动顺序
3.6. 磁盘分区
3.6.1. Windows系统的磁盘分区
3.6.2. Linux系统的磁盘分区
3.6.3. Mac系统的磁盘分区
3.7. 电脑的BIOS
4. 电脑基础知识之软硬件之间的关系
4.1. 硬件与安装的操作系统之间的关系
参考书目


正文之前

目录

1. 目的
2. 声明

1. 目的

本文旨在用尽可能通俗的语言，解释清楚电脑的基础知识，包括硬件的基础知识，和软件的基础知识。

以使得之前对于电脑没啥概念的人，看了之后，能大概对电脑有个更加清晰的认识。


2. 声明

任何疑问，意见，建议等，都欢迎一起探讨：admin (at) crifan.com。


第 1 章 电脑基础知识简介

目录

1.1. 电脑基础知识分类

摘要

1.1. 电脑基础知识分类

电脑的基础知识，主要分三大方面

  • 软件
  • 硬件
  • 软硬件之间的关系

下面就针对这三方面，详细的解释解释。


第 2 章 电脑基础知识之硬件基础知识

目录

2.1. 常见的电脑的类型
2.2. 电脑的硬盘

摘要

2.1. 常见的电脑的类型

主要有：笔记本，台式机

其他的也有很多，相对不那么常见的形式，比如一体机等等。

详见：【教程】电脑知识介绍：常见的电脑类型：台式机，笔记本，一体机


2.2. 电脑的硬盘

用于存储东西的

有一些工具，用于帮助查看和诊断硬盘信息的。

比如：【已解决】HD Tune测试硬盘健康状况中：重定位扇区数量-衰退，重定位扇区数据操作数量-警告，如何解决


第 3 章 电脑基础知识之软件基础知识

目录

3.1. 操作系统类型
3.1.1. Windows操作系统
3.1.2. Linux操作系统
3.1.3. Mac操作系统
3.2. 正版系统与盗版系统
3.3. 安装操作系统
3.3.1. 安装Windows操作系统
3.3.2. 安装Linux操作系统
3.3.3. 安装Mac操作系统
3.4. 安装驱动
3.5. 操作系统启动顺序
3.6. 磁盘分区
3.6.1. Windows系统的磁盘分区
3.6.2. Linux系统的磁盘分区
3.6.3. Mac系统的磁盘分区
3.7. 电脑的BIOS

摘要

3.1. 操作系统类型

详解：大白话之什么是操作系统

主要分三种：

  • Windows
  • Linux
  • Mac

下面详细解释其具体的特点：

3.1.1. Windows操作系统

相对来说，中国人，最熟悉的操作系统。

从古至今，一些耳熟能详的windows的系统有：win95，win98，WinXP，Vista，Win7，Win8等等

详解：【教程】什么是Windows系统：XP/Win7/Win8

3.1.2. Linux操作系统

分很多种不同的发行版（distribution）

详解：【整理】什么是Linux系统

3.1.3. Mac操作系统

Mac，中文名是，苹果，其logo就是那个被咬了一口的苹果

也是，相对来说，价格最贵的电脑了。

详解：【教程】什么是Mac系统：Mac OS X

更多解释详见：【教程】软件开发基础知识之操作系统类型：Windows/Linux/Mac，32位/64位


3.2. 正版系统与盗版系统

简单说就是：目前国内，用的最多的系统，很多都是盗版的Windows系统。

对于普通消费者来说，盗版系统，使用起来，和正版的，没有任何区别。

因为相对来说，盗版的技术，已经太发达了。发达到微软都无法忽视盗版系统这个市场了，都不敢轻易的彻底封杀盗版。（当然也很难彻底封杀）

更多解释详见：【教程】电脑基础知识之操作系统的盗版与正版的关系


3.3. 安装操作系统

3.3.1. 安装Windows操作系统

安装windows操作系统，是个很大的话题。

此处只是介绍一下，常见的安装方法，和我个人折腾过的实际例子，供参考：

硬盘安装Ghostxp系统的图解教程（不用光盘重装系统）

3.3.2. 安装Linux操作系统

如前所述，Linux有很多发行版本。此处主要介绍，相对用的比较广的，最新的，Ubuntu。

3.3.3. 安装Mac操作系统

Mac系统，一般都是买Mac的电脑，自带的。

但是也有别人破解的。所以，也是可以通过虚拟机安装的。

但此处不详细解释了，细节可参考：使用VirtualBox创建Mac类的虚拟机

但是，对于Mac系统中，有时候也有需求是在Mac系统之上，再去安装Windows系统的。

详见：【记录】给MacBook Air安装Win7双系统


3.4. 安装驱动

因为相对来说，多数人，没怎么接触过Linux，而买Mac系统的也不多。

所以，此处所说的安装驱动，更多的时候，指的是，在Windows操作系统中，为某硬件设备安装驱动。

以前安装驱动，相对比较麻烦，尤其是win98，包括winXP等时代，都还是很折腾的。

现在，主要是Win7，Win8等环境下，加上各种辅助安装驱动的软件，所以安装驱动的事情，相对变得比较简单了。

相对来说，目前最好用的，就是利用：驱动人生，自动帮助我们去下载和安装驱动。

详见：【教程】利用驱动人生软件,实现快速方便智能地安装（笔记本）电脑驱动


3.5. 操作系统启动顺序

详见：【整理】操作系统（和虚拟机）的启动过程和启动顺序


3.6. 磁盘分区

3.6.1. Windows系统的磁盘分区

举例：【记录】通过分区工具给C盘扩大容量

3.6.2. Linux系统的磁盘分区

3.6.3. Mac系统的磁盘分区


3.7. 电脑的BIOS

简单来说，就是可以对电脑的基本的一些参数，进行配置。

详见：【教程】什么是BIOS以及如何配置电脑中的BIOS


第 4 章 电脑基础知识之软硬件之间的关系

目录

4.1. 硬件与安装的操作系统之间的关系

摘要

4.1. 硬件与安装的操作系统之间的关系

简单说就是：你的电脑的硬件本身，和你在上面安装的操作系统这个软件，没有本质的必然的联系的。

详见：【教程】电脑基础知识之电脑硬件和所安装的操作系统的关系


参考书目

[1] 【记录】通过分区工具给C盘扩大容量