【crifan推荐】支持多种协议的串口开发工具：SecureCRT

版本：v0.4.0

Crifan Li

摘要

本文主要介绍了笔者crifan推荐，支持多种协议，比如串口，SSH2等的开发工具SecureCRT。

[提示] 本文提供多种格式供：
在线阅读 | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP
下载（7zip压缩包） | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP

HTML版本的在线地址为：

http://www.crifan.com/files/doc/docbook/rec_soft_securecrt/release/html/rec_soft_securecrt.html

有任何意见，建议，提交bug等，都欢迎去讨论组发帖讨论：

http://www.crifan.com/bbs/categories/rec_soft_securecrt/

2015-05-22

修订历史
修订 0.4.0 2015-05-22 crl
  1. 添加基本框架

版权 © 2015 Crifan, http://crifan.com

本文章遵从：署名-非商业性使用 2.5 中国大陆(CC BY-NC 2.5)

目录

正文之前
1. 目的
2. 声明
1. SecureCRT简介
1.1. 下载SecureCRT
2. SecureCRT的各种功能
2.1. SecureCRT功能介绍之serial串口
2.2. SecureCRT功能介绍之modem
2.3. SecureCRT功能介绍之SSH
2.4. SecureCRT功能介绍之丰富的日志功能
3. SecureCRT常见问题及解答
常见问题
3.1. SecureCRT中串口无法输入
3.2. 如何解决SecureCRT的中文乱码？
3.3. 如何让SecureCRT支持vi/vim的彩色显示？
3.4. 如何让SecureCRT在SSH2连接期间的Home、End等快捷键起效果？
参考书目


正文之前

目录

1. 目的
2. 声明

1. 目的

本文旨在推荐我个人（crifan）觉得好用的，开发工具：SecureCRT


2. 声明

任何疑问、意见、建议等，欢迎发邮件一起探讨：admin (at) crifan.com。


第 1 章 SecureCRT简介

目录

1.1. 下载SecureCRT

摘要

TOOD：整理帖子

【crifan推荐】极佳的串口开发工具：SecureCRT

SecureCRT是个开发工具，其支持很多种协议，比如串口，SSH等等。

在软件开发期间，常常会用得到。

比如：

  • 用SecureCRT通过串口连接嵌入式开发板的串口，进行调试。
  • 用SecureCRT通过SSH2连接远程Linux的主机，进行远程操作。
  • 用SecureCRT通过zmodem传输文件到远程的Linux主机中。

1.1. 下载SecureCRT

TODO：【下载】VanDyke.SecureCRT.x86.v6.5.0.380 附带破解注册机crack 和 注册机使用说明


第 2 章 SecureCRT的各种功能

目录

2.1. SecureCRT功能介绍之serial串口
2.2. SecureCRT功能介绍之modem
2.3. SecureCRT功能介绍之SSH
2.4. SecureCRT功能介绍之丰富的日志功能

摘要

此处介绍，SecureCRT的各种常见功能。

2.1. SecureCRT功能介绍之serial串口

支持serial串口协议，用于连接串口，包括典型的嵌入式开发板上的串口，和其他设备的串口。

TODO：【记录】恢复win7与ARM开发板TQ2440的串口连接

TODO：【记录】继续尝试通过TTL串口去访问pcDuino


2.2. SecureCRT功能介绍之modem

关于modem类的协议，比如xmodem，ymodem，zmodem协议，不熟悉的可以去看看：

TODO：【整理】Kermit Xmodem Xmodem-1K Ymodem Ymodem-G Ymodem-1K Zmodem

支持modem类的协议，比如Xmodem，zmodem等等，用于和远程互相传输文件用。

TODO：【解决】从Linux服务器上，高效地下载多个文件 + 从Linux服务器下载文件到windows中的各种方法简介


2.3. SecureCRT功能介绍之SSH

支持SSH2协议。可以用来连接远程开启了SSH协议支持的Linux服务器。

TODO：【记录】尝试通过网络中的ssh2去连接pcDuino

比如后来就通过SecureCRT去以ssh方式连接远程的VPS主机：

TODO：【记录】用SecureCRT上传文件到通过ssh连接的Linode的VPS服务器


2.4. SecureCRT功能介绍之丰富的日志功能

对于多日志文件的支持

TODO：整理

SecureCRT的日志设置


第 3 章 SecureCRT常见问题及解答

目录

常见问题
3.1. SecureCRT中串口无法输入
3.2. 如何解决SecureCRT的中文乱码？
3.3. 如何让SecureCRT支持vi/vim的彩色显示？
3.4. 如何让SecureCRT在SSH2连接期间的Home、End等快捷键起效果？

摘要

此处整理，在使用SecureCRT期间，比较常见的一些问题，以及如何解决。

TOOD：整理帖子

【记录】SecureCRT中用Ymodem传输文件，中途死掉Halt -> Ymodem-1K可以正常传输，但是完成后会死掉

【已解决】secureCRT中：中文乱码显示问题 + Home/End移动到行首/行尾 + vi/vim中显示彩色代码

3.1. SecureCRT中串口无法输入
3.2. 如何解决SecureCRT的中文乱码？
3.3. 如何让SecureCRT支持vi/vim的彩色显示？
3.4. 如何让SecureCRT在SSH2连接期间的Home、End等快捷键起效果？
3.1. | SecureCRT中串口无法输入
 | TODO：待整理： 【已解决】secureCRT下的串口不能输入 【已解决】keyboard-interactive authentication with the ssh2 server failed
3.2. | 如何解决SecureCRT的中文乱码？ 如何让SecureCRT显示中文？ 如何去除SecureCRT显示出的乱码？
 | TODO：待整理： 【已解决】secureCRT中：中文乱码显示问题 + Home/End移动到行首/行尾 + vi/vim中显示彩色代码 让secureCRT正确显示中文
3.3. | 如何让SecureCRT支持vi/vim的彩色显示？
 | TODO：待整理： 【已解决】secureCRT中：中文乱码显示问题 + Home/End移动到行首/行尾 + vi/vim中显示彩色代码 【整理】secureCRT连Linux服务器，配置vim使得色彩显示生效
3.4. | 如何让SecureCRT在SSH2连接期间的Home、End等快捷键起效果？
 | TODO：待整理： 【已解决】secureCRT中：中文乱码显示问题 + Home/End移动到行首/行尾 + vi/vim中显示彩色代码


参考书目

[1] 【crifan推荐】极佳的串口开发工具：SecureCRT