VirtualBox教程

版本：v1.0

Crifan Li

摘要

本文主要介绍虚拟机VirtualBox的知识，主要包括，VirtualBox的基本介绍，如何使用VirtualBox创建各种虚拟机，包括XP,Ubuntu,Mac,Android等虚拟机，另外也针对VirtualBox的各种方面的配置进行了详细解释，包括显卡的配置，串口的配置，文件共享的配置，增强包和扩展包等等

[提示] 本文提供多种格式供：
在线阅读 | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP
下载（7zip压缩包） | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP

HTML版本的在线地址为：

http://www.crifan.com/files/doc/docbook/virtualbox_tutorial/release/html/virtualbox_tutorial.html

有任何意见，建议，提交bug等，都欢迎去讨论组发帖讨论：

http://www.crifan.com/bbs/categories/virtualbox_tutorial/

2015-05-19

修订历史
修订 1.0 2015-05-19 crl
  1. 把之前教程的地址整理过来
  2. 添加VirtualBox中的鼠标自动切换

版权 © 2015 Crifan, http://crifan.com

本文章遵从：署名-非商业性使用 2.5 中国大陆(CC BY-NC 2.5)

目录

前言
1. 本文目的
1. VirtualBox基本知识介绍
2. 下载和安装VirtualBox
3. 通用的配置和常见的问题
3.1. VirtualBox中一些通用的配置
3.2. VirtualBox中常见的问题及解决办法
4. 使用VirtualBox安装一个新的虚拟机的通用步骤
4.1. 步骤1：下载OS操作系统安装（ISO镜像）文件
4.2. 步骤2：创建新的虚拟机
4.3. 步骤3：配置刚新建好的虚拟机
4.4. 步骤4：真正开始去安装虚拟机
4.5. 步骤5：在第一次运行安装好的虚拟机时，去做一些必要的配置
5. 使用VirtualBox创建Windows类的虚拟机
5.1. 用VirtualBox创建XP虚拟机
5.2. 用VirtualBox创建Win8虚拟机
6. 使用VirtualBox创建Linux类的虚拟机
6.1. 用VirtualBox安装Ubuntu虚拟机
6.2. 用VirtualBox安装Android虚拟机
7. 使用VirtualBox创建Mac类的虚拟机
参考书目

插图清单

3.1. Virtualbox中Ubuntu系统提示鼠标自动切换
3.2. Virtualbox中Ubuntu中已经开启鼠标自动切换


前言

目录

1. 本文目的

1. 本文目的

本文目的在于，介绍虚拟机的基础知识。


第 1 章 VirtualBox基本知识介绍

[提示] 相关旧帖

【整理】VirtualBox常见问题及解答

【crifan推荐】虚拟机软件VirtualBox


第 2 章 下载和安装VirtualBox

[提示] 相关旧帖

【教程】如何安装VirtualBox

【整理】VirtualBox常见问题及解答

【crifan推荐】虚拟机软件VirtualBox


第 3 章 通用的配置和常见的问题

目录

3.1. VirtualBox中一些通用的配置
3.2. VirtualBox中常见的问题及解决办法

摘要

此处只整理出，VirtualBox中，和所创建的虚拟机类型无关的，通用配置，常见的一些问题。

3.1. VirtualBox中一些通用的配置

[提示] 相关旧帖

【整理】VirtualBox中的Guest Additions（客户端增强包)和Extension Pack（扩展增强包）的含义和区别

【教程】如何为VirtualBox安装 Guest Additions/增强工具包/功能增强包/增强功能包

【整理】Virtualbox中的网络类型（NAT，桥接等），网卡，IP地址等方面的设置

【详解】如何配置VirtualBox中的虚拟机的串口

【整理】VirtualBox中如何实现主机和虚拟机之间的文件拖放（Drag-and-Drop）

VirtualBox中的：鼠标自动切换

图 3.1. Virtualbox中Ubuntu系统提示鼠标自动切换

Virtualbox中Ubuntu系统提示鼠标自动切换

图 3.2. Virtualbox中Ubuntu中已经开启鼠标自动切换

Virtualbox中Ubuntu中已经开启鼠标自动切换


3.2. VirtualBox中常见的问题及解决办法

[提示] 相关旧帖

【已解决】VirtualBox中安装虚拟机时出错：VT-x features locked or unavailable in MSR,VERR_VMX_MSR_LOCKED_OR_DISABLED

【整理】运行Virtualbox去安装系统时出错：Failed to open a session for the virtual machine，Unable to load R3 module xxxx/VBoxDD.DLL(VBoxDD)，GetLastError=126，(VERR_MODULE_NOT_FOUND)


第 4 章 使用VirtualBox安装一个新的虚拟机的通用步骤

目录

4.1. 步骤1：下载OS操作系统安装（ISO镜像）文件
4.2. 步骤2：创建新的虚拟机
4.3. 步骤3：配置刚新建好的虚拟机
4.4. 步骤4：真正开始去安装虚拟机
4.5. 步骤5：在第一次运行安装好的虚拟机时，去做一些必要的配置

用VirtualBox创建虚拟机，有大部分的步骤，是通用的。现在整理如下：

4.1. 步骤1：下载OS操作系统安装（ISO镜像）文件


4.2. 步骤2：创建新的虚拟机


4.3. 步骤3：配置刚新建好的虚拟机


4.4. 步骤4：真正开始去安装虚拟机


4.5. 步骤5：在第一次运行安装好的虚拟机时，去做一些必要的配置

比如安装Mac后，需要设置对应的引导工具，才能引导，才能正常启动Mac系统。

比如安装好Android系统后，第一次启动，需要进行相关设置，之后才能正常使用Android系统。


第 5 章 使用VirtualBox创建Windows类的虚拟机

目录

5.1. 用VirtualBox创建XP虚拟机
5.2. 用VirtualBox创建Win8虚拟机

5.1. 用VirtualBox创建XP虚拟机

[提示] 相关旧帖

【资源下载】各种版本的Windows XP镜像下载：深度技术Ghost版

【记录】在Virtualbox上安装Windows XP虚拟机

【教程】如何在Virtualbox中创建Windows XP的虚拟机

【教程】如何在Virtualbox中设置XP虚拟机

【教程】如何在Virtualbox中安装（已创建且配置好的）XP（虚拟机）的过程

安装XP时分区错误：EDD BIOS data ERROR, Disk 80h. General failure reading drive A. Abort, Retry, Ignore, Fail?

【教程】如何（在Virtualbox中的Deepin XP安装盘中）通过PQ(PowerQuest PartitionMagic)给空白硬盘分区

【已解决】Virtualbox中安装完毕XP后，启动出错：FATAL INT18 BOOT FAILURE

【教程】实现Virtualbox中的XP虚拟机和主机Win7之间的共享文件夹


5.2. 用VirtualBox创建Win8虚拟机


第 6 章 使用VirtualBox创建Linux类的虚拟机

目录

6.1. 用VirtualBox安装Ubuntu虚拟机
6.2. 用VirtualBox安装Android虚拟机

6.1. 用VirtualBox安装Ubuntu虚拟机

[提示] 相关旧帖

【教程】下载最新版（桌面版的）Ubuntu

【教程】【每步均有截图和解释】如何在VirtualBox中安装Ubuntu虚拟机

【教程】【每步均有截图和解释】在VirtualBox中创建Ubuntu的虚拟机

【教程】【每步均有截图和解释】在VirtualBox中配置（刚创建好的）Ubuntu虚拟机

【教程】【每步均有截图和解释】在VirtualBox中安装（刚配置好）Ubuntu虚拟机

【已解决】在Virtualbox中的Ubuntu虚拟机中，安装Guest Additions客户端增强包时出错：分配介质 虚拟光盘 xxx\VBoxsGuestAdditions.iso 到虚拟电脑 xxx 失败。您是否要强制卸载分配该介质？

【已解决】virtualbox下的Ubuntu的1366×768全屏显示


6.2. 用VirtualBox安装Android虚拟机

[提示] 相关旧帖

【记录】Virtualbox中安装Android虚拟机

【记录】Virtualbox中创建Android-x86的虚拟机

【记录】Virtualbox中配置新建好的Android-x86的虚拟机

【记录】Virtualbox中安装已配置好的Android-x86的虚拟机

【记录】Virtualbox中安装Android-x86过程中去创建新的分区

【记录】Virtualbox中安装Android-x86过程中新建分区后再去格式化分区，安装GRUB，设置system文件夹为可读写

【记录】Virtualbox中安装Android-x86过程中开始真正的去安装Android-x86

【记录】Virtualbox中安装Android-x86过程中安装完毕Android-x86后第一次启动

【已解决】Virtualbox中安装Android-x86后第一次启动，结果没有响应，Android像死掉了一样

【已解决】Virtualbox中安装Android-x86后去启动Android，结果出错：FATAL no bootable medium found system halted

【记录】在Virtualbox中使用Android-x86虚拟机

【已解决】在Virtualbox中的虚拟机Android-x86 4.0不能上网

【整理】Virtualbox中安装Android-x86虚拟机的注意事项和心得


第 7 章 使用VirtualBox创建Mac类的虚拟机

[提示] 相关旧帖

【总结】用虚拟机安装Mac之前的注意事项

【总结】在VirtualBox上面安装Mac的注意事项

【超多图，超详解】在virtualbox上安装Mac OS X Lion 之 配置过程

【超多图，超详解】在virtualbox上安装Mac OS X Lion 之 安装过程

记录在K470+SSD+Win7下，在VirtualBox中安装Mac Lion 10.7

【继续折腾】在K470+SSD+Win7下，使用VirtualBox安装Mac Lion 10.7

【记录】在6G内存的64位Win7主机中，在VirtualBox中安装Mac OS X 10.7 Lion

【教程】6G内存的64位Win7下，新建Mac虚拟机

【教程】6G内存的64位Win7下，配置Mac虚拟机

【教程】6G内存的64位Win7下，安装Mac虚拟机

【教程】6G内存的64位Win7下，第一次启动已安装好的Mac虚拟机

【已解决】实现VirtualBox中的（Guest OS）Mac和主机（Host OS）Win7之间的文件和文件夹共享


参考书目

[1] 【整理】VirtualBox常见问题及解答