虚拟机教程

版本：v1.0

Crifan Li

摘要

本文主要介绍虚拟机方面的知识，主要包括，什么是虚拟机，目前主流包含哪些虚拟机软件，以及虚拟机领域中的基本概念，比如虚拟机和真实主机之间的关系等内容

[提示] 本文提供多种格式供：
在线阅读 | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP
下载（7zip压缩包） | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP

HTML版本的在线地址为：

http://www.crifan.com/files/doc/docbook/virutal_machine_tutorial/release/html/virutal_machine_tutorial.html

有任何意见，建议，提交bug等，都欢迎去讨论组发帖讨论：

http://www.crifan.com/bbs/categories/virutal_machine_tutorial/

2013-01-30

修订历史
修订 1.0 2013-01-30 crl
  1. 把之前教程的地址整理过来

版权 © 2013 Crifan, http://crifan.com

本文章遵从：署名-非商业性使用 2.5 中国大陆(CC BY-NC 2.5)

目录

前言
1. 本文目的
1. 虚拟机基础知识介绍
2. 常见虚拟机软件介绍
3. 虚拟机领域内的基本概念和基础知识
3.1. 虚拟机和真实主机之间的关系
3.2. 虚拟机中的设备驱动
3.3. 虚拟机中的启动相关的设置
参考书目


前言

目录

1. 本文目的

1. 本文目的

本文目的在于，介绍虚拟机的基础知识。


第 1 章 虚拟机基础知识介绍

[提示] 相关旧帖

【整理】什么是虚拟机


第 2 章 常见虚拟机软件介绍

【整理】虚拟机的选择，VMWare还是VirtualBox – 绝对推荐VirtualBox

比较常见的几个虚拟机软件是，VirtualBox，VMWare，Virtual PC


第 3 章 虚拟机领域内的基本概念和基础知识

目录

3.1. 虚拟机和真实主机之间的关系
3.2. 虚拟机中的设备驱动
3.3. 虚拟机中的启动相关的设置

3.1. 虚拟机和真实主机之间的关系

[提示] 相关旧帖

【教程】详细解释主机和虚拟机之间的关系以及常见问题的解答

【整理】操作系统（和虚拟机）的启动过程和启动顺序

【整理】宿主机中的操作系统和虚拟机中的操作系统是否一样


3.2. 虚拟机中的设备驱动

【整理】虚拟机系统中的显卡和显卡驱动

虚拟机中的设备的驱动，和你当前真实主机内的设备和对应的设备的驱动，基本上没有关系。


3.3. 虚拟机中的启动相关的设置

【整理】（VirtualBox中的虚拟机的配置中的）EFI(Extensible Firmware Interface),UEFI(Unified EFI)

不要随便使用EFI（UEFI），否则很可能会导致虚拟机无法启动。


参考书目

[1] 【整理】什么是虚拟机