VMWare教程

版本：v1.1

Crifan Li

摘要

本文主要介绍虚拟机软件VMWare的各方面知识。主要包括，使用VMWare过程中遇到的一些问题及解决办法，VMWare如何使用等等。

[提示] 本文提供多种格式供：
在线阅读 | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP
下载（7zip压缩包） | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP

HTML版本的在线地址为：

http://www.crifan.com/files/doc/docbook/vmware_tutorial/release/html/vmware_tutorial.html

有任何意见，建议，提交bug等，都欢迎去讨论组发帖讨论：

http://www.crifan.com/bbs/categories/vmware_tutorial/

2013-09-04

修订历史
修订 1.1 2013-09-04 crl
  1. 把之前教程的地址整理过来
  2. 把一些帖子地址加进来

版权 © 2013 Crifan, http://crifan.com

本文章遵从：署名-非商业性使用 2.5 中国大陆(CC BY-NC 2.5)

目录

前言
1. 本文目的
2. 前提
1. 虚拟机软件VMWare简介
2. 如何使用VMWare
2.1. 用VMWare安装Mac虚拟机
3. VMWare常见问题及解决办法
参考书目


前言

目录

1. 本文目的
2. 前提

1. 本文目的

本文目的是介绍虚拟机软件VMWare方面的基础知识和常见问题。

[注意] 推荐使用VirtualBox而不是VMWare

简单解释：由于VirtualBox比VMWare更加好用，省资源，所以，更加推荐VirtualBox，而不是VMWare。

详解：

  • 关于为何推荐VirtualBox：常见虚拟机软件介绍
  • 关于VirtualBox，不了解的可参考：VirtualBox教程
  • 而此处之所以还继续写VMWare教程，是因为，只是整理一下之前已经折腾过的一些内容，供有需要的参考，并不会写极其详尽的教程。


2. 前提

在看此文之前，你需要对于虚拟机本身，有了相应的了解了。

如果不了解虚拟机，请先去参考：

虚拟机教程


第 1 章 虚拟机软件VMWare简介

VMWare只是常用的虚拟机软件中的一种。


第 2 章 如何使用VMWare

目录

2.1. 用VMWare安装Mac虚拟机

就像可以用VirtualBox去安装很多不同的虚拟机系统一样，也可以用VMWare来安装很多种虚拟机系统。

比如安装Mac，XP等等虚拟机。

2.1. 用VMWare安装Mac虚拟机

[提示] 相关旧帖

【整理】关于Vmware和VirtualBox上安装Mac，Xcode,iOS SDK等相关资料

【记录】在VMware Workstation 8.0.0 build-471780上安装Mac OSX v10.7 Lion的过程 – 1

【记录】在VMware Workstation 8.0.0 build-471780上安装Mac OSX v10.7 Lion的过程 – 2

【超多图详解】在VMWare虚拟机上安装Mac OS X Lion

【超多图详解】VMWare上安装Mac后，用HJMac引导（第一次）启动Mac的过程

【总结】在VMWare上面安装Mac的注意事项

【成功】通过Samba实现Windows XP和VMware下的Ubuntu共享

【已解决】用VMWare安装Longhorn出错：Setup has encountered an error(system file time out of sync,error code is 800b0101)

VMware下Ubuntu不能和Windows共享文件夹

【安装VMware tools遇到的问题】

Ubuntu8.10在虚拟机VMWare 6.5精简版不能上网的解决办法

成功安装vmhgfs模块，实现文件夹共享

【已解决】安装VMWare Workstation期间使用默认的HTTPS Port 443结果出现：This port is in use by another program

【记录】安装VMware Workstation

【记录】VMWare Workstation 8中创建一个Ubuntu的虚拟机

【记录】VMWare Workstation 8中安装刚创建和配置好的Ubuntu 13.04虚拟机

【整理】VMWare Workstation 8使用心得

【记录】VMWare Workstation 8安装Ubuntu

【记录】VMWare Workstation中实现Win7和Ubuntu虚拟机之间的文件共享

【已解决】VMWare Workstation和Ubuntu之间无法共享（复制和粘贴）剪贴板

【未解决】VMware Workstation的Ubuntu虚拟机中安装VMWare Tools出现提示：Enter the path to the kernel header files for the 3.8.0-27-generic kernel?

【吐槽】VMWare Workstation中的VMWare Tools还是很不好用啊

【已 解决】VMware Workstation 8下Ubuntu 13.04中安装VMware Tools出错：/tmp/vmware-root/modules/vmci-only/linux/driver.c:127:4: error: implicit declaration of function ‘__devexit_p’ [-Werror=implicit-function-declaration]

【记录】继续折腾VMWare Workstation 8下的虚拟机Ubuntu 13.04中的文件夹共享


第 3 章 VMWare常见问题及解决办法

[提示] 相关旧帖

给VMWare下的虚拟机扩充硬盘大小【详细过程记录—>>>最后彻底弄废了虚拟机】


参考书目

[1] 【总结】在VMWare上面安装Mac的注意事项