网站搬家详解

版本：v1.0

Crifan Li

摘要

本文主要介绍网站搬家的过程，涉及到搬家之前，需要了解的很多基本概念，如何具体操作网站搬家，其中有哪些注意事项，常见的问题的现象和解决办法。

[提示] 本文提供多种格式供：
在线阅读 | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP
下载（7zip压缩包） | HTML | HTMLs | PDF | CHM | TXT | RTF | WEBHELP

HTML版本的在线地址为：

http://www.crifan.com/files/doc/docbook/website_transfer/release/html/website_transfer.html

有任何意见，建议，提交bug等，都欢迎去讨论组发帖讨论：

http://www.crifan.com/bbs/categories/website_transfer/

2013-08-01

修订历史
修订 1.0 2013-08-01 crl
  1. 把之前教程的地址整理过来

版权 © 2013 Crifan, http://crifan.com

本文章遵从：署名-非商业性使用 2.5 中国大陆(CC BY-NC 2.5)

目录

前言
1. 本文目的
1. 网站搬家之前要了解的概念和要做的事情
1.1. 网站搬家之前需要了解的概念
1.2. 网站搬家之前要做的事情
2. 真正去操作网站搬家
2.1. 网站搬家的详细步骤
2.1.1. 步骤1：创建邮件账户
2.1.2. 步骤2：创建ftp账户
2.1.3. 步骤3：上传文件
2.1.4. 步骤4：创建数据库和用户
2.1.5. 步骤5：修改wordpress的配置
2.1.6. 步骤6：验证主页地址访问是否正常
2.1.7. 步骤7：更新DNS
2.2. 网站搬家期间常见的错误及解决办法
2.2.1. 您可能正在上传很大的文件，请参考文档来寻找解决办法
2.2.2. DROP TABLE IF EXISTS `wp_commentmeta`
2.2.3. 访问主页出错：403 Permission Denied
2.2.4. 建立数据库连接时出错
2.2.5. 访问主页出现404错误
2.2.6. GoDaddy的DNS Manager的Not hosted here
3. 网站搬家之后需要做的事情
参考书目


前言

目录

1. 本文目的

1. 本文目的

本文目的在于，搞懂网站搬家的概念和真正学会去实际操作网站搬家。


第 1 章 网站搬家之前要了解的概念和要做的事情

目录

1.1. 网站搬家之前需要了解的概念
1.2. 网站搬家之前要做的事情

1.1. 网站搬家之前需要了解的概念

搬家之前，有很多基本概念需要了解的。

包括，所谓的网站搬家，此处指的是，从一个虚拟主机，换到另外一个虚拟主机。

不懂的可参考：

【整理】什么是 wordpress博客搬家/wordpress搬家/博客搬家

以及一些背景知识：

【整理】关于TTL的单位


1.2. 网站搬家之前要做的事情

网站搬家之前，最好还是本地先测试一把，看看是否正常。如果正常了，再继续去搬家。可参考：

【记录】在wordpress完整的文件都导出到本地后，本地测试在线导出的wordpress是否正常工作

【记录】在本地测试wordpress已成功后去实现在线的wordpress网站搬家(换主机)

搬家之前，当然先要将旧空间里面的内容导出来。

方式有很多种。

有的虚拟空间商，提供工具帮你搬家，则可以利用。比如：

【整理】利用hawk的cpanel中的R1Soft Restore Backups实现网站备份


第 2 章 真正去操作网站搬家

目录

2.1. 网站搬家的详细步骤
2.1.1. 步骤1：创建邮件账户
2.1.2. 步骤2：创建ftp账户
2.1.3. 步骤3：上传文件
2.1.4. 步骤4：创建数据库和用户
2.1.5. 步骤5：修改wordpress的配置
2.1.6. 步骤6：验证主页地址访问是否正常
2.1.7. 步骤7：更新DNS
2.2. 网站搬家期间常见的错误及解决办法
2.2.1. 您可能正在上传很大的文件，请参考文档来寻找解决办法
2.2.2. DROP TABLE IF EXISTS `wp_commentmeta`
2.2.3. 访问主页出错：403 Permission Denied
2.2.4. 建立数据库连接时出错
2.2.5. 访问主页出现404错误
2.2.6. GoDaddy的DNS Manager的Not hosted here

此处，是在了解了网站搬家之前要知道的概念和做好了准备工作后，开始真正去操作，网站搬家。

[提示] 相关旧帖

【记录】把crifan.com的虚拟主机从HostMonster换到BlueHost的过程

【记录】在本地测试wordpress已成功后去实现在线的wordpress网站搬家(换主机)

2.1. 网站搬家的详细步骤

2.1.1. 步骤1：创建邮件账户

【记录】网站搬家之在新虚拟主机hawk的cpanel中新建邮件账户并尝试实现邮件备份

【记录】网站搬家之去新空间hawk的cpanel中创建对应的邮件账号

2.1.2. 步骤2：创建ftp账户

【记录】网站搬家之在新空间hawk的cpanel中创建ftp账户和确认压缩格式支持的类型

2.1.3. 步骤3：上传文件

【记录】网站搬家之通过ftp上传wordpress文件到新的虚拟空间hawk中

2.1.4. 步骤4：创建数据库和用户

【记录】网站搬家之在新空间hawk的cpanel的phpMyAdmin中创建对应的数据库以及用户

2.1.5. 步骤5：修改wordpress的配置

【记录】网站搬家之在新空间hawk的cpanel的文件管理器中修改wordpress的配置

2.1.6. 步骤6：验证主页地址访问是否正常

【记录】网站搬家之先去新空间hawk中验证一下wordpress主页是否可以正常显示

2.1.7. 步骤7：更新DNS

【记录】网站搬家之去godaddy中更新DNS配置使得域名解析为当前新空间的IP


2.2. 网站搬家期间常见的错误及解决办法

网站搬家期间，可能出现的一些常见错误和解决办法：

2.2.1. 您可能正在上传很大的文件，请参考文档来寻找解决办法

【已解决】phpMyAdmin中导入mysql数据库文件时出错：您可能正在上传很大的文件，请参考文档来寻找解决办法

2.2.2. DROP TABLE IF EXISTS `wp_commentmeta`

【已解决】phpMyAdmin导入Wordpress的MySQL数据库出错：表的结构 `wp_commentmeta`，DROP TABLE IF EXISTS `wp_commentmeta`

2.2.3. 访问主页出错：403 Permission Denied

【已解决】wordpress网站搬家期间，访问临时主页地址出现错误：403 Permission Denied，You do not have permission for this request

2.2.4. 建立数据库连接时出错

【已解决】wordpress网站搬家期间，访问临时主页地址出现错误：建立数据库连接时出错

2.2.5. 访问主页出现404错误

【已解决】wordpress网站搬家期间，访问临时主页地址出现404错误

2.2.6. GoDaddy的DNS Manager的Not hosted here

【已解决】GoDaddy的DNS Manager的Not hosted here的问题 + 到Hostmonster中修改A Record


第 3 章 网站搬家之后需要做的事情

网站搬家之后，还有很多事情需要做：

【记录】网站搬家完成后需要折腾的一些事情


参考书目

[1] 【记录】在本地测试wordpress已成功后去实现在线的wordpress网站搬家(换主机)