【记录】将当前的ANTLRWorks 1.4.3,升级到ANTLRWorks 1.5.rc1,实际上是ANTLRWorks 1.5.rc2

1.本来之前就是过了antlrworks 1.5,不能用,结果换用antlrworks 1.4.3的:

【记录】尝试使用ANTLRWorks 1.5开发

2.正在用antlrworks 1.4.3呢,结果跳出对话框,让我升级到最新版本的antlrworks 1.5rc1:

ask update to version 1.5rc1 with ANTLR 3.5rc1

然后就点击download了,结果还出错:

cannot download update

很明显,上述地址是打不开了。

3.而实际上,自己知道对应的地址,所以专门去看了看,很搞笑的是,没有找到1.5rc1,但是却找到了1.5rc2了:

actually found antlworks 1.5rc2 jar

4.所以下载下来:

antlrworks-1.5rc2.jar

然后去试试。

当前包含的版本信息为:

antlrworks 1.5rc2 versions

测试结果很不错,也是可以正常使用的:

Run->Debug后,可以正常调试的:

1.5rc2 can debug normally

 

【总结】

对于antlrworks来说,从最早的1.2的系列的到最新的1.5rc2,就只有1.5,无法正常调试,其他版本,均可正常调试。

那么以后就可以继续使用最新的,针对于antlr v3系列的 1.5rc2版本的antlrworks了,其内部集成了antlr 3.5-rc-2。



发表评论

电子邮件地址不会被公开。 必填项已用*标注

无觅相关文章插件,快速提升流量