最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【已解决】Ubuntu下去配置crosstool-ng时出现:configure: error: could not find GNU libtool >= 1.5.26

Ubuntu crifan 7237浏览 0评论

【问题】

折腾:

【记录】在Ubuntu下用crosstool-ng编译xscale的交叉工具链

期间出现:

crifan@ubuntu:~/develop/crosstool-ng/crosstool-ng-1.18.0$ ./configure --prefix=/opt/crosstool-ng
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking whether sed understands -r -i -e... yes
checking whether ln -s works... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for ranlib... ranlib
checking for objcopy... objcopy
checking for absolute path to objcopy... /usr/bin/objcopy
checking for objdump... objdump
checking for absolute path to objdump... /usr/bin/objdump
checking for readelf... readelf
checking for absolute path to readelf... /usr/bin/readelf
checking for bison... bison
checking for flex... flex
checking for gperf... gperf
checking for makeinfo... makeinfo
checking for cut... cut
checking for stat... stat
checking for readlink... readlink
checking for wget... wget
checking for tar... tar
checking for gzip... gzip
checking for bzip2... bzip2
checking for patch... /usr/bin/patch
checking for bash >= 3.1... /bin/bash
checking for GNU awk... /usr/bin/awk
checking for GNU make >= 3.80... /usr/bin/make
checking whether /usr/bin/make sets $(MAKE)... yes
checking for GNU libtool >= 1.5.26... no
configure: error: could not find GNU libtool >= 1.5.26
crifan@ubuntu:~/develop/crosstool-ng/crosstool-ng-1.18.0$ 

即:

configure: error: could not find GNU libtool >= 1.5.26

【折腾过程】

1.很明显,是libtool的版本太低。

2.所以,想办法,在Ubuntu下,升级libtool

3.找了半天,关于如何Ubuntu下升级某个软件,结果还是用install而搞定:

crifan@ubuntu:~/develop/crosstool-ng/crosstool-ng-1.18.0$ sudo apt-get install libtool
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  autotools-dev libltdl-dev
Suggested packages:
  libtool-doc autoconf automaken gfortran fortran95-compiler gcj
The following NEW packages will be installed:
  autotools-dev libltdl-dev libtool
0 upgraded, 3 newly installed, 0 to remove and 202 not upgraded.
Need to get 549 kB of archives.
After this operation, 2,553 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://mirrors.163.com/ubuntu/ raring/main autotools-dev all 20120608.1 [42.9 kB]
Get:2 http://mirrors.163.com/ubuntu/ raring/main libltdl-dev i386 2.4.2-1.2ubuntu1 [203 kB]
Get:3 http://mirrors.163.com/ubuntu/ raring/main libtool i386 2.4.2-1.2ubuntu1 [303 kB]
Fetched 549 kB in 4s (127 kB/s)
Selecting previously unselected package autotools-dev.
(Reading database ... 157196 files and directories currently installed.)
Unpacking autotools-dev (from .../autotools-dev_20120608.1_all.deb) ...
Selecting previously unselected package libltdl-dev:i386.
Unpacking libltdl-dev:i386 (from .../libltdl-dev_2.4.2-1.2ubuntu1_i386.deb) ...
Selecting previously unselected package libtool.
Unpacking libtool (from .../libtool_2.4.2-1.2ubuntu1_i386.deb) ...
Processing triggers for man-db ...
Setting up autotools-dev (20120608.1) ...
Setting up libltdl-dev:i386 (2.4.2-1.2ubuntu1) ...
Setting up libtool (2.4.2-1.2ubuntu1) ...
crifan@ubuntu:~/develop/crosstool-ng/crosstool-ng-1.18.0$ 

4.再去configure试试,即可解决此问题:

crifan@ubuntu:~/develop/crosstool-ng/crosstool-ng-1.18.0$ ./configure --prefix=/opt/crosstool-ng
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking whether sed understands -r -i -e... yes
checking whether ln -s works... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for ranlib... ranlib
checking for objcopy... objcopy
checking for absolute path to objcopy... /usr/bin/objcopy
checking for objdump... objdump
checking for absolute path to objdump... /usr/bin/objdump
checking for readelf... readelf
checking for absolute path to readelf... /usr/bin/readelf
checking for bison... bison
checking for flex... flex
checking for gperf... gperf
checking for makeinfo... makeinfo
checking for cut... cut
checking for stat... stat
checking for readlink... readlink
checking for wget... wget
checking for tar... tar
checking for gzip... gzip
checking for bzip2... bzip2
checking for patch... /usr/bin/patch
checking for bash >= 3.1... /bin/bash
checking for GNU awk... /usr/bin/awk
checking for GNU make >= 3.80... /usr/bin/make
checking whether /usr/bin/make sets $(MAKE)... yes
checking for GNU libtool >= 1.5.26... /usr/bin/libtool
checking for GNU libtoolize >= 1.5.26... /usr/bin/libtoolize

 

【总结】

对于出现:

configure: error: could not find GNU libtool >= 1.5.26

时,解决办法是:

不是去升级libtool,而是直接安装libtool即可:

sudo apt-get install libtool

转载请注明:在路上 » 【已解决】Ubuntu下去配置crosstool-ng时出现:configure: error: could not find GNU libtool >= 1.5.26

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

网友最新评论 (5)

  1. 我现在的libtool是最新版本的,还是报这个错
    小电工2年前 (2018-09-28)回复
  2. sudo apt install libtool-bin
    harper3年前 (2017-02-25)回复
  3. 已经安装了最新版本libtool还是提示这个configure: error: could not find GNU libtool >= 1.5.26是什么原因
    外设4年前 (2016-11-06)回复
    • 你怎么解决的最后_ 希望回复626845072@qq.com
      jinyang05083年前 (2017-07-07)回复
      • apt-get install libtool-bin
        weiyy3年前 (2017-08-28)回复
571 queries in 0.337 seconds, using 19.38MB memory