最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【记录】Mac中升级和使用新版Trojan-QT5以方便科学上网

Mac crifan 128浏览 0评论
折腾:
【已解决】Mac中用Trojan的客户端Trojan-QT5实现科学上网
后,后来看到有新版本,所以去升级。毕竟之前旧版本,不好用。而且还不稳定。
所以希望新版好用和稳定。
【20200224】
mac客户端已有新版本 0.0.4:
Trojan-Qt5-macOS-0.0.4.dmg
抽空更新试试,看看是否更稳定以及是否支持自动模式(而不是 只能全局)
Trojan-QT5 Mac 客户端(点击下载)
本文导入配置文件仅适用于 V0.04a 客户端(帮助 > 关于 查看客户端版本号)
由于部分客户端版本存在配置互不兼容的情况,建议更换版本时请删除之前的版本重新进行配置
目前客户端流量统计功能无法正常工作,显示用量 0 是正常的
教程对应的服务版本为: Lite 服务
请注意目前配置文件为 V0.0.4a 版本适配,低版本客户端请更新至 V0.0.4a
拷贝到 应用程序:
Version 0.0.4a
Using trojan 1.14.1, Privoxy 3.0.28
Boost 1_71, OpenSSL 1.1.1d 10 Sep 2019
LibQREncode 4.0.2
【MacOS】【推荐】 Trojan-QT5 设置方法 – 帮助中心 – Shadowsocks.com
https://portal.shadowsocks.nl/knowledgebase/162/
可以上网了:
【后记2】
又看到有新版,所以去升级:
估计要开启代理,才能下载更新
通过 帮助找到项目Github的主页
TheWanderingCoel/Trojan-Qt5: A cross-platform trojan GUI client based on Shadowsocks-qt
去下载
Releases · TheWanderingCoel/Trojan-Qt5
结果最新版本是0.0.4a
Trojan-QT5 v2.0
Trojan-QT5 2.0
Trojan-Qt5/README_CN.md at master · TheWanderingCoel/Trojan-Qt5
Shadowsocks – Clients
那再去
Trojan-QT5 Mac 客户端(点击下载)
看看是否有2.0新版
结果还是之前的:0.0.4a版
所以基本上证明:此处的2.0版本,是假的,不存在的。
等以后有新版本,再说。
目前只能用0.0.4a
使用0.0.4a期间,结果也有问题:
偶尔连接几次后,结果再也无法连接 找不到 connected的节点,再去连接其他节点,也无法连接了
折腾:
【已解决】Mac中购买和试用V2Ray科学上网
期间,看到:
-》基本上推断是:当前系统底层线程或端口还在被Trojan占用了
所以:最好重启,这样或许能排除Trojan的影响
所以去重启Mac
重启后,问题依旧:
连接后,还是Disconnected。放弃。
期间后来发现是端口问题:
【已解决】启动V2RayU提示:http error listen tcp 127.0.0.1:1087 bind address already in use
看来要去打开Trojan,换端口
换了端口,为之前默认的8081后
结果就可以正常启动和连接了:
说明还是:不够人性化。没提示具体错误原因。
20200308
后记测试,此处
0.0.4a的Trojan-QT5
的http代理,是没用的:

转载请注明:在路上 » 【记录】Mac中升级和使用新版Trojan-QT5以方便科学上网

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
20 queries in 0.095 seconds, using 9.31MB memory