最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【已解决】Xcode出错:Swift Language Version SWIFT_VERSION is required to be configured correctly for targets which use Swift

Xcode crifan 2950浏览 0评论

折腾:

【部分解决】Xcode的CPU占用率长期超过100%+建立索引和编译极其慢

期间,结果打开了BuildTimeAnalyzer-for-Xcode项目,去build编译,结果出错:

<code>Check dependencies

“Swift Language Version” (SWIFT_VERSION) is required to be configured correctly for targets which use Swift. Use the [Edit &gt; Convert &gt; To Current Swift Syntax…] menu to choose a Swift version or use the Build Settings editor to configure the build setting directly.
</code>

然后更无语的是:

从:

Release v0.0.0-Plugin-for-Xcode7 · RobertGummesson/BuildTimeAnalyzer-for-Xcode

发现说是:

“An Xcode plug-in for Xcode 7.

NOTE: Starting with Xcode 8, plug-ins are no longer supported.“

而我这里是Xcode 8,无法使用该插件。。。

先不管,去试试:

Swift Language Version” (SWIFT_VERSION) is required to be configured correctly for targets which use Swift

ios – “Swift Language Version” (SWIFT_VERSION) is required to be configured correctly for targets which use Swift – Stack Overflow

然后去:

结果根据没法转换:

看到Swift Language Version既然是Swift 4.0(unsupported)

所以去换成swift 3:

结果一堆的语法错误:

算了,放弃吧。

即使花时间改掉这些错误,估计也未必能用,因为作者说了只是针对于Xcode 7的插件的。

【总结】

此处的Xcode中swift版本不匹配,所以报错。

解决办法:

此处是去Build Setting中,把

Swift Language Version

把Swift 4.0(unsupported)改为此处的Swift 3,即可。

只不过,由于代码问题,有很多语法错误,需要额外时间去修复,就不是这个问题了。

转载请注明:在路上 » 【已解决】Xcode出错:Swift Language Version SWIFT_VERSION is required to be configured correctly for targets which use Swift

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
56 queries in 0.092 seconds, using 18.31MB memory