最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

[已解决]CentOS中查看某个包的依赖

CentOS crifan 1674浏览 0评论

折腾:

[记录]CentOS 6中Python从2.6升级到2.7

期间,需要去了解:

yum,在update后到了新版本:

yum-3.2.29-73.el6.centos.noarch

想要去看看,是否还是像别人说的,依赖于python 2.6

(python 2.7就不能用?) 

搜:

centos 查看包 依赖

参考:

centos下查看软件依赖关系 – 夜空

“yum命令详解

yum check-update 检查可更新的所有软件包

yum update 下载更新系统已安装的所有软件包

yum upgrade 大规模的版本升级,与yum update不同的是,连旧的淘汰的包也升级

yum install 安装新软件包

yum update 更新指定的软件包

yum remove 卸载指定的软件包

yum groupinstall 安装指定软件组中的软件包

yum groupupdate 更新指定软件组中的软件包

yum groupremove 卸载指定软件组中的软件包

yum grouplist 查看系统中已经安装的和可用的软件组

yum list 列出资源库中所有可以安装或更新以及已经安装的rpm包

yum list 列出资源库中与正则表达式匹配的可以安装或更新以及已经安装的rpm包

yum list available 列出资源库中所有可以安装的rpm包

yum list available 列出资源库中与正则表达式匹配的所有可以安装的rpm包

yum list updates 列出资源库中所有可以更新的rpm包

yum list updates 列出资源库中与正则表达式匹配的所有可以更新的rpm包

yum list installed 列出资源库中所有已经安装的rpm包

yum list installed 列出资源库中与正则表达式匹配的所有已经安装的rpm包

yum list extras 列出已经安装的但是不包含在资源库中的rpm包

yum list extras 列出与正则表达式匹配的已经安装的但是不包含在资源库中的rpm包

yum list recent 列出最近被添加到资源库中的软件包

yum search 检测所有可用的软件的名称、描述、概述和已列出的维护者,查找与正则表达式匹配的值

yum provides 检测软件包中包含的文件以及软件提供的功能,查找与正则表达式匹配的值

yum clean headers 清除缓存中的rpm头文件

yum clean packages 清除缓存中rpm包文件

yum clean all 清除缓存中的rpm头文件和包文件

yum deplist 显示软件包的依赖信息

 html yum deplist –help
Loaded plugins: security
Usage: yum [options] COMMAND
List of Commands:
check          Check for problems in the rpmdb
check-update   Check for available package updates
clean          Remove cached data
deplist        List a package’s dependencies
distribution-synchronization Synchronize installed packages to the latest available versions
downgrade      downgrade a package
erase          Remove a package or packages from your system
groupinfo      Display details about a package group
groupinstall   Install the packages in a group on your system
grouplist      List available package groups
groupremove    Remove the packages in a group from your system
help           Display a helpful usage message
history        Display, or use, the transaction history
info           Display details about a package or group of packages
install        Install a package or packages on your system
list           List a package or groups of packages
load-transaction load a saved transaction from filename
makecache      Generate the metadata cache
provides       Find what package provides the given value
reinstall      reinstall a package
repolist       Display the configured software repositories
resolvedep     Determine which package provides the given dependency
search         Search package details for the given string
shell          Run an interactive yum shell
update         Update a package or packages on your system
update-minimal Works like update, but goes to the ‘newest’ package match which fixes a problem that affects your system
updateinfo     Acts on repository update information
upgrade        Update packages taking obsoletes into account
version        Display a version for the machine and/or available repos.
Options:
  -h, –help            show this help message and exit
  -t, –tolerant        be tolerant of errors
  -C, –cacheonly       run entirely from system cache, don’t update cache
  -c [config file], –config=[config file]
                        config file location
  -R [minutes], –randomwait=[minutes]
                        maximum command wait time
  -d [debug level], –debuglevel=[debug level]
                        debugging output level
  –showduplicates      show duplicates, in repos, in list/search commands
  -e [error level], –errorlevel=[error level]
                        error output level
  –rpmverbosity=[debug level name]
                        debugging output level for rpm
  -q, –quiet           quiet operation
  -v, –verbose         verbose operation
  -y, –assumeyes       answer yes for all questions
  –assumeno            answer no for all questions
  –version             show Yum version and exit
  –installroot=[path]  set install root
  –enablerepo=[repo]   enable one or more repositories (wildcards allowed)
  –disablerepo=[repo]  disable one or more repositories (wildcards allowed)
  -x [package], –exclude=[package]
                        exclude package(s) by name or glob
  –disableexcludes=[repo]
                        disable exclude from main, for a repo or for
                        everything
  –obsoletes           enable obsoletes processing during updates
  –noplugins           disable Yum plugins
  –nogpgcheck          disable gpg signature checking
  –disableplugin=[plugin]
                        disable plugins by name
  –enableplugin=[plugin]
                        enable plugins by name
  –skip-broken         skip packages with depsolving problems
  –color=COLOR         control whether color is used
  –releasever=RELEASEVER
                        set value of $releasever in yum config and repo files
  –downloadonly        don’t update, just download
  –downloaddir=DLDIR   specifies an alternate directory to store packages
  –setopt=SETOPTS      set arbitrary config and repo options
  Plugin Options:
    –security          Include security relevant packages
    –bugfixes          Include bugfix relevant packages
    –cve=CVE           Include packages needed to fix the given CVE
    –bz=BZ             Include packages needed to fix the given BZ
    –sec-severity=SEVERITY
                        Include security relevant packages, of this severity
    –advisory=ADVISORY
                        Include packages needed to fix the given advisory
 html
 html yum deplist yum   
Loaded plugins: security
Finding dependencies: 
package: yum.noarch 3.2.29-73.el6.centos
  dependency: yum-plugin-fastestmirror
   provider: yum-plugin-fastestmirror.noarch 1.1.30-37.el6
  dependency: python-urlgrabber >= 3.9.1-10
   provider: python-urlgrabber.noarch 3.9.1-11.el6
  dependency: rpm >= 4.4.2
   provider: rpm.x86_64 4.8.0-55.el6
  dependency: pygpgme
   provider: pygpgme.x86_64 0.1-18.20090824bzr68.el6
  dependency: python >= 2.4
   provider: python.x86_64 2.6.6-64.el6
  dependency: rpm-python
   provider: rpm-python.x86_64 4.8.0-55.el6
  dependency: /usr/bin/python
   provider: python.x86_64 2.6.6-64.el6
  dependency: python(abi) = 2.6
   provider: python.x86_64 2.6.6-64.el6
  dependency: yum-metadata-parser >= 1.1.0
   provider: yum-metadata-parser.x86_64 1.1.2-16.el6
  dependency: python-sqlite
   provider: python.x86_64 2.6.6-64.el6
  dependency: python-iniparse
   provider: python-iniparse.noarch 0.3.1-2.1.el6
package: yum.noarch 3.2.29-75.el6.centos
  dependency: yum-plugin-fastestmirror
   provider: yum-plugin-fastestmirror.noarch 1.1.30-37.el6
  dependency: python-urlgrabber >= 3.9.1-10
   provider: python-urlgrabber.noarch 3.9.1-11.el6
  dependency: rpm >= 4.4.2
   provider: rpm.x86_64 4.8.0-55.el6
  dependency: pygpgme
   provider: pygpgme.x86_64 0.1-18.20090824bzr68.el6
  dependency: python >= 2.4
   provider: python.x86_64 2.6.6-64.el6
  dependency: rpm-python
   provider: rpm-python.x86_64 4.8.0-55.el6
  dependency: /usr/bin/python
   provider: python.x86_64 2.6.6-64.el6
  dependency: python(abi) = 2.6
   provider: python.x86_64 2.6.6-64.el6
  dependency: yum-metadata-parser >= 1.1.0
   provider: yum-metadata-parser.x86_64 1.1.2-16.el6
  dependency: python-sqlite
   provider: python.x86_64 2.6.6-64.el6
  dependency: python-iniparse
   provider: python-iniparse.noarch 0.3.1-2.1.el6

其中可见:

python >= 2.4

python(abi) = 2.6

-》由此可见:

的确是,此处的yum,虽然升级到了最新的版本

3.2.29

但是,还是依赖于Python 2.6的

Python 2.7的话,虽然符合python >= 2.4,但是abi是2.6不一样,所以也是用不了的。。。

【总结】

用yum的话,则是:

<code>yum deplist xxx
</code>

可以查看xxx的依赖。

转载请注明:在路上 » [已解决]CentOS中查看某个包的依赖

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
56 queries in 0.084 seconds, using 18.63MB memory