最新消息:20190529 VPS服务器已从腾讯云香港换为Vultr新加坡,主题仍用朋友推荐的大前端D8

【已解决】ERROR UglifyJs DefaultsError: `screw_ie8` is not a supported option

JS crifan 992浏览 0评论

折腾:

【已解决】npm run build出错:validateOptions.js throw new _ValidationError2.default(ajv.errors, name)

之后,又有其他参数不支持

所以去搜搜,

DefaultsError screw_ie8 is not a supported option

没有太搞懂,到底之前的screw_ie8,是想要支持ie8还是不支持ie8

Allow passing screw_ie8 option to uglify-js · Issue #2325 · webpack/webpack

UglifyJS 3.0 changes (breaking changes only) · Issue #1411 · mishoo/UglifyJS2

貌似有人建议把

screw_ie8

改为:–support-ie8

-》就是screw_ie8意思是想要支持ie8了?

Add support for UglifyJS `–screw-ie8` option · Issue #40 · gruntjs/grunt-contrib-uglify

What does screw-ie8 break? · Issue #1204 · mishoo/UglifyJS2

Cannot build with uglifyjs, changing to uglify-js works · Issue #784 · swimlane/ngx-datatable

screw_ie8 in Node.js 6.3.1 · Issue #1246 · mishoo/UglifyJS2

算了,就算是:

screw_ie8就是支持ie8的意思

所以参考新文档:

webpack-contrib/uglifyjs-webpack-plugin: UglifyJS plugin for webpack

去换为ie8的参数即可。

// screw_ie8: true,

ie8 : true,

结果至少这个错误消失了。

【总结】

把之前

new webpack.optimize.UglifyJsPlugin

screw_ie8: true

改为:

uglifyjs-webpack-plugin的

ie8 : true

即可。

转载请注明:在路上 » 【已解决】ERROR UglifyJs DefaultsError: `screw_ie8` is not a supported option

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
64 queries in 0.083 seconds, using 18.80MB memory