最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【未解决】gitbook中安装emoji表情插件

gitbook crifan 1204浏览 0评论

折腾:

【记录】给Gitbook添加更多配置和功能

期间,去添加gitbook的emoji的表情插件。

参考:

https://gitbook.zhangjikai.com/plugins.html#advanced-emoji

直接安装Advanced Emoji

➜  htttp_summary git:(master) gitbook install

info: installing 5 plugins using npm@3.9.2

info:

info: installing plugin “search-plus”

info: install plugin “search-plus” (*) from NPM with version 1.0.3

info: >> plugin “search-plus” installed with success

info:

info: installing plugin “disqus”

info: install plugin “disqus” (*) from NPM with version 0.1.0

info: >> plugin “disqus” installed with success

info:

info: installing plugin “prism”

info: install plugin “prism” (*) from NPM with version 2.3.0

info: >> plugin “prism” installed with success

info:

info: installing plugin “prism-themes”

info: install plugin “prism-themes” (*) from NPM with version 0.0.2

info: >> plugin “prism-themes” installed with success

info:

info: installing plugin “advanced-emoji”

info: install plugin “advanced-emoji” (*) from NPM with version 0.2.2

/Users/crifan/GitBook/Library/Import/htttp_summary

├─┬ gitbook-plugin-advanced-emoji@0.2.2

│ └── emojify.js@1.1.0

├── gitbook-plugin-disqus@0.1.0

├── gitbook-plugin-multipart@0.3.0

├── gitbook-plugin-numbered-headings@1.1.1

├── gitbook-plugin-prism@2.3.0

├── gitbook-plugin-prism-themes@0.0.2

└── gitbook-plugin-search-plus@1.0.3

info: >> plugin “advanced-emoji” installed with success

去参考:

https://www.webpagefx.com/tools/emoji-cheat-sheet/

去用两个试试。

gitbook editor中不支持:

去编译出来看看

“plugins”: [

    “advanced-emoji”

  ],

结果不起效果:

gitbook Advanced Emoji 无效

gitbook Advanced Emoji not work

Not working with unicode emoji? · Issue #4 · codeclou/gitbook-plugin-advanced-emoji

emojione/emojify.js: A Javascript module to convert Emoji keywords to images

去看html源码是否加入了对应的emoji的js

结果好像没有emoji的js,只有css

手动去试试:

npm install gitbook-plugin-advanced-emoji

<code>➜  htttp_summary git:(master) npm install gitbook-plugin-advanced-emoji
npm WARN saveError ENOENT: no such file or directory, open '/Users/crifan/GitBook/Library/Import/htttp_summary/package.json'
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN enoent ENOENT: no such file or directory, open '/Users/crifan/GitBook/Library/Import/htttp_summary/package.json'
npm WARN htttp_summary No description
npm WARN htttp_summary No repository field.
npm WARN htttp_summary No README data
npm WARN htttp_summary No license field.

+ gitbook-plugin-advanced-emoji@0.2.2
updated 1 package in 4.403s
</code>

显示updated,那就是之前已经安装了。

再去:

<code>➜  htttp_summary git:(master) ✗ gitbook serve . output/website
Live reload server started on port: 35729
Press CTRL+C to quit ...

info: 14 plugins are installed
info: 9 explicitly listed
info: loading plugin "search-plus"... OK
info: loading plugin "disqus"... OK
info: loading plugin "prism"... OK
info: loading plugin "prism-themes"... OK
info: loading plugin "advanced-emoji"... OK
info: loading plugin "livereload"... OK
info: loading plugin "sharing"... OK
info: loading plugin "fontsettings"... OK
info: loading plugin "theme-default"... OK
info: found 19 pages
info: found 26 asset files
warn: "options" property is deprecated, use config.get(key) instead
warn: "options.generator" property is deprecated, use "output.name" instead
info: &gt;&gt; generation finished with success in 4.0s !

Starting server ...
Serving book on http://localhost:4000
</code>

结果:

问题依旧。

算了,暂时不去弄了。反正也不是那么想要。

转载请注明:在路上 » 【未解决】gitbook中安装emoji表情插件

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
54 queries in 0.088 seconds, using 18.25MB memory