最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

[已解决]上传app到AppStore失败:ERROR ITMS-90101 This bundle does not support one or more of the devices supported by the previous app version

iOS crifan 3314浏览 0评论

折腾:

[记录]通过iTunes Connect上架新版本iOS app到App Store上

期间,遇到:

ERROR ITMS-90101: "This bundle does not support one or more of the devices supported by the previous app version. Your app update must continue to support all devices previously supported. You declare supported devices in Xcode with the Targeted Device Family build setting. Refer to QA1623 for additional information: https://developer.apple.com/library/ios/#qa/qa1623/_index.html";

ERROR ITMS-90101: "This bundle does not support one or more of the devices supported by the previous app version. Your app update must continue to support all devices previously supported. You declare supported devices in Xcode with the Targeted Device Family build setting. Refer to QA1623 for additional information: https://developer.apple.com/library/ios/#qa/qa1623/_index.html";

急求助:iOS在线应用升级打包后上传报错-AppCan交流社区 – Powered by Discuz!

Technical Q&A QA1623: Why am I getting device support errors when uploading my app?

Running into multiple errors regarding icon (iOS)

Change targeted device family on existing iPhone/iPad app – Stack Overflow

好像找到原因了:

之前的Deployment Info中的Devices是Universal

现在不知道,被谁改为了iPhone

所以去改回来:

即可:

估计之后再去重新archive打包,再去发布,就可以了。

重新上传:

然后就可以上传成功了。

【总结】

此处打包上架提示出错:

ERROR ITMS-90101 This bundle does not support one or more of the devices supported by the previous app version

的原因是:

之前打包上架的都是Universal,即支持iPhone又支持iPad,但是此处不知何故只被设置了支持iPhone,所以去:

项目配置-》Deployment info-〉Devices-》设置Universal

即可。

转载请注明:在路上 » [已解决]上传app到AppStore失败:ERROR ITMS-90101 This bundle does not support one or more of the devices supported by the previous app version

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
60 queries in 0.119 seconds, using 18.91MB memory