最新消息:VPS服务器又从fzhost.net换回Linode了,主题仍用朋友推荐的大前端D8

Jikes已安装,编译生成kaffe时,出问题了

默认分类 crifan 436浏览 0评论

过程:

将从http://www.kaffe.org/ftp/pub/kaffe/v1.1.x-development/

下载下来的kaffe-1.1.6.tar

FlashFXP上传到server上的home/ustc/paul下之后

tar xzvf kaffe-1.1.6.tar.gz 解压之后

进入文件夹kaffe-1.1.6

按照上面要求,运行./configure之后,出错:

。。。。。

checking PANGOFT2_CFLAGS… -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  

checking PANGOFT2_LIBS… -Wl,–export-dynamic -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0  

checking for gtk+-2.0 >= 2.4 gthread-2.0 >= 2.2 gdk-pixbuf-2.0… Requested ‘gtk+-2.0 >= 2.4’ but version of GTK+ is 2.2.1

configure: error: Library requirements (gtk+-2.0 >= 2.4 gthread-2.0 >= 2.2 gdk-pixbuf-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

到网上看了些资料:

http://topic.csdn.net/t/20050114/16/3726498.html

然后重新输入:

./configure –prefix=/usr

后,运行还是出现同样的错误。

又试了试:

./configure –prefix=/usr

也还是不行。

今天就到这,脑子崩溃了,明天继续。

转载请注明:在路上 » Jikes已安装,编译生成kaffe时,出问题了

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
14 queries in 0.217 seconds, using 10.15MB memory