最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【已解决】pip3 install出错:Could not install packages due to an EnvironmentError Errno 13 Permission denied /usr/local/man

Mac crifan 2857浏览 0评论

Mac中,需要本地运行起来一个Django项目,结果:

  xxx git:(master) pip3 install -r requirements.txt

Collecting Django==2.0.6 (from -r requirements.txt (line 1))

  Downloading https://files.pythonhosted.org/packages/56/0e/afdacb47503b805f3ed213fe732bff05254c8befaa034bbada580be8a0ac/Django-2.0.6-py3-none-any.whl (7.1MB)

    100% |████████████████████████████████| 7.1MB 12kB/s

Collecting mysqlclient==1.3.12 (from -r requirements.txt (line 2))

Requirement already satisfied: pymongo==3.6.1 in /usr/local/lib/python3.6/site-packages (from -r requirements.txt (line 3)) (3.6.1)

Collecting ipython==6.4.0 (from -r requirements.txt (line 4))

  。。。

  Running setup.py bdist_wheel for itypes … done

  Stored in directory: /Users/crifan/Library/Caches/pip/wheels/7b/52/af/4e27324812e7ab7bbbc30f748d317f3739477562325cb4c723

  Running setup.py bdist_wheel for coreschema … done

  Stored in directory: /Users/crifan/Library/Caches/pip/wheels/10/7b/ba/04fcd6b33e6123ca11a5f5ab56decb1a2d87ced028377a1377

Successfully built python-docx pytest-sugar simplegeneric backcall openapi-codec simplejson termcolor itypes coreschema

Installing collected packages: pytz, Django, mysqlclient, appnope, parso, jedi, simplegeneric, decorator, ptyprocess, pexpect, ipython-genutils, traitlets, wcwidth, prompt-toolkit, backcall, pickleshare, pygments, ipython, Werkzeug, django-cors-headers, djangorestframework, PyJWT, djangorestframework-jwt, uritemplate, chardet, urllib3, idna, requests, itypes, MarkupSafe, jinja2, coreschema, coreapi, openapi-codec, simplejson, django-rest-swagger, click, python-dotenv, typing, django-extensions, gunicorn, lxml, python-docx, more-itertools, atomicwrites, py, pluggy, attrs, pytest, nose, text-unidecode, python-dateutil, Faker, factory-boy, pytest-django, termcolor, pytest-sugar, raven

Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: ‘/usr/local/man’

Consider using the `–user` option or check the permissions.

或许是直接加上:

–user

就可以了?

mac pip3 install Could not install packages due to an EnvironmentError Errno 13 Permission denied /usr/local/man

[Errno 13] Permission denied How i solve this problem · Issue #236 · googlesamples/assistant-sdk-python

  • 用虚拟环境

    • 就有权限了

  • 加上参数–user

  • 用sudo

还是加上–user试试,结果就可以了:

pip3 install –user  -r requirements.txt

.2.0->-r requirements.txt (line 9)) (2.10)

Requirement already satisfied: MarkupSafe>=0.23 in /usr/local/lib/python3.6/site-packages (from jinja2->coreschema->coreapi>=2.3.0->django-rest-swagger==2.2.0->-r requirements.txt (line 9)) (1.0)

Installing collected packages: text-unidecode, python-dateutil, Faker, factory-boy, pytest-django, termcolor, pytest-sugar, raven

Successfully installed Faker-0.8.15 factory-boy-2.11.1 pytest-django-3.2.1 pytest-sugar-0.9.1 python-dateutil-2.7.3 raven-6.9.0 termcolor-1.1.0 text-unidecode-1.2

转载请注明:在路上 » 【已解决】pip3 install出错:Could not install packages due to an EnvironmentError Errno 13 Permission denied /usr/local/man

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
58 queries in 0.097 seconds, using 18.87MB memory