最新消息:20190529 VPS服务器已从腾讯云香港换为Vultr新加坡,主题仍用朋友推荐的大前端D8

【已解决】Python中如何安装某个特定的版本的包

Python crifan 2120浏览 0评论

折腾:

【已解决】Flask的虚拟环境中把gunicorn的版本从19降低为18

期间,需要了解:

pip 安装指定版本

参考:

pip 安装特定版本的 Python 包

pip install -v pycrypto==2.3

pip指定安装包版本 – walker的流水账 – 51CTO技术博客

版本范围符号:==、>=、<=、>、<。

pip install cchardet                    #不指定版本号,安装可用的最新版本

pip install "requests==2.7"            #指定版本号2.7

pip install "requests>2.0,<3.0"        #(2.0,3.0)之间的最新版本

优雅的使用Python之软件管理 – 吴秦 – 博客园

$ pip install SomePackage            # latest version

$ pip install SomePackage==1.0.4     # specific version

$ pip install ‘SomePackage>=1.0.4’     # minimum version

pip常用命令 | iblogc’s blog

【总结】

Python中安装指定版本的包,可以用pip,加上==xxx.xxx.xx即可。

同时,==,可以换为:

=,<=,>,<

用于指定版本的范围

借用上面的举例:

版本范围符号:==、>=、<=、>、<。
pip install cchardet                    #不指定版本号,安装可用的最新版本
pip install "requests==2.7"            #指定版本号2.7
pip install "requests>2.0,<3.0"        #(2.0,3.0)之间的最新版本

我此处用:

pip install gunicorn==18.0

即可安装指定的18.0版本的gunicorn。

转载请注明:在路上 » 【已解决】Python中如何安装某个特定的版本的包

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
62 queries in 0.094 seconds, using 18.72MB memory