最新消息:VPS服务器又从fzhost.net换回Linode了,主题仍用朋友推荐的大前端D8

【记录】将win7 x64下的cygwin的gcc从当前的4.7.3降级到4.5.3

Cygwin crifan 190浏览 0评论

【背景】

折腾:

【未解决】再次研究:Cygwin下编译Buildroot时在编译libtool-2.2.10时出错:configure: error: C compiler cannot create executables

期间,实在找不到根据原因和解决办法了。

只能尝试参考

gcc4.7.2 cc1 error while loading shared libraries

去把gcc换了。

从当前的4.7.3降级到4.5.3。

【折腾过程】

1.参考之前的:

【记录】Cygwin下把make从v3.82换成v3.81

去运行之前下载的,最新的那个setup.exe:

setup-x86_001.exe

2.然后一路安装,还是选163的x86的mirror

3.然后搜gcc,然后看到一堆的和gcc相关的库的版本,都是4.7.3.1

然后基本上都是双击那个原先的keep,知道变成4.5.3(或相关的4.5.2等)版本:

change all gcc from 4.7.3.1 to 4.5.3.3 - 1

change all gcc from 4.7.3.1 to 4.5.3.3 - 2

4.然后就可以继续去安装了:

installing for gcc from 4.7.3 to 4.5.3 version

5.最后终于安装完毕:

install cygwin gcc old version done

 

【总结】

此处,主要是,cygwin安装界面中,搜gcc

找到相关的东西后,点击keep直到变到旧版本的。即可。

转载请注明:在路上 » 【记录】将win7 x64下的cygwin的gcc从当前的4.7.3降级到4.5.3

与本文相关的文章

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
16 queries in 0.609 seconds, using 9.88MB memory