最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【未解决】XCode中把ArcGIS.framework换成用Cocoapods管理

Cocoapods crifan 995浏览 0评论

iOS项目中用到的库ArcGIS.framework:

是单独的200多MB的文件。

被之前iOS开发人员放到代码中了。很大。不合适。

想要换成用已有的Cocoapods去管理。

ArcGIS framework ios

10.2版本的:

Install and set up—ArcGIS Runtime SDK for iOS | ArcGIS for Developers

最新版本100.1.1的:

Install and set up—ArcGIS Runtime SDK for iOS | ArcGIS for Developers

pod ‘ArcGIS-Runtime-SDK-iOS’, ‘100.1.1’

ArcGIS framework ios release history

不同版本发布日志:

Release notes for 100.1.1—ArcGIS Runtime SDK for iOS | ArcGIS for Developers

Release notes for 100.0—ArcGIS Runtime SDK for iOS | ArcGIS for Developers

Release notes for 10.1.1—ArcGIS Runtime SDK for iOS | ArcGIS for Developers

ArcGIS Runtime SDK for iOS: Introduction

Migrate to version 100.x—ArcGIS Runtime SDK for iOS | ArcGIS for Developers

去修改podfile,加上:

pod ‘ArcGIS-Runtime-SDK-iOS’, ‘10.3’

然后去

pod install

结果:

➜  inquzhou_ios git:(master) ✗ pod install

Analyzing dependencies

[!] Unable to satisfy the following requirements:

– `ArcGIS-Runtime-SDK-iOS (= 10.3)` required by `Podfile`

None of your spec sources contain a spec satisfying the dependency: `ArcGIS-Runtime-SDK-iOS (= 10.3)`.

You have either:

* out-of-date source repos which you can update with `pod repo update` or with `pod install –repo-update`.

* mistyped the name or version.

* not added the source repo that hosts the Podspec to your Podfile.

Note: as of CocoaPods 1.0, `pod repo update` does not happen on `pod install` by default.

算了,换最新的100.1.1吧:

pod ‘ArcGIS-Runtime-SDK-iOS’, ‘100.1.1’

再去试试install

➜  inquzhou_ios git:(master) ✗ pod install

Analyzing dependencies

[!] Unable to satisfy the following requirements:

– `ArcGIS-Runtime-SDK-iOS (= 100.1.1)` required by `Podfile`

Specs satisfying the `ArcGIS-Runtime-SDK-iOS (= 100.1.1)` dependency were found, but they required a higher minimum deployment target.

所以去看看官网的安装和升级的介绍。

System requirements—ArcGIS Runtime SDK for iOS | ArcGIS for Developers

Device requirements for deployment

Applications built with this release of ArcGIS Runtime SDK for iOS can be deployed to iPhone, iPad, and iPod touch devices running any version of iOS 11, iOS 10, or iOS 9.

去改自己的target

从8.0改为9.0

问题依旧。

【未解决】Cocoapods去pod install版本10.2.5的ArcGIS-Runtime-SDK-iOS出错:curl 56 Recv failure: Connection reset by peer

转载请注明:在路上 » 【未解决】XCode中把ArcGIS.framework换成用Cocoapods管理

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
61 queries in 0.252 seconds, using 18.99MB memory