1.3.1. 安装Cygwin

关于什么是Cygwin和如何安装Cygwin,请参考:Cygwin

需要注意的是,安装时候,记得要选择以下几个库/模块:

  1. xsltproc

    用于将xml转换为HTML和FO等格式

  2. xsltproc所依赖的一些库

    xsltproc运行的话,需要依赖一些库,所以也要选上这些库。

    同时,后期的一些其他处理,比如编码转换等,也需要相关的像iconv等工具,所以要安装上这些工具,方便后期使用。

    • libxml2
    • zlib
    • libxslt
    • iconv
  3. [docbook-xsl]

    如前面第 1.2.3 节 “下载docbook-xsl-ns-1.77.1”中的解释,为了生成各种格式的文件,是需要对应的xsl配置文件的。

    其实这部分配置文件,新版本的cygwin中,也有了,所以可以选择安装,也可以不安装:

    • 安装的话,就是选择对应的模块docbook-xsl

      安装的理由是,cygwin自带的xsl,其实版本已经够新了,也基本足够用了。而且总类也很多,包括docbook-xsl,docbook-xsl-ns等等。

    • 不安装的理由是,可以自己去按照前面的第 1.2.3 节 “下载docbook-xsl-ns-1.77.1”一样去手动自己下载最新版本的,自己所需要的docbook-xsl。

      因为最新的版本,往往功能上更加全。

    所以,是否安装此docbook-xsl的话,可以根据自己的需要决定。

    个人更加倾向于后者,自己手动下载最新版本的。

安装完毕cygwin后,可以查看对应的这些工具的版本等信息:

[email protected] ~/develop/docbook/books/soft_dev_basic/src
$ which xsltproc.exe
/usr/bin/xsltproc.exe

[email protected] ~/develop/docbook/books/soft_dev_basic/src
$ xsltproc --version
Using libxml 20708, libxslt 10126 and libexslt 815
xsltproc was compiled against libxml 20708, libxslt 10126 and libexslt 815
libxslt 10126 was compiled against libxml 20708
libexslt 815 was compiled against libxml 20708