最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

install the vmware tool

VMWare crifan 1041浏览 0评论

install VMWare Tools:

tips:

Do not forget to install the VMware Tools package inside this virtual machine: wait until your guest operating system finishes booting, then choose VM > Install VMware Tools… and follow the instructions.

slect VM->Install VMware Tools,popup tips:

Installing the VMware Tools package will greatly enhance graphics and mouse performance in your virtual machine.

WARNING: You cannot install the VMware Tools package until the guest operating system is running. If your guest operating system is not running, choose Cancel and install the VMware Tools package later.

click Install:

but there is some problem on my vmware ,for the cdrom0 display confusing character rather than sth like the vmware-tool.tar.gz .

the reason is ,I have load a installation of Ubuntu cdrom onboot .so here reboot and reject it ,and choose the

The guest operating system has locked the CD-ROM door and is probably using the CD-ROM, which can prevent the guest from recognizing media changes. If possible, eject the CD-ROM from inside the guest before disconnecting.

Disconnect anyway (and override the lock)?

click ok ,then go into vmware ,but there is empty in the cdrom0 .

so reboot and unload the image in virtual cdrom:H in my notebook,then redo the install the vmware ,is OK. and finnally see the VMWaretools-5.5.1-19175.tar.gz

^_^.

then copy the tar file to another place, and untar it,install that .pl file .

then enter by default config ,but in the end ,can’t find the include file in /usr/src/linux

so google ,and in here find ,I should install the kernel-devel package,so do :

crifan@crifan-desktop:~$ sudo apt-file search kernel-devel
sudo: apt-file: command not found
crifan@crifan-desktop:~$ sudo apt-cache search kernel-devel
linux-kernel-devel – Linux kernel hacking dependencies
crifan@crifan-desktop:~$ sudo apt-get install linux-kernel-devel
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
curl debhelper gettext git-core gitk html2text intltool-debian
kernel-package kernel-wedge libcurl3 libdigest-sha1-perl liberror-perl
po-debconf tcl8.4 tk8.4
Suggested packages:
dh-make cvs gettext-doc git-arch git-cvs git-svn git-email git-daemon-run
git-gui gitweb cogito linux-source kernel-source libdb3-dev libncurses-dev
docbook-utils tclreadline
Recommended packages:
git-doc libmail-sendmail-perl libcompress-zlib-perl
The following NEW packages will be installed:
curl debhelper gettext git-core gitk html2text intltool-debian
kernel-package kernel-wedge libcurl3 libdigest-sha1-perl liberror-perl
linux-kernel-devel po-debconf tcl8.4 tk8.4
0 upgraded, 16 newly installed, 0 to remove and 191 not upgraded.
Need to get 9291kB of archives.
After unpacking 26.3MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://cn.archive.ubuntu.com gutsy/main libcurl3 7.16.4-2ubuntu1 [182kB]
Get:2 http://security.ubuntu.com gutsy-security/main linux-kernel-devel 2.6.22-14.52 [47.7kB]
Get:3 http://cn.archive.ubuntu.com gutsy/main curl 7.16.4-2ubuntu1 [175kB]
Get:4 http://cn.archive.ubuntu.com gutsy/main html2text 1.3.2a-3build1 [90.6kB]
Get:5 http://cn.archive.ubuntu.com gutsy/main gettext 0.16.1-2ubuntu3 [1552kB]
Get:6 http://cn.archive.ubuntu.com gutsy/main intltool-debian 0.35.0+20060710.1 [31.6kB]
Get:7 http://cn.archive.ubuntu.com gutsy/main po-debconf 1.0.9 [117kB]
Get:8 http://cn.archive.ubuntu.com gutsy/main debhelper 5.0.51ubuntu3 [526kB]
Get:9 http://cn.archive.ubuntu.com gutsy/main liberror-perl 0.15-8 [15.5kB]
Get:10 http://cn.archive.ubuntu.com gutsy/main libdigest-sha1-perl 2.11-2 [24.7kB]
Get:11 http://cn.archive.ubuntu.com gutsy/main git-core 1:1.5.2.5-2build1 [3631kB]
Get:12 http://cn.archive.ubuntu.com gutsy/main tcl8.4 8.4.15-1build1 [1169kB]
Get:13 http://cn.archive.ubuntu.com gutsy/main tk8.4 8.4.15-1ubuntu1 [1002kB]
Get:14 http://cn.archive.ubuntu.com gutsy/main gitk 1:1.5.2.5-2build1 [177kB]
Get:15 http://cn.archive.ubuntu.com gutsy/main kernel-package 11.001 [510kB]
Get:16 http://cn.archive.ubuntu.com gutsy/main kernel-wedge 2.29ubuntu2 [40.0kB]
Fetched 9291kB in 60s (155kB/s)
Selecting previously deselected package libcurl3.
(Reading database … 91876 files and directories currently installed.)
Unpacking libcurl3 (from …/libcurl3_7.16.4-2ubuntu1_i386.deb) …
Selecting previously deselected package curl.
Unpacking curl (from …/curl_7.16.4-2ubuntu1_i386.deb) …
Selecting previously deselected package html2text.
Unpacking html2text (from …/html2text_1.3.2a-3build1_i386.deb) …
Selecting previously deselected package gettext.
Unpacking gettext (from …/gettext_0.16.1-2ubuntu3_i386.deb) …
Selecting previously deselected package intltool-debian.
Unpacking intltool-debian (from …/intltool-debian_0.35.0+20060710.1_all.deb) …
Selecting previously deselected package po-debconf.
Unpacking po-debconf (from …/po-debconf_1.0.9_all.deb) …
Selecting previously deselected package debhelper.
Unpacking debhelper (from …/debhelper_5.0.51ubuntu3_all.deb) …
Selecting previously deselected package liberror-perl.
Unpacking liberror-perl (from …/liberror-perl_0.15-8_all.deb) …
Selecting previously deselected package libdigest-sha1-perl.
Unpacking libdigest-sha1-perl (from …/libdigest-sha1-perl_2.11-2_i386.deb) …
Selecting previously deselected package git-core.
Unpacking git-core (from …/git-core_1%3a1.5.2.5-2build1_i386.deb) …
Selecting previously deselected package tcl8.4.
Unpacking tcl8.4 (from …/tcl8.4_8.4.15-1build1_i386.deb) …
Selecting previously deselected package tk8.4.
Unpacking tk8.4 (from …/tk8.4_8.4.15-1ubuntu1_i386.deb) …
Selecting previously deselected package gitk.
Unpacking gitk (from …/gitk_1%3a1.5.2.5-2build1_all.deb) …
Selecting previously deselected package kernel-package.
Unpacking kernel-package (from …/kernel-package_11.001_all.deb) …
Selecting previously deselected package kernel-wedge.
Unpacking kernel-wedge (from …/kernel-wedge_2.29ubuntu2_all.deb) …
Selecting previously deselected package linux-kernel-devel.
Unpacking linux-kernel-devel (from …/linux-kernel-devel_2.6.22-14.52_all.deb) …
Setting up libcurl3 (7.16.4-2ubuntu1) …

Setting up curl (7.16.4-2ubuntu1) …
Setting up html2text (1.3.2a-3build1) …

Setting up gettext (0.16.1-2ubuntu3) …

Setting up intltool-debian (0.35.0+20060710.1) …
Setting up po-debconf (1.0.9) …
Setting up debhelper (5.0.51ubuntu3) …
Setting up liberror-perl (0.15-8) …
Setting up libdigest-sha1-perl (2.11-2) …
Setting up git-core (1:1.5.2.5-2build1) …
Setting up tcl8.4 (8.4.15-1build1) …

Setting up tk8.4 (8.4.15-1ubuntu1) …

Setting up gitk (1:1.5.2.5-2build1) …
Setting up kernel-package (11.001) …
Setting up kernel-wedge (2.29ubuntu2) …
Setting up linux-kernel-devel (2.6.22-14.52) …
Processing triggers for libc6 …
ldconfig deferred processing now taking place

but still cannot find the needed header files :

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include] /usr/src/linux

The path “/usr/src/linux” is an existing directory, but it does not contain a
“linux” subdirectory as expected.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include] /usr/include/linux

The header files in /usr/include are generally for C libraries, not for the
running kernel. If you do not have kernel header files in your /usr/src
directory, you probably do not have the kernel-source package installed. Are you
sure that /usr/include contains the header files associated with your running
kernel? [no] yes

The path “/usr/include/linux” is an existing directory, but it does not contain
a “linux” subdirectory as expected.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include] /usr/src/linux-headers-2.6.22-14/include/linux

The path “/usr/src/linux-headers-2.6.22-14/include/linux” is an existing
directory, but it does not contain a “linux” subdirectory as expected.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include] /usr/src/linux-headers-2.6.22-14/include/

The path “/usr/src/linux-headers-2.6.22-14/include” is a kernel header file
directory, but it does not contain the file “linux/version.h” as expected. This
can happen if the kernel has never been built, or if you have invoked the “make
mrproper” command in your kernel directory. In any case, you may want to
rebuild your kernel.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]

 

reboot ,and in here find a solution,so :

crifan@crifan-desktop:~$ uname -a
Linux crifan-desktop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux
crifan@crifan-desktop:~$ sudo apt-cache search 2.6.22-14-generic
[sudo] password for crifan:
linux-backports-modules-2.6.22-14-generic – Ubuntu supplied Linux modules for version 2.6.22 on x86/x86_64
linux-ubuntu-modules-2.6.22-14-generic – Ubuntu supplied Linux modules for version 2.6.22 on x86/x86_64
virtualbox-ose-modules-2.6.22-14-generic – virtualbox-ose modules for linux-image-2.6.22-14-generic
linux-restricted-modules-2.6.22-14-generic – Non-free Linux 2.6.22 modules on x86/x86_64
linux-headers-2.6.22-14-generic – Linux kernel headers for version 2.6.22 on x86/x86_64
linux-image-2.6.22-14-generic – Linux kernel image for version 2.6.22 on x86/x86_64
linux-image-debug-2.6.22-14-generic – Linux kernel debug image for version 2.6.22 on x86/x86_64
crifan@crifan-desktop:~$ sudo apt-get install linux-headers-2.6.22-14-generic
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be upgraded:
linux-headers-2.6.22-14-generic
1 upgraded, 0 newly installed, 0 to remove and 190 not upgraded.
Need to get 0B/581kB of archives.
After unpacking 4096B of additional disk space will be used.
(Reading database … 93380 files and directories currently installed.)
Preparing to replace linux-headers-2.6.22-14-generic 2.6.22-14.46 (using …/linux-headers-2.6.22-14-generic_2.6.22-14.52_i386.deb) …
Unpacking replacement linux-headers-2.6.22-14-generic …
Setting up linux-headers-2.6.22-14-generic (2.6.22-14.52) …

转载请注明:在路上 » install the vmware tool

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
59 queries in 0.215 seconds, using 18.92MB memory