最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【已解决】Mac中xcode-select –install出错:xcode-select: error: command line tools are already installed, use “Software Update” to install updates

Mac crifan 3678浏览 0评论

折腾:

【已解决】Mac中编译安装pycurl失败:error: command ‘gcc’ failed with exit status 1

期间,出错:

<code>(xx) bash-3.2$ xcode-select --install
xcode-select: error: command line tools are already installed, use "Software Update" to install updates
</code>

error: command ‘gcc’ failed with exit status 1 – qq_37879432的博客 – CSDN博客

xcode-select: error: command line tools are already installed, use “Software Update” to install updates

How to update xcode from command line – Stack Overflow

macos – Xcode Command Line Tools: How to update? – Stack Overflow

<code>(x) bash-3.2$ softwareupdate -i
Software Update Tool

(x) bash-3.2$ softwareupdate --list
Software Update Tool

Finding available software
Software Update found the following new or updated software:
   * Safari12.0HighSierraAuto-12.0
    Safari 浏览器 (12.0), 78915K [recommended]
   * iTunesX-12.8
    iTunes (12.8), 263192K [recommended]
</code>

Xcode – Apple Developer

macos – Why xcode-select: error :command line tools are already installed, use “Software Update” to install updates – Stack Overflow

macos – Mac Command Line Tools Continue to Update – Ask Different

去试试:

<code>(xx) bash-3.2$ brew config
HOMEBREW_VERSION: 1.7.7
ORIGIN: https://github.com/Homebrew/brew
HEAD: c54a657cd5987cba2718f7012a55101324fde8b1
Last commit: 8 days ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: 2b97bb3e80d5c7bf68d40d7cff613ed1aac731c4
Core tap last commit: 6 hours ago
HOMEBREW_PREFIX: /usr/local
CPU: quad-core 64-bit sandybridge
Homebrew Ruby: 2.3.7 =&gt; /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/ruby
Clang: 10.0 build 1000
Git: 2.17.1 =&gt; /Library/Developer/CommandLineTools/usr/bin/git
Curl: 7.54.0 =&gt; /usr/bin/curl
macOS: 10.13.6-x86_64
CLT: 10.0.0.0.1.1535735448
Xcode: N/A
</code>

意思是:

CLT: 10.0.0.0.1.1535735448

-》CLT=command line tools,已经安装了

macos – Xcode, Command Line Tools, GCC, and HomeBrew – Ask Different

<code>(x) bash-3.2$ xcode-select --version
xcode-select version 2349.
(x) bash-3.2$ xcode-select -p
/Library/Developer/CommandLineTools
(x) bash-3.2$ gcc --version
Configured with: --prefix=/Library/Developer/CommandLineTools/usr --with-gxx-include-dir=/usr/include/c++/4.2.1
Apple LLVM version 10.0.0 (clang-1000.10.44.2)
Target: x86_64-apple-darwin17.7.0
Thread model: posix
InstalledDir: /Library/Developer/CommandLineTools/usr/bin
(x) bash-3.2$
</code>

macos – How to open Xcode from Terminal? – Ask Different

Command Line Tools安装方法 – More930的博客 – CSDN博客

【总结】

运行:

<code>xcode-select --install
</code>

出现:

xcode-select: error: command line tools are already installed, use “Software Update” to install updates

说明:xcode-select已经安装了。

转载请注明:在路上 » 【已解决】Mac中xcode-select –install出错:xcode-select: error: command line tools are already installed, use “Software Update” to install updates

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
56 queries in 0.100 seconds, using 18.25MB memory