最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

[已解决] pod update出错: Re-creating CocoaPods due to major version update

Mac crifan 813浏览 0评论

一个旧的iOS的Pods的项目,用svn下载后再去更新:

➜  jianyou pod update
Update all pods
Re-creating CocoaPods due to major version update.
Updating local specs repositories
CocoaPods 1.1.0.beta.1 is available.
To update use: `sudo gem install cocoapods –pre`
[!] This is a test version we’d love you to try.
For more information, see https://blog.cocoapods.org and the CHANGELOG for this version at https://github.com/CocoaPods/CocoaPods/releases/tag/1.1.0.beta.1
Analyzing dependencies
[!] The dependency `AFNetworking (~> 2.5.0)` is not used in any concrete target.
The dependency `SWTableViewCell (~> 0.3.7)` is not used in any concrete target.
The dependency `REFrostedViewController (~> 2.4)` is not used in any concrete target.
The dependency `MWPhotoBrowser` is not used in any concrete target.
The dependency `MJExtension` is not used in any concrete target.
The dependency `FMDB` is not used in any concrete target.
The dependency `QBPopupMenu` is not used in any concrete target.
The dependency `FDFullscreenPopGesture (= 1.1)` is not used in any concrete target.
The dependency `QBImagePickerController (~> 2.5.2)` is not used in any concrete target.
The dependency `OLCOrm` is not used in any concrete target.
The dependency `MBProgressHUD+BWMExtension (~> 1.0.0)` is not used in any concrete target.
The dependency `MJRefresh` is not used in any concrete target.
The dependency `mailcore2-ios` is not used in any concrete target.
➜  jianyou

注:

后来去看了看,此处是1.0.0版本:

licrifandeMacBook-Pro:CrifanThread crifan$ pod –version
1.0.0

按照提示去:

sudo gem install cocoapods –pre

➜  jianyou sudo gem install cocoapods –pre
Password:
Fetching: cocoapods-core-1.1.0.beta.1.gem (100%)
Successfully installed cocoapods-core-1.1.0.beta.1
Fetching: cocoapods-downloader-1.1.0.gem (100%)
Successfully installed cocoapods-downloader-1.1.0
Fetching: cocoapods-try-1.1.0.gem (100%)
Successfully installed cocoapods-try-1.1.0
Fetching: molinillo-0.5.0.gem (100%)
Successfully installed molinillo-0.5.0
Fetching: xcodeproj-1.2.0.gem (100%)
ERROR:  While executing gem … (Errno::EPERM)
    Operation not permitted – /usr/bin/xcodeproj

搜:

ERROR:  While executing gem … (Errno::EPERM)

不过没去研究。

但是自己无意间想起来了:

Operation not permitted – /usr/bin/xcodeproj

估计是说:

此处没有权限去更新xcodeproj

-》即对应着,无法更新Xcode

-》估计是因为:此处正在用Xcode打开其他项目呢

-》所以应该是:关闭Xcode后,再去更新,估计就可以了。

先去搜:

Re-creating CocoaPods due to major version update

更新CocoaPods碰到的问题及知识点 – 踏浪帅 – 博客园

pod》error:The dependency “ is not used in any concrete target – Xylophone – 博客园

ios – Xcode 8 Pod update issue – Re-creating CocoaPods due to major version update – Stack Overflow

cocoapods – 佳强的菜园子

Pods 更新后提示Bundle资源找不到 – 开源中国社区

去把之前的:

➜  jianyou cat podfile
platform:ios,’7.0′
pod ‘AFNetworking’, ‘~> 2.5.0’
pod ‘SWTableViewCell’, ‘~> 0.3.7’
pod ‘REFrostedViewController’, ‘~> 2.4’
pod ‘MWPhotoBrowser’
pod ‘MJExtension’
pod ‘FMDB’
pod ‘QBPopupMenu’
pod ‘FDFullscreenPopGesture’, ‘1.1’
pod ‘QBImagePickerController’, ‘~> 2.5.2’
pod “OLCOrm”
pod ‘MBProgressHUD+BWMExtension’, ‘~> 1.0.0’
pod ‘MJRefresh’
pod ‘mailcore2-ios’

加上target变成:

➜  jianyou cat podfile
platform:ios,’7.0′
target ‘EasyMail’ do
pod ‘AFNetworking’, ‘~> 2.5.0’
pod ‘SWTableViewCell’, ‘~> 0.3.7’
pod ‘REFrostedViewController’, ‘~> 2.4’
pod ‘MWPhotoBrowser’
pod ‘MJExtension’
pod ‘FMDB’
pod ‘QBPopupMenu’
pod ‘FDFullscreenPopGesture’, ‘1.1’
pod ‘QBImagePickerController’, ‘~> 2.5.2’
pod “OLCOrm”
pod ‘MBProgressHUD+BWMExtension’, ‘~> 1.0.0’
pod ‘MJRefresh’
pod ‘mailcore2-ios’
end

然后更新安装库,就可以了:

[已解决]pod update卡死在Installing mailcore2-ios

注意:

如果是swift项目,则还要在

platform:ios,’7.0′

之后,加上一个:

use_frameworks!

变成,类似于这种:

# Uncomment this line to define a global platform for your project
platform :ios, ‘8.0’
# Uncomment this line if you’re using Swift
use_frameworks!
target ‘QorosSales’ do
    pod “KKGestureLockView”
    pod ‘SEFilterControl’
end
target ‘QorosSalesTests’ do
end
target ‘QorosSalesUITests’ do
end

转载请注明:在路上 » [已解决] pod update出错: Re-creating CocoaPods due to major version update

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
64 queries in 0.094 seconds, using 18.86MB memory