最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【已解决】Ubuntu下配置QEMU出错:ERROR: glib-2.12 required to compile QEMU

QEMU crifan 5812浏览 0评论

【问题】

折腾:

【记录】在Ubuntu 13.04上安装QEMU

期间,解决了:

【已解决】Ubuntu下安装QEMU在配置时出错:ERROR: zlib check failed

结果继续出现其他错误:

crifan@ubuntu:qemu-1.6.0-rc3$ ./configure --prefix=/opt/qemu --target-list=arm-softmmu,arm-linux-user --enable-debug

ERROR: glib-2.12 required to compile QEMU

截图:

ERROR glib 2 12 required to compile QEMU

【解决过程】

1.参考:

Re: [Qemu-discuss] Configure error with qemu 1.4

去安装glib2-devel

2.但是安装之前,先去搜索有哪些glib2:

crifan@ubuntu:qemu-1.6.0-rc3$ apt-cache search glib2
libcglib-java - code generation library for Java
libglib2.0-0 - GLib library of C routines
libglib2.0-0-dbg - Debugging symbols for the GLib libraries
libglib2.0-bin - Programs for the GLib library
libglib2.0-cil - CLI binding for the GLib utility library 2.12
libglib2.0-cil-dev - CLI binding for the GLib utility library 2.12
libglib2.0-data - Common files for GLib library
libglib2.0-dev - Development files for the GLib library
libglib2.0-doc - Documentation files for the GLib library
libpackagekit-glib2-14 - Library for accessing PackageKit using GLib
libpackagekit-glib2-dev - Library for accessing PackageKit using GLib (development files)
libpulse-mainloop-glib0 - PulseAudio client libraries (glib support)
libglib2-ruby - Transitional package for ruby-glib2
libglib2-ruby1.8 - Transitional package for ruby-glib2
libglib2-ruby1.8-dbg - Transitional package for ruby-glib2
libglib2.0-0-refdbg - GLib library of C routines - refdbg library
libntrack-glib2 - glib API for ntrack
libtaglib2.1-cil - CLI library for accessing audio and video files metadata
ruby-glib2 - Glib 2 bindings for the Ruby language
ruby-glib2-dbg - Glib 2 bindings for the Ruby language (debugging symbols)
ruby-taglib2 - Ruby interface to TagLib, the audio meta-data library

3.看起来,最像的是:libglib2.0-dev,去安装:

crifan@ubuntu:qemu-1.6.0-rc3$ sudo apt-get install glib2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package glib2
crifan@ubuntu:qemu-1.6.0-rc3$ sudo apt-get install libglib2-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libglib2-dev
crifan@ubuntu:qemu-1.6.0-rc3$ sudo apt-get install libglib2.0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libpcre3-dev libpcrecpp0
Suggested packages:
  libglib2.0-doc
The following NEW packages will be installed:
  libglib2.0-dev libpcre3-dev libpcrecpp0
0 upgraded, 3 newly installed, 0 to remove and 13 not upgraded.
Need to get 1,506 kB of archives.
After this operation, 8,535 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://mirrors.ustc.edu.cn/ubuntu/ raring/main libpcrecpp0 i386 1:8.31-2 [17.1 kB]
Get:2 http://mirrors.ustc.edu.cn/ubuntu/ raring/main libpcre3-dev i386 1:8.31-2 [261 kB]
Get:3 http://mirrors.ustc.edu.cn/ubuntu/ raring/main libglib2.0-dev i386 2.36.0-1ubuntu2 [1,227 kB]
Fetched 1,506 kB in 3s (401 kB/s)         
Selecting previously unselected package libpcrecpp0:i386.
(Reading database ... 189509 files and directories currently installed.)
Unpacking libpcrecpp0:i386 (from .../libpcrecpp0_1%3a8.31-2_i386.deb) ...
Selecting previously unselected package libpcre3-dev:i386.
Unpacking libpcre3-dev:i386 (from .../libpcre3-dev_1%3a8.31-2_i386.deb) ...
Selecting previously unselected package libglib2.0-dev.
Unpacking libglib2.0-dev (from .../libglib2.0-dev_2.36.0-1ubuntu2_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for libglib2.0-0:i386 ...
Setting up libpcrecpp0:i386 (1:8.31-2) ...
Setting up libpcre3-dev:i386 (1:8.31-2) ...
Setting up libglib2.0-dev (2.36.0-1ubuntu2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
crifan@ubuntu:qemu-1.6.0-rc3$ 

4.然后再接着配置,看看是否解决问题,然后就解决问题了。

 

【总结】

当Ubuntu下配置QEMU时出现:

ERROR: glib-2.12 required to compile QEMU

的错误时,意思是缺少了glib2库,此处通过搜索:

apt-cache search glib2

找到了是:

libglib2.0-dev

所以去安装该库:

sudo apt-get install libglib2.0-dev

即可解决问题。

转载请注明:在路上 » 【已解决】Ubuntu下配置QEMU出错:ERROR: glib-2.12 required to compile QEMU

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
46 queries in 0.126 seconds, using 16.87MB memory