最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【未解决】Ubuntu中apt-get安装报错:dpkg: error processing package mysql-server

MySQL crifan 224浏览 0评论
折腾:
【未解决】Ubuntu中升级Python 3.5到最新版的Python 3.7
期间,安装python3.7的最后报错:
# sudo apt-get install python3.7
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python3.7 is already the newest version (3.7.3-1+xenial1).
0 upgraded, 0 newly installed, 0 to remove and 435 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up mysql-server-5.7 (5.7.23-0ubuntu0.16.04.1) ...
/var/lib/dpkg/info/mysql-server-5.7.postinst: line 143: /usr/share/mysql-common/configure-symlinks: No such file or directory
dpkg: error processing package mysql-server-5.7 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.7; however:
  Package mysql-server-5.7 is not configured yet.


dpkg: error processing package mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
ubunt dpkg error processing package mysql-server –configure
apt – dpkg: error processing package mysql-server (–configure) – Ask Ubuntu
sudo apt-get purge mysql*
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get dist-upgrade
详细log
# sudo apt-get purge mysql*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'mysqltcl' for glob 'mysql*'
Note, selecting 'mysql-mmm-agent' for glob 'mysql*'
Note, selecting 'mysql-workbench' for glob 'mysql*'
Note, selecting 'mysql-client-4.1' for glob 'mysql*'
Note, selecting 'mysql-client-5.0' for glob 'mysql*'
Note, selecting 'mysql-client-5.1' for glob 'mysql*'
Note, selecting 'mysql-client-5.5' for glob 'mysql*'
Note, selecting 'mysql-client-5.6' for glob 'mysql*'
Note, selecting 'mysql-client-5.7' for glob 'mysql*'
Note, selecting 'mysql-mmm-tools' for glob 'mysql*'
Note, selecting 'mysql-common-5.6' for glob 'mysql*'
Note, selecting 'mysql-server-4.1' for glob 'mysql*'
Note, selecting 'mysql-server-5.0' for glob 'mysql*'
Note, selecting 'mysql-server-5.1' for glob 'mysql*'
Note, selecting 'mysql-server-5.5' for glob 'mysql*'
Note, selecting 'mysql-server-5.6' for glob 'mysql*'
Note, selecting 'mysql-server-5.7' for glob 'mysql*'
Note, selecting 'mysql-utilities' for glob 'mysql*'
Note, selecting 'mysql-testsuite' for glob 'mysql*'
Note, selecting 'mysql-mmm-common' for glob 'mysql*'
Note, selecting 'mysql-server' for glob 'mysql*'
Note, selecting 'mysql-client' for glob 'mysql*'
Note, selecting 'mysql-sandbox' for glob 'mysql*'
Note, selecting 'mysql-client-core-5.5' for glob 'mysql*'
Note, selecting 'mysql-client-core-5.6' for glob 'mysql*'
Note, selecting 'mysql-client-core-5.7' for glob 'mysql*'
Note, selecting 'mysql-testsuite-5.5' for glob 'mysql*'
Note, selecting 'mysql-testsuite-5.6' for glob 'mysql*'
Note, selecting 'mysql-testsuite-5.7' for glob 'mysql*'
Note, selecting 'mysql-common' for glob 'mysql*'
Note, selecting 'mysql-mmm-monitor' for glob 'mysql*'
Note, selecting 'mysqltuner' for glob 'mysql*'
Note, selecting 'mysql-workbench-data' for glob 'mysql*'
Note, selecting 'mysql-server-core-5.1' for glob 'mysql*'
Note, selecting 'mysql-server-core-5.5' for glob 'mysql*'
Note, selecting 'mysql-server-core-5.6' for glob 'mysql*'
Note, selecting 'mysql-server-core-5.7' for glob 'mysql*'
Note, selecting 'mysql-source-5.7' for glob 'mysql*'
Package 'mysql-server-core-5.6' is not installed, so not removed
Package 'mysql-client-core-5.5' is not installed, so not removed
Package 'mysql-client-core-5.6' is not installed, so not removed
Package 'mysql-server-5.5' is not installed, so not removed
Package 'mysql-server-5.6' is not installed, so not removed
Package 'mysql-server-core-5.5' is not installed, so not removed
Package 'mysql-testsuite-5.5' is not installed, so not removed
Package 'mysql-testsuite-5.6' is not installed, so not removed
Package 'mysql-server-5.0' is not installed, so not removed
Package 'mysql-server-5.1' is not installed, so not removed
Package 'mysql-server-core-5.1' is not installed, so not removed
Package 'mysql-client-5.0' is not installed, so not removed
Package 'mysql-server-4.1' is not installed, so not removed
Package 'mysql-mmm-agent' is not installed, so not removed
Package 'mysql-mmm-common' is not installed, so not removed
Package 'mysql-mmm-monitor' is not installed, so not removed
Package 'mysql-mmm-tools' is not installed, so not removed
Package 'mysql-sandbox' is not installed, so not removed
Package 'mysql-utilities' is not installed, so not removed
Package 'mysql-workbench' is not installed, so not removed
Package 'mysql-workbench-data' is not installed, so not removed
Package 'mysqltcl' is not installed, so not removed
Package 'mysqltuner' is not installed, so not removed
Package 'mysql-client' is not installed, so not removed
Package 'mysql-source-5.7' is not installed, so not removed
Package 'mysql-testsuite' is not installed, so not removed
Package 'mysql-testsuite-5.7' is not installed, so not removed
The following packages were automatically installed and are no longer required:
  libcgi-fast-perl libcgi-pm-perl libencode-locale-perl libevent-core-2.0-5 libfcgi-perl libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl libhttp-date-perl
  libhttp-message-perl libio-html-perl liblwp-mediatypes-perl libtimedate-perl liburi-perl
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  libmysqlclient-dev* libmysqlclient20* libqt4-sql-mysql* mysql-client-5.7* mysql-client-core-5.7* mysql-common* mysql-server* mysql-server-5.7* mysql-server-core-5.7*
0 upgraded, 0 newly installed, 9 to remove and 428 not upgraded.
2 not fully installed or removed.
After this operation, 172 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 113064 files and directories currently installed.)
Removing mysql-server (5.7.23-0ubuntu0.16.04.1) ...
Removing mysql-server-5.7 (5.7.23-0ubuntu0.16.04.1) ...
Purging configuration files for mysql-server-5.7 (5.7.23-0ubuntu0.16.04.1) ...
Removing libmysqlclient-dev (5.7.18-0ubuntu0.16.04.1) ...
Removing libqt4-sql-mysql:amd64 (4:4.8.7+dfsg-5ubuntu2) ...
Removing libmysqlclient20:amd64 (5.7.18-0ubuntu0.16.04.1) ...
Removing mysql-client-5.7 (5.7.23-0ubuntu0.16.04.1) ...
Removing mysql-client-core-5.7 (5.7.23-0ubuntu0.16.04.1) ...
Removing mysql-common (10.1.21+maria-1~xenial) ...
Purging configuration files for mysql-common (10.1.21+maria-1~xenial) ...
Removing mysql-server-core-5.7 (5.7.23-0ubuntu0.16.04.1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu3) ...
[email protected]:~# sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libcgi-fast-perl libcgi-pm-perl libencode-locale-perl libevent-core-2.0-5 libfcgi-perl libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl libhttp-date-perl
  libhttp-message-perl libio-html-perl liblwp-mediatypes-perl libtimedate-perl liburi-perl
0 upgraded, 0 newly installed, 14 to remove and 428 not upgraded.
After this operation, 2,132 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 112682 files and directories currently installed.)
Removing libcgi-fast-perl (1:2.10-1) ...
Removing libhtml-template-perl (2.95-2) ...
Removing libcgi-pm-perl (4.26-1) ...
Removing libhttp-message-perl (6.11-1) ...
Removing libencode-locale-perl (1.05-1) ...
Removing libevent-core-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Removing libfcgi-perl (0.77-1build1) ...
Removing libhtml-parser-perl (3.72-1) ...
Removing libhtml-tagset-perl (3.20-2) ...
Removing libhttp-date-perl (6.02-1) ...
Removing libio-html-perl (1.001-1) ...
Removing liblwp-mediatypes-perl (6.02-1) ...
Removing libtimedate-perl (2.3000-2) ...
Removing liburi-perl (1.71-1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu3) ...
[email protected]:~# sudo apt-get autoclean
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Del vim-common 2:7.4.1689-3ubuntu1.2 [103 kB]
Del dbus 1.10.6-1ubuntu3.3 [142 kB]
Del sudo 1.8.16-0ubuntu1.6 [390 kB]
Del python3-apt 1.1.0~beta1ubuntu0.16.04.4 [138 kB]
Del vim-tiny 2:7.4.1689-3ubuntu1.2 [445 kB]
Del python-apt-common 1.1.0~beta1ubuntu0.16.04.4 [16.0 kB]
Del libdbus-1-3 1.10.6-1ubuntu3.3 [161 kB]
Del dbus-x11 1.10.6-1ubuntu3.3 [21.4 kB]
Del vim 2:7.4.1689-3ubuntu1.2 [1,036 kB]
Del vim-runtime 2:7.4.1689-3ubuntu1.2 [5,164 kB]

# sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libllvm3.8 libmircommon5 libssl1.0.2
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  amd64-microcode intel-microcode iucode-tool libcapnp-0.5.3 libicu64 libllvm6.0 libmircommon7 libmircore1 libsensors4 libsnappy1v5 libwebp6 libxmlsec1
  libxmlsec1-openssl linux-headers-4.4.0-150 linux-headers-4.4.0-150-generic linux-image-4.4.0-150-generic linux-modules-4.4.0-150-generic
  linux-modules-extra-4.4.0-150-generic ubuntu-advantage-tools
The following packages will be upgraded:
  accountsservice apache2 apache2-bin apache2-data apache2-utils apparmor apport apt apt-transport-https apt-utils base-files bash bind9-host binutils bsdutils
  btrfs-tools busybox-initramfs busybox-static ca-certificates cloud-guest-utils cloud-initramfs-copymods cloud-initramfs-dyn-netconf console-setup console-setup-linux
  coreutils cpp-5 crash cryptsetup cryptsetup-bin curl dbus dbus-x11 debconf debconf-i18n distro-info-data dns-root-data dnsmasq-base dnsutils dpkg dpkg-dev eject file
  firefox friendly-recovery fuse g++-5 gcc-5 gcc-5-base gettext-base ghostscript gir1.2-gdkpixbuf-2.0 git git-man gnupg gpgv grub-common grub-legacy-ec2 grub-pc
  grub-pc-bin grub2-common gstreamer1.0-plugins-base hdparm hicolor-icon-theme icu-devtools idle-python2.7 ifupdown imagemagick imagemagick-6.q16 imagemagick-common
  init init-system-helpers initramfs-tools initramfs-tools-bin initramfs-tools-core iproute2 isc-dhcp-client isc-dhcp-common kbd kdump-tools kexec-tools
  keyboard-configuration klibc-utils kmod krb5-locales language-selector-common less libaccountsservice0 libapparmor-perl libapparmor1 libapt-inst2.0 libapt-pkg5.0
  libarchive13 libasan2 libasn1-8-heimdal libasprintf0v5 libatomic1 libaudit-common libaudit1 libavahi-client3 libavahi-common-data libavahi-common3 libbind9-140
  libblkid1 libc-bin libc-dev-bin libc6 libc6-dev libcc1-0 libcilkrts5 libcryptsetup4 libcups2 libcupsfilters1 libcupsimage2 libcurl3 libcurl3-gnutls libdb5.3
  libdbus-1-3 libdns-export162 libdns162 libdpkg-perl libdw1 libegl1-mesa libelf1 libepoxy0 libevent-2.0-5 libexpat1 libexpat1-dev libfdisk1 libfreetype6
  libfreetype6-dev libfuse2 libgbm1 libgcc-5-dev libgcrypt20 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgdk-pixbuf2.0-dev libgl1-mesa-dri libglib2.0-0
  libglib2.0-bin libglib2.0-data libglib2.0-dev libgnutls-openssl27 libgnutls30 libgomp1 libgraphite2-3 libgs9 libgs9-common libgssapi-krb5-2 libgssapi3-heimdal
  libgstreamer-plugins-base1.0-0 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhogweed4 libhx509-5-heimdal
  libicu-dev libicu55 libidn11 libisc-export160 libisc160 libisccc140 libisccfg140 libitm1 libjasper-dev libjasper1 libjbig2dec0 libjpeg-turbo8 libjpeg-turbo8-dev
  libk5crypto3 libklibc libkmod2 libkrb5-26-heimdal libkrb5-3 libkrb5support0 liblcms2-2 liblcms2-dev libldap-2.4-2 libldb1 liblsan0 liblwres141 liblxc1 libmagic1
  libmagickcore-6-arch-config libmagickcore-6-headers libmagickcore-6.q16-2 libmagickcore-6.q16-2-extra libmagickcore-6.q16-dev libmagickcore-dev
  libmagickwand-6-headers libmagickwand-6.q16-2 libmagickwand-6.q16-dev libmagickwand-dev libmirclient9 libmirprotobuf3 libmount1 libmpx0 libmspack0 libnettle6
  libnl-3-200 libnl-genl-3-200 libnss3 libnss3-nssdb libnuma1 libpam-modules libpam-modules-bin libpam-runtime libpam-systemd libpam0g libparted2 libpci3 libpcre16-3
  libpcre3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libperl5.22 libplymouth4 libpng12-0 libpng12-dev libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0
  libprocps4 libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libpython3.5 libpython3.5-dev libpython3.5-minimal libpython3.5-stdlib libqt5core5a
  libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5sql5 libqt5sql5-sqlite libqt5widgets5 libquadmath0 libroken18-heimdal librtmp1
  libruby2.3 libsasl2-2 libsasl2-modules libsasl2-modules-db libseccomp2 libslang2 libsmartcols1 libsoup-gnome2.4-1 libsoup2.4-1 libsqlite3-0 libssl-dev libssl-doc
  libssl1.0.0 libssl1.1 libstdc++-5-dev libstdc++6 libsvn1 libsystemd0 libtasn1-6 libtiff5 libtiff5-dev libtiffxx5 libtirpc1 libtsan0 libubsan0 libudev1 libuuid1
  libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa libwayland-server0 libwbclient0 libwind0-heimdal libx11-6 libx11-data libx11-dev libx11-doc libx11-xcb-dev
  libx11-xcb1 libxcursor1 libxkbcommon-x11-0 libxkbcommon0 libxslt1.1 libzip4 linux-base linux-crashdump linux-firmware linux-generic linux-headers-generic
  linux-image-generic linux-libc-dev locales login logrotate lshw lxc-common lxcfs lxd lxd-client makedev makedumpfile mdadm mount multiarch-support nano nfs-common
  nfs-kernel-server nginx nodejs ntfs-3g ntpdate open-iscsi open-vm-tools openssh-client openssh-server openssh-sftp-server openssl os-prober overlayroot parted passwd
  patch pciutils perl perl-base perl-modules-5.22 php-common php5.6-cli php5.6-common php5.6-curl php5.6-fpm php5.6-gd php5.6-imap php5.6-json php5.6-mbstring
  php5.6-mcrypt php5.6-mysql php5.6-opcache php5.6-readline php5.6-soap php5.6-xml php5.6-xmlrpc php5.6-zip plymouth plymouth-theme-ubuntu-text policykit-1 procps
  python-apt-common python-crypto python-ldb python-samba python2.7 python2.7-dev python2.7-minimal python3-apport python3-apt python3-distupgrade
  python3-problem-report python3-requests python3-software-properties python3-update-manager python3-urllib3 python3.5 python3.5-dev python3.5-minimal resolvconf rsync
  rsyslog ruby-loofah ruby2.3 ruby2.3-dev samba samba-common samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules sensible-utils shared-mime-info snapd
  software-properties-common sosreport sqlite3 squashfs-tools subversion sudo systemd systemd-sysv tar tcpdump tzdata ubuntu-core-launcher ubuntu-minimal ubuntu-mono
  ubuntu-release-upgrader-core ubuntu-server ubuntu-standard udev uidmap unattended-upgrades update-manager-core update-notifier-common ureadahead util-linux
  uuid-runtime vim vim-common vim-runtime vim-tiny vlan wget wireless-regdb x11-common x11proto-core-dev xdg-user-dirs xfsprogs xserver-xephyr-hwe-16.04 xul-ext-ubufox
  zlib1g zlib1g-dev
428 upgraded, 19 newly installed, 0 to remove and 0 not upgraded.
Need to get 179 MB/490 MB of archives.
After this operation, 668 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 dbus-x11 amd64 1.10.6-1ubuntu3.4 [21.6 kB]
Get:2 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 dbus amd64 1.10.6-1ubuntu3.4 [142 kB]
Get:3 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 libdbus-1-3 amd64 1.10.6-1ubuntu3.4 [161 kB]
Get:4 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 python-apt-common all 1.1.0~beta1ubuntu0.16.04.5 [16.2 kB]
Get:5 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 libicu64 amd64 64.1-0.1+ubuntu16.04.1+deb.sury.org+1 [8,352 kB]
Get:6 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 python3-apt amd64 1.1.0~beta1ubuntu0.16.04.5 [138 kB]
Get:7 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 sudo amd64 1.8.16-0ubuntu1.7 [390 kB]
Get:8 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 ubuntu-advantage-tools all 10ubuntu0.16.04.1 [11.5 kB]
Get:9 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 vim amd64 2:7.4.1689-3ubuntu1.3 [1,036 kB]
Get:10 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 vim-tiny amd64 2:7.4.1689-3ubuntu1.3 [446 kB]
Get:11 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 vim-runtime all 2:7.4.1689-3ubuntu1.3 [5,179 kB]
Get:12 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 vim-common amd64 2:7.4.1689-3ubuntu1.3 [103 kB]
Get:13 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 ubuntu-minimal amd64 1.361.3 [2,696 B]
Get:14 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 libicu55 amd64 55.1-7ubuntu0.4 [7,646 kB]
Get:15 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libsnappy1v5 amd64 1.1.3-2 [16.0 kB]
Get:16 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 crash amd64 7.2.3+real-1~16.04.1 [2,680 kB]
Get:17 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 firefox amd64 67.0.2+build2-0ubuntu0.16.04.1 [48.2 MB]
Get:18 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 iucode-tool amd64 1.5.1-1ubuntu0.1 [33.8 kB]
Get:19 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 libcapnp-0.5.3 amd64 0.5.3-2ubuntu1.1 [580 kB]
Get:20 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 libwayland-egl1-mesa amd64 18.0.5-0ubuntu0~16.04.1 [5,778 B]
Get:21 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 libegl1-mesa amd64 18.0.5-0ubuntu0~16.04.1 [87.0 kB]
Get:22 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 libgbm1 amd64 18.0.5-0ubuntu0~16.04.1 [24.0 kB]
Get:23 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 libmircore1 amd64 0.26.3+16.04.20170605-0ubuntu1.1 [24.4 kB]
Get:24 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 libmircommon7 amd64 0.26.3+16.04.20170605-0ubuntu1.1 [89.7 kB]
Get:25 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 libmirclient9 amd64 0.26.3+16.04.20170605-0ubuntu1.1 [194 kB]
Get:26 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 libllvm6.0 amd64 1:6.0-1ubuntu2~16.04.1 [14.3 MB]
Get:27 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libsensors4 amd64 1:3.4.0-2 [28.4 kB]
Get:28 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 libgl1-mesa-dri amd64 18.0.5-0ubuntu0~16.04.1 [6,080 kB]
Get:29 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libxmlsec1 amd64 1.2.20-2ubuntu4 [118 kB]
Get:30 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libxmlsec1-openssl amd64 1.2.20-2ubuntu4 [65.0 kB]
Get:31 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 linux-modules-4.4.0-150-generic amd64 4.4.0-150.176 [12.0 MB]
Get:32 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 linux-image-4.4.0-150-generic amd64 4.4.0-150.176 [6,928 kB]
Get:33 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 linux-modules-extra-4.4.0-150-generic amd64 4.4.0-150.176 [36.6 MB]
Get:34 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 intel-microcode amd64 3.20190514.0ubuntu0.16.04.2 [2,050 kB]
Get:35 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 amd64-microcode amd64 3.20180524.1~ubuntu0.16.04.2 [32.2 kB]
Get:36 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 linux-generic amd64 4.4.0.150.158 [1,788 B]
Get:37 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 linux-image-generic amd64 4.4.0.150.158 [2,742 B]
Get:38 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 linux-headers-4.4.0-150 all 4.4.0-150.176 [10.1 MB]
Get:39 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 linux-headers-4.4.0-150-generic amd64 4.4.0-150.176 [806 kB]                                      
Get:40 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 linux-headers-generic amd64 4.4.0.150.158 [2,576 B]                                               
Get:41 http://mirrors.tencentyun.com/ubuntu xenial-updates/main amd64 open-vm-tools amd64 2:10.2.0-3~ubuntu0.16.04.1 [538 kB]                                            
Get:42 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 icu-devtools amd64 64.1-0.1+ubuntu16.04.1+deb.sury.org+1 [195 kB]                                    
Get:43 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 libicu-dev amd64 64.1-0.1+ubuntu16.04.1+deb.sury.org+1 [9,216 kB]                                    
Get:44 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 libwebp6 amd64 0.6.0-4+ubuntu16.04.1+deb.sury.org+1 [184 kB]                                         
Get:45 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 libgd3 amd64 2.2.5-5.1+ubuntu16.04.1+deb.sury.org+1 [133 kB]                                         
Get:46 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 php5.6-cli amd64 5.6.40-8+ubuntu16.04.1+deb.sury.org+1 [1,285 kB]                                    
Get:47 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 php5.6-common amd64 5.6.40-8+ubuntu16.04.1+deb.sury.org+1 [2,762 kB]                                 
Fetched 178 MB in 34s (5,179 kB/s)                                                                                                                                       
Extracting templates from packages: 100%
Preconfiguring packages ...
... 
期间还要去配置:
kdump-tools
kexec-tools
 Configuring kdump-tools ├───────────────────────────────────────────────────────────────┐        
        │                                                                                                                                                        │        
        │ If you choose this option, the kdump-tools mechanism will be enabled. A reboot is still required in order to enable the crashkernel kernel parameter.  │        
        │                                                                                                                                                        │        
        │ Should kdump-tools be enabled by default?                                                                                                              │        
        │                                                                                                                                                        │        
        │                                              <Yes>                                                 <No>  

                                                                                                    
    ┌──────────────────────────────────────────────────────────────────┤ Configuring kexec-tools ├───────────────────────────────────────────────────────────────────┐    
    │                                                                                                                                                                │    
    │ If you choose this option, a system reboot will trigger a restart into a kernel loaded by kexec instead of going through the full system boot loader process.  │    
    │                                                                                                                                                                │    
    │ Should kexec-tools handle reboots (sysvinit only)?                                                                                                             │    
    │                                                                                                                                                                │    
    │                                                 <Yes>                                                    <No>   
(Reading database ... 112408 files and directories currently installed.)
Preparing to unpack .../base-files_9.4ubuntu4.8_amd64.deb ...
Unpacking base-files (9.4ubuntu4.8) over (9.4ubuntu4.2) ...
Processing triggers for plymouth-theme-ubuntu-text (0.9.2-3ubuntu13.1) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for install-info (6.1.0.dfsg.1-5) ...
Processing triggers for initramfs-tools (0.122ubuntu8.1) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-53-generic
cryptsetup: WARNING: failed to detect canonical device of /dev/vda1
cryptsetup: WARNING: could not determine root device from /etc/fstab
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
Setting up base-files (9.4ubuntu4.8) ...
Installing new version of config file /etc/issue ...
Installing new version of config file /etc/issue.net ...
Installing new version of config file /etc/lsb-release ...
Processing triggers for plymouth-theme-ubuntu-text (0.9.2-3ubuntu13.1) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.122ubuntu8.1) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-53-generic
cryptsetup: WARNING: failed to detect canonical device of /dev/vda1
cryptsetup: WARNING: could not determine root device from /etc/fstab
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
(Reading database ... 112408 files and directories currently installed.)
Preparing to unpack .../bash_4.3-14ubuntu1.3_amd64.deb ...
Unpacking bash (4.3-14ubuntu1.3) over (4.3-14ubuntu1.1) ...
Processing triggers for install-info (6.1.0.dfsg.1-5) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up bash (4.3-14ubuntu1.3) ...
update-alternatives: using /usr/share/man/man7/bash-builtins.7.gz to provide /usr/share/man/man7/builtins.7.gz (builtins.7.gz) in auto mode
(Reading database ... 112408 files and directories currently installed.)
Preparing to unpack .../bsdutils_1%3a2.27.1-6ubuntu3.7_amd64.deb ...
Unpacking bsdutils (1:2.27.1-6ubuntu3.7) over (1:2.27.1-6ubuntu3.1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up bsdutils (1:2.27.1-6ubuntu3.7) ...
(Reading database ... 112408 files and directories currently installed.)
Preparing to unpack .../coreutils_8.25-2ubuntu3~16.04_amd64.deb ...
Unpacking coreutils (8.25-2ubuntu3~16.04) over (8.25-2ubuntu2) ...
Processing triggers for install-info (6.1.0.dfsg.1-5) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up coreutils (8.25-2ubuntu3~16.04) ...
(Reading database ... 112408 files and directories currently installed.)
Preparing to unpack .../dpkg_1.18.4ubuntu1.5_amd64.deb ...
Unpacking dpkg (1.18.4ubuntu1.5) over (1.18.4ubuntu1.1) ...
Setting up dpkg (1.18.4ubuntu1.5) ...
Processing triggers for man-db (2.7.5-1) ...
(Reading database ... 112408 files and directories currently installed.)
Preparing to unpack .../libperl5.22_5.22.1-9ubuntu0.6_amd64.deb ...
Unpacking libperl5.22:amd64 (5.22.1-9ubuntu0.6) over (5.22.1-9) ...
。。。
。。。
Unpacking linux-generic (4.4.0.150.158) over (4.4.0.53.56) ...
Preparing to unpack .../linux-image-generic_4.4.0.150.158_amd64.deb ...
Unpacking linux-image-generic (4.4.0.150.158) over (4.4.0.53.56) ...
Selecting previously unselected package linux-headers-4.4.0-150.
Preparing to unpack .../linux-headers-4.4.0-150_4.4.0-150.176_all.deb ...
Unpacking linux-headers-4.4.0-150 (4.4.0-150.176) ...
Selecting previously unselected package linux-headers-4.4.0-150-generic.
Preparing to unpack .../linux-headers-4.4.0-150-generic_4.4.0-150.176_amd64.deb ...
Unpacking linux-headers-4.4.0-150-generic (4.4.0-150.176) ...
Preparing to unpack .../linux-headers-generic_4.4.0.150.158_amd64.deb ...
。。。。。
software installation – dpkg: error processing package mysql-server (–configure): dependency problems – leaving unconfigured – Ask Ubuntu
Error while installing mysql-server in ubuntu 16.04 – Ask Ubuntu
server – Unable to install or remove MySQL – Ask Ubuntu
原因找到了:
之前混装了 MariaDB和MySQL,冲突了。
(最大可能相关的地方是:装mysql-server之前先安装了mariadb-server)
解决办法是:
根据帖子解释是:
重新安装mysql
重要提示:先备份之前mysql数据,否则后续会被清空
完全清空之前mysql:
sudo apt purge mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server-5.7 mysql-server-core-5.7 mysql-server

再去:
sudo apt update && sudo apt dist-upgrade && sudo apt autoremove && sudo apt -f install
最后重新安装:
sudo apt install mysql-server


后来ssh都断开连接了,重连再去试试:
# sudo apt-get dist-upgrade
E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
E: Could not get lock /var/lib/dpkg/lock-frontend – open (11: Resource temporarily unavailable)
[Solved] Could not get lock /var/lib/dpkg/lock Error in Ubuntu
apt – E: Could not get lock /var/lib/dpkg/lock-frontend – open (11: Resource temporarily unavailable) – Ask Ubuntu
# sudo killall apt apt-get
apt: no process found
[email protected]:~# sudo killall apt apt-get
apt: no process found
apt-get: no process found
另外错误:
# sudo apt-get dist-upgrade
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 
然后:
# sudo dpkg --configure -a
Setting up python-apt-common (1.1.0~beta1ubuntu0.16.04.5) ...
Setting up libgs9-common (9.26~dfsg+0-0ubuntu0.16.04.9) ...


update-alternatives: warning: alternative /usr/share/ghostscript/9.18 (part of link group ghostscript-current) doesn't exist; removing from list of alternatives
update-alternatives: warning: /etc/alternatives/ghostscript-current is dangling; it will be updated with best choice
update-alternatives: using /usr/share/ghostscript/9.26 to provide /usr/share/ghostscript/current (ghostscript-current) in auto mode
Setting up ubuntu-advantage-tools (10ubuntu0.16.04.1) ...
Setting up makedev (2.3.1-93ubuntu2~ubuntu16.04.1) ...
Setting up cloud-guest-utils (0.27-0ubuntu25.1) ...
Setting up libapt-inst2.0:amd64 (1.2.32) ...
Setting up libnettle6:amd64 (3.2-1ubuntu0.16.04.1) ...
Setting up git-man (1:2.7.4-0ubuntu1.6) ...
Setting up libicu55:amd64 (55.1-7ubuntu0.4) ...
Setting up keyboard-configuration (1.108ubuntu15.5) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-initramfs: deferring update (trigger activated)
Setting up libwbclient0:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.21) ...
Setting up kmod (22-1ubuntu5.2) ...
Installing new version of config file /etc/modprobe.d/blacklist.conf ...
Setting up libparted2:amd64 (3.2-15ubuntu0.1) ...
Setting up less (481-2.1ubuntu0.2) ...
Setting up libgtk2.0-common (2.24.30-1ubuntu1.16.04.2) ...
Setting up python-crypto (2.6.1-6ubuntu0.16.04.3) ...
Setting up vlan (1.9-3.2ubuntu1.16.04.5) ...
Installing new version of config file /etc/network/if-pre-up.d/vlan ...
Installing new version of config file /etc/network/if-up.d/ip ...
Setting up ruby-loofah (2.0.3-2+deb9u2build0.16.04.1) ...
Setting up python3-apt (1.1.0~beta1ubuntu0.16.04.5) ...
Setting up libisc160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.14) ...
Setting up xfsprogs (4.3.0+nmu1ubuntu1.1) ...
update-initramfs: deferring update (trigger activated)
Setting up x11proto-core-dev (7.0.31-1~ubuntu16.04.2) ...
Setting up libmspack0:amd64 (0.5-1ubuntu0.16.04.3) ...
Setting up libssl1.0.0:amd64 (1.0.2g-1ubuntu4.15) ...
Setting up libisc-export160 (1:9.10.3.dfsg.P4-8ubuntu1.14) ...
Setting up ureadahead (0.100.0-19.1) ...
Setting up libllvm6.0:amd64 (1:6.0-1ubuntu2~16.04.1) ...
Setting up sudo (1.8.16-0ubuntu1.7) ...


Configuration file '/etc/sudoers'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** sudoers (Y/I/N/O/D/Z) [default=N] ? Y
Installing new version of config file /etc/sudoers ...
Setting up libjasper1:amd64 (1.900.1-debian1-2.4ubuntu1.2) ...
Setting up nodejs (4.2.6~dfsg-1ubuntu4.2) ...
Setting up liblcms2-2:amd64 (2.6-3ubuntu2.1) ...
Setting up isc-dhcp-common (4.3.3-5ubuntu12.10) ...
Setting up libarchive13:amd64 (3.1.2-11ubuntu0.16.04.6) ...
Setting up apt-utils (1.2.32) ...
Setting up apache2-utils (2.4.18-2ubuntu3.10) ...
Setting up libmirprotobuf3:amd64 (0.26.3+16.04.20170605-0ubuntu1.1) ...
Setting up kexec-tools (1:2.0.16-1ubuntu1~16.04.1) ...
Installing new version of config file /etc/init.d/kexec ...
Installing new version of config file /etc/init.d/kexec-load ...
Removing obsolete conffile /etc/default/grub.d/kexec-tools.cfg ...
Setting up grub-pc (2.02~beta2-36ubuntu3.22) ...
Installing for i386-pc platform.
...


┌───────────────────────────────────────────────────────────────┤ Configuring unattended-upgrades ├────────────────────────────────────────────────────────────────┐   
   │ A new version (/etc/apt/apt.conf.d/50unattended-upgrades.ucftmp) of configuration file /etc/apt/apt.conf.d/50unattended-upgrades is available, but the version   │   
   │ installed currently has been locally modified.                                                                                                                   │   
   │                                                                                                                                                                  │   
   │ What do you want to do about modified configuration file 50unattended-upgrades?                                                                                  │   
   │                                                                                                                                                                  │   
   │                                                    install the package maintainer's version                                                                      │   
   │                                                    keep the local version currently installed                                                                    │   
   │                                                    show the differences between the versions                                                                     │   
   │                                                    show a side-by-side difference between the versions                                                           │   
   │                                                    show a 3-way difference between available versions                                                            │   
   │                                                    do a 3-way merge between available versions (experimental)                                                    │   
   │                                                    start a new shell to examine the situation                                                                    │   
   │                                                                                                                                                                  │   
   │                                                                                                                                                                  │   
   │                                                                              <Ok>                                                                                │ 

...
17 added, 42 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.
Processing triggers for linux-image-4.4.0-150-generic (4.4.0-150.176) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.4.0-150-generic
cryptsetup: WARNING: failed to detect canonical device of /dev/vda1
cryptsetup: WARNING: could not determine root device from /etc/fstab
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
/etc/kernel/postinst.d/kdump-tools:
kdump-tools: Generating /var/lib/kdump/initrd.img-4.4.0-150-generic
cryptsetup: WARNING: failed to detect canonical device of /dev/vda1
cryptsetup: WARNING: could not determine root device from /etc/fstab
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
/etc/kernel/postinst.d/x-grub-legacy-ec2:
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-4.4.0-150-generic
Found kernel: /boot/vmlinuz-4.4.0-53-generic
Replacing config file /run/grub/menu.lst with new version
Found kernel: /boot/vmlinuz-4.4.0-150-generic
Found kernel: /boot/vmlinuz-4.4.0-53-generic
Updating /boot/grub/menu.lst ... done


/etc/kernel/postinst.d/zz-update-grub:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.4.0-150-generic
Found initrd image: /boot/initrd.img-4.4.0-150-generic
Found linux image: /boot/vmlinuz-4.4.0-53-generic
Found initrd image: /boot/initrd.img-4.4.0-53-generic
done
Processing triggers for php5.6-fpm (5.6.40-8+ubuntu16.04.1+deb.sury.org+1) ...
NOTICE: Not enabling PHP 5.6 FPM by default.
NOTICE: To enable PHP 5.6 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php5.6-fpm
NOTICE: You are seeing this message because you have apache2 package installed.
终于终于完成了。
再去:
sudo apt-get install mysql-server 
问题依旧:
# sudo apt-get install mysql-server 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libllvm3.8 libmircommon5 libssl1.0.2
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libcgi-fast-perl libcgi-pm-perl libencode-locale-perl libevent-core-2.0-5 libfcgi-perl libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl libhttp-date-perl
  libhttp-message-perl libio-html-perl liblwp-mediatypes-perl libtimedate-perl liburi-perl mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server-5.7
  mysql-server-core-5.7
Suggested packages:
  libdata-dump-perl libipc-sharedcache-perl libwww-perl mailx tinyca
The following NEW packages will be installed:
  libcgi-fast-perl libcgi-pm-perl libencode-locale-perl libevent-core-2.0-5 libfcgi-perl libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl libhttp-date-perl
  libhttp-message-perl libio-html-perl liblwp-mediatypes-perl libtimedate-perl liburi-perl mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server
  mysql-server-5.7 mysql-server-core-5.7
0 upgraded, 20 newly installed, 0 to remove and 0 not upgraded.
Need to get 722 kB/19.3 MB of archives.
After this operation, 162 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 mysql-common all 5.7.26-0ubuntu0.16.04.1 [15.4 kB]
Get:2 http://mirrors.tencentyun.com/ubuntu xenial-security/main amd64 libevent-core-2.0-5 amd64 2.0.21-stable-2ubuntu0.16.04.1 [70.6 kB]
Get:3 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libhtml-tagset-perl all 3.20-2 [13.5 kB]
Get:4 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 liburi-perl all 1.71-1 [76.9 kB]
Get:5 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libhtml-parser-perl amd64 3.72-1 [86.1 kB]
Get:6 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libcgi-pm-perl all 4.26-1 [185 kB]
Get:7 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libfcgi-perl amd64 0.77-1build1 [32.3 kB]
Get:8 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libcgi-fast-perl all 1:2.10-1 [10.2 kB]
Get:9 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libencode-locale-perl all 1.05-1 [12.3 kB]
Get:10 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libhtml-template-perl all 2.95-2 [60.4 kB]
Get:11 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libtimedate-perl all 2.3000-2 [37.5 kB]
Get:12 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libhttp-date-perl all 6.02-1 [10.4 kB]
Get:13 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libio-html-perl all 1.001-1 [14.9 kB]
Get:14 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 liblwp-mediatypes-perl all 6.02-1 [21.7 kB]
Get:15 http://mirrors.tencentyun.com/ubuntu xenial/main amd64 libhttp-message-perl all 6.11-1 [74.3 kB]
Fetched 722 kB in 0s (6,161 kB/s)                
Preconfiguring packages ...
Selecting previously unselected package mysql-common.
(Reading database ... 146145 files and directories currently installed.)
Preparing to unpack .../mysql-common_5.7.26-0ubuntu0.16.04.1_all.deb ...
Unpacking mysql-common (5.7.26-0ubuntu0.16.04.1) ...
Selecting previously unselected package mysql-client-core-5.7.
Preparing to unpack .../mysql-client-core-5.7_5.7.26-0ubuntu0.16.04.1_amd64.deb ...
Unpacking mysql-client-core-5.7 (5.7.26-0ubuntu0.16.04.1) ...
Selecting previously unselected package mysql-client-5.7.
Preparing to unpack .../mysql-client-5.7_5.7.26-0ubuntu0.16.04.1_amd64.deb ...
Unpacking mysql-client-5.7 (5.7.26-0ubuntu0.16.04.1) ...
Selecting previously unselected package mysql-server-core-5.7.
Preparing to unpack .../mysql-server-core-5.7_5.7.26-0ubuntu0.16.04.1_amd64.deb ...
Unpacking mysql-server-core-5.7 (5.7.26-0ubuntu0.16.04.1) ...
Selecting previously unselected package libevent-core-2.0-5:amd64.
Preparing to unpack .../libevent-core-2.0-5_2.0.21-stable-2ubuntu0.16.04.1_amd64.deb ...
Unpacking libevent-core-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
Setting up mysql-common (5.7.26-0ubuntu0.16.04.1) ...
update-alternatives: using /etc/mysql/my.cnf.fallback to provide /etc/mysql/my.cnf (my.cnf) in auto mode
Selecting previously unselected package mysql-server-5.7.
(Reading database ... 146304 files and directories currently installed.)
Preparing to unpack .../mysql-server-5.7_5.7.26-0ubuntu0.16.04.1_amd64.deb ...
Unpacking mysql-server-5.7 (5.7.26-0ubuntu0.16.04.1) ...
Selecting previously unselected package libhtml-tagset-perl.
Preparing to unpack .../libhtml-tagset-perl_3.20-2_all.deb ...
Unpacking libhtml-tagset-perl (3.20-2) ...
Selecting previously unselected package liburi-perl.
Preparing to unpack .../liburi-perl_1.71-1_all.deb ...
Unpacking liburi-perl (1.71-1) ...
Selecting previously unselected package libhtml-parser-perl.
Preparing to unpack .../libhtml-parser-perl_3.72-1_amd64.deb ...
Unpacking libhtml-parser-perl (3.72-1) ...
Selecting previously unselected package libcgi-pm-perl.
Preparing to unpack .../libcgi-pm-perl_4.26-1_all.deb ...
Unpacking libcgi-pm-perl (4.26-1) ...
Selecting previously unselected package libfcgi-perl.
Preparing to unpack .../libfcgi-perl_0.77-1build1_amd64.deb ...
Unpacking libfcgi-perl (0.77-1build1) ...
Selecting previously unselected package libcgi-fast-perl.
Preparing to unpack .../libcgi-fast-perl_1%3a2.10-1_all.deb ...
Unpacking libcgi-fast-perl (1:2.10-1) ...
Selecting previously unselected package libencode-locale-perl.
Preparing to unpack .../libencode-locale-perl_1.05-1_all.deb ...
Unpacking libencode-locale-perl (1.05-1) ...
Selecting previously unselected package libhtml-template-perl.
Preparing to unpack .../libhtml-template-perl_2.95-2_all.deb ...
Unpacking libhtml-template-perl (2.95-2) ...
Selecting previously unselected package libtimedate-perl.
Preparing to unpack .../libtimedate-perl_2.3000-2_all.deb ...
Unpacking libtimedate-perl (2.3000-2) ...
Selecting previously unselected package libhttp-date-perl.
Preparing to unpack .../libhttp-date-perl_6.02-1_all.deb ...
Unpacking libhttp-date-perl (6.02-1) ...
Selecting previously unselected package libio-html-perl.
Preparing to unpack .../libio-html-perl_1.001-1_all.deb ...
Unpacking libio-html-perl (1.001-1) ...
Selecting previously unselected package liblwp-mediatypes-perl.
Preparing to unpack .../liblwp-mediatypes-perl_6.02-1_all.deb ...
Unpacking liblwp-mediatypes-perl (6.02-1) ...
Selecting previously unselected package libhttp-message-perl.
Preparing to unpack .../libhttp-message-perl_6.11-1_all.deb ...
Unpacking libhttp-message-perl (6.11-1) ...
Selecting previously unselected package mysql-server.
Preparing to unpack .../mysql-server_5.7.26-0ubuntu0.16.04.1_all.deb ...
Unpacking mysql-server (5.7.26-0ubuntu0.16.04.1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for ureadahead (0.100.0-19.1) ...
Processing triggers for systemd (229-4ubuntu21.21) ...
Setting up mysql-client-core-5.7 (5.7.26-0ubuntu0.16.04.1) ...
Setting up mysql-client-5.7 (5.7.26-0ubuntu0.16.04.1) ...
Setting up mysql-server-core-5.7 (5.7.26-0ubuntu0.16.04.1) ...
Setting up libevent-core-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Setting up mysql-server-5.7 (5.7.26-0ubuntu0.16.04.1) ...
update-alternatives: using /etc/mysql/mysql.cnf to provide /etc/mysql/my.cnf (my.cnf) in auto mode
Renaming removed key_buffer and myisam-recover options (if present)
mysql_upgrade: Got error: 1045: Access denied for user 'debian-sys-maint'@'localhost' (using password: YES) while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: error processing package mysql-server-5.7 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up libhtml-tagset-perl (3.20-2) ...
Setting up liburi-perl (1.71-1) ...
Setting up libhtml-parser-perl (3.72-1) ...
Setting up libcgi-pm-perl (4.26-1) ...
Setting up libfcgi-perl (0.77-1build1) ...
Setting up libcgi-fast-perl (1:2.10-1) ...
Setting up libencode-locale-perl (1.05-1) ...
Setting up libhtml-template-perl (2.95-2) ...
Setting up libtimedate-perl (2.3000-2) ...
Setting up libhttp-date-perl (6.02-1) ...
Setting up libio-html-perl (1.001-1) ...
Setting up liblwp-mediatypes-perl (6.02-1) ...
Setting up libhttp-message-perl (6.11-1) ...
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.7; however:
  Package mysql-server-5.7 is not configured yet.


dpkg: error processing package mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Processing triggers for libc-bin (2.23-0ubuntu11) ...
Processing triggers for ureadahead (0.100.0-19.1) ...
Processing triggers for systemd (229-4ubuntu21.21) ...
Errors were encountered while processing:
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

转载请注明:在路上 » 【未解决】Ubuntu中apt-get安装报错:dpkg: error processing package mysql-server

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
85 queries in 0.122 seconds, using 20.83MB memory