最新消息:20210816 当前crifan.com域名已被污染,为防止失联,请关注(页面右下角的)公众号

【已解决】Fabric的三个版本fabric1、fabric2和fabric3的区别

版本 crifan 720浏览 0评论
折腾:
【已解决】Mac中安装并试用Fabric
期间,看到:
Python – Fabric简介 – Anliven – 博客园
说Fabric有3个版本,但是看官网:
Welcome to Fabric! — Fabric documentation
Welcome to Fabric’s documentation! — Fabric documentation
好像没提到有Fabric 3啊,所以去看看:
fabric 3 vs fabric 2
Clarify fabric vs fabric2 vs fabric3 differences · Issue #1791 · fabric/fabric
分别去看看:
https://pypi.org/project/Fabric/
https://pypi.org/project/fabric2/
https://pypi.org/project/Fabric3/
-》
结论很简单了:
https://pypi.org/project/Fabric/
pip install Fabric
https://pypi.org/project/fabric2/
pip install fabric2
是同一个东西
https://pypi.org/project/Fabric3/
pip install Fabric3
是:最早当Fabric不支持Python3的时候,别人Fork了Fabric,加了Python3的支持
-》而最新的对待Fabric3的态度是:
忽略不计,不用考虑
因为官网的Fabric现在已经是2.x的版本了,且已经支持了Python 3+和2.7了。
而从官网的Fabric2的版本更新历史:
https://www.fabfile.org/changelog.html
可见:
最早是1.x:官网不建议使用,建议你升级到最新的2.x了
接着就是2.0.0,直到现在的2.3.1
Python 3 support · Issue #1424 · fabric/fabric
后来才注意到,其实Fabric官网中也提到了Fabric3:
Running both Fabric versions simultaneously
“fabric2 as a distinct package and module is intended to be a stopgap, and there will not be any fabric3 or above (not least because some of those names are already taken!)”
意思是:
fabric2(由于改动很大),为了和之前的fabric 1区别开来,所以单独弄了个fabric2的包
而以后(即使版本再升级,比如到了3.x)也不会再弄出来个fabric3了
因为fabric3名字已经被别人,也就是:
https://pypi.org/project/Fabric3/
占用了。
【总结】
Fabric1,Fabric2,Fabric3,分别对应着python官网发布的地址:
https://pypi.org/project/Fabric/
https://pypi.org/project/fabric2/
https://pypi.org/project/Fabric3/
安装方式分别是:
pip install Fabric
pip install fabric2
pip install fabric3
而结论是:
  • Fabric1和Fabric2,在pypi中的页面,就是同一个东西:
    • 都是Fabric的最新版:Fabric 2.x
      • 截至到20180817,安装出来的版本是:2.3.1
    • 而官网之所以弄出来个Fabric2是因为:
    • Fabric2和Fabric1相比,完全重写了,接口和功能都有很大改动
      • 官网也不建议你继续用Fabric1,建议升级到Fabric2
      • 最新版也早就支持Python 3.4+,和之前的Python2.7
  • 而Fabric3,是非官网的
    • 是当之前Fabric1还没有支持Python3时,别人去fork出来,加了Python 3的支持的
    • 现在好像基本上不维护了
总结一下态度就是:
  • 尽量用最新的Fabric2
    • Mac中用brew install fabric,已经是最新的2.3.1版本了
    • 如果pip install的话,应该是:
    • pip install fabric
    • pip install fabric2
    • 都是最新版本
  • 尽量不要用之前旧的版本的Fabric1了
    • 如果还在用,建议升级到最新的Fabric2
  • 不需要操心、忽略掉,所谓的、非官网的,现在已没价值的:Fabric3

转载请注明:在路上 » 【已解决】Fabric的三个版本fabric1、fabric2和fabric3的区别

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
93 queries in 0.135 seconds, using 20.56MB memory