最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【已解决】VSCode中运行Jupyter报错:Error Data Science libraries notebook and jupyter are not installed

VSCode crifan 59浏览 0评论
折腾:
【未解决】VSCode中调试Notebook的ipynb文件中的Python代码
期间,点击第一个按钮后,报错:
Error: Jupyter cannot be started. Error attempting to locate jupyter: Data Science libraries notebook and jupyter are not installed in interpreter Python 3.7.3 64-bit. at A.startServer (/Users/crifan/.vscode/extensions/ms-python.python-2020.2.64397/out/client/extension.js:1:786120) at async A.ensureServerAndNotebookImpl (/Users/crifan/.vscode/extensions/ms-python.python-2020.2.64397/out/client/extension.js:1:785575) at async A.ensureServerAndNotebook (/Users/crifan/.vscode/extensions/ms-python.python-2020.2.64397/out/client/extension.js:1:785376) at async A.submitCode (/Users/crifan/.vscode/extensions/ms-python.python-2020.2.64397/out/client/extension.js:1:782328) at async A.reexecuteCell (/Users/crifan/.vscode/extensions/ms-python.python-2020.2.64397/out/client/extension.js:75:879318)
弹出提示,问是否要安装: 
Data Science libraries jupyter and notebook are not installed in interpreter Python 3.7.3 64-bit.
点击Install
下载好慢,最后终于安装好了:
/usr/local/opt/python/bin/python3.7 /Users/crifan/.vscode/extensions/ms-python.python-2020.2.64397/pythonFiles/shell_exec.py /usr/local/opt/python/bin/python3.7 -m pip install -U jupyter --user /var/folders/46/2hjxz38n22n3ypp_5f6_p__00000gn/T/tmp-412388jzJPPLmKDly.log
➜  debugNotebook /usr/local/opt/python/bin/python3.7 /Users/crifan/.vscode/extensions/ms-python.python-2020.2.64397/pythonFiles/shell_exec.py /usr/local/opt/python/bin/python3.7 -m pip install -U jupyter --user /var/folders/46/2hjxz38n22n3ypp_5f6_p__00000gn/T/tmp-412388jzJPPLmKDly.log
Executing command in shell >> /usr/local/opt/python/bin/python3.7 -m pip install -U jupyter --user
Collecting jupyter
  Downloading jupyter-1.0.0-py2.py3-none-any.whl (2.7 kB)
Collecting qtconsole
  Downloading qtconsole-4.6.0-py2.py3-none-any.whl (121 kB)
     |████████████████████████████████| 121 kB 16 kB/s 
Collecting nbconvert
  Downloading nbconvert-5.6.1-py2.py3-none-any.whl (455 kB)
     |████████████████████████████████| 455 kB 8.7 kB/s 
Collecting jupyter-console
  Downloading jupyter_console-6.1.0-py2.py3-none-any.whl (21 kB)
Collecting notebook
  Downloading notebook-6.0.3-py3-none-any.whl (9.7 MB)
     |████████████████████████████████| 9.7 MB 8.9 kB/s 
WARNING: Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ReadTimeoutError("HTTPSConnectionPool(host='
pypi.org
', port=443): Read timed out. (read timeout=15)")': /simple/ipywidgets/
Collecting ipywidgets
  Downloading ipywidgets-7.5.1-py2.py3-none-any.whl (121 kB)
     |████████████████████████████████| 121 kB 6.4 kB/s 
Collecting ipykernel
  Downloading ipykernel-5.1.4-py3-none-any.whl (116 kB)
     |████████████████████████████████| 116 kB 9.5 kB/s 
Collecting ipython-genutils
  Downloading ipython_genutils-0.2.0-py2.py3-none-any.whl (26 kB)
Collecting jupyter-client>=4.1
  Downloading jupyter_client-6.0.0-py3-none-any.whl (104 kB)
     |████████████████████████████████| 104 kB 14 kB/s 
Collecting pygments
  Downloading Pygments-2.5.2-py2.py3-none-any.whl (896 kB)
     |████████████████████████████████| 896 kB 13 kB/s 
Collecting jupyter-core
  Downloading jupyter_core-4.6.3-py2.py3-none-any.whl (83 kB)
     |████████████████████████████████| 83 kB 11 kB/s 
Collecting traitlets
  Downloading traitlets-4.3.3-py2.py3-none-any.whl (75 kB)
     |████████████████████████████████| 75 kB 10 kB/s 
Collecting bleach
  Downloading bleach-3.1.1-py2.py3-none-any.whl (150 kB)
     |████████████████████████████████| 150 kB 6.6 kB/s 
Collecting jinja2>=2.4
  Downloading Jinja2-2.11.1-py2.py3-none-any.whl (126 kB)
     |████████████████████████████████| 126 kB 8.3 kB/s 
Collecting entrypoints>=0.2.2
  Downloading entrypoints-0.3-py2.py3-none-any.whl (11 kB)
Collecting mistune<2,>=0.8.1
  Downloading mistune-0.8.4-py2.py3-none-any.whl (16 kB)
Collecting nbformat>=4.4
  Downloading nbformat-5.0.4-py3-none-any.whl (169 kB)
     |████████████████████████████████| 169 kB 8.8 kB/s 
Collecting defusedxml
  Downloading defusedxml-0.6.0-py2.py3-none-any.whl (23 kB)
Collecting testpath
  Downloading testpath-0.4.4-py2.py3-none-any.whl (163 kB)
     |████████████████████████████████| 163 kB 6.8 kB/s 
Collecting pandocfilters>=1.4.1
  Downloading pandocfilters-1.4.2.tar.gz (14 kB)
Collecting prompt-toolkit!=3.0.0,!=3.0.1,<3.1.0,>=2.0.0
  Downloading prompt_toolkit-3.0.3-py3-none-any.whl (348 kB)
     |████████████████████████████████| 348 kB 13 kB/s 
Collecting ipython
  Downloading ipython-7.12.0-py3-none-any.whl (777 kB)
     |████████████████████████████████| 777 kB 9.8 kB/s 
Collecting tornado>=5.0
  Downloading tornado-6.0.3.tar.gz (482 kB)
     |████████████████████████████████| 482 kB 8.3 kB/s 
Collecting Send2Trash
  Downloading Send2Trash-1.5.0-py3-none-any.whl (12 kB)
Collecting terminado>=0.8.1
  Downloading terminado-0.8.3-py2.py3-none-any.whl (33 kB)
Collecting prometheus-client
  Downloading prometheus_client-0.7.1.tar.gz (38 kB)
Collecting pyzmq>=17
  Downloading pyzmq-19.0.0-cp37-cp37m-macosx_10_9_x86_64.whl (815 kB)
     |████████████████████████████████| 815 kB 8.0 kB/s 
Collecting widgetsnbextension~=3.5.0
  Downloading widgetsnbextension-3.5.1-py2.py3-none-any.whl (2.2 MB)
     |████████████████████████████████| 2.2 MB 5.3 kB/s 
Collecting appnope; platform_system == "Darwin"
  Downloading appnope-0.1.0-py2.py3-none-any.whl (4.0 kB)
Collecting python-dateutil>=2.1
  Downloading python_dateutil-2.8.1-py2.py3-none-any.whl (227 kB)
     |████████████████████████████████| 227 kB 7.2 kB/s 
Collecting decorator
  Downloading decorator-4.4.1-py2.py3-none-any.whl (9.2 kB)
Requirement already satisfied, skipping upgrade: six in /usr/local/lib/python3.7/site-packages (from traitlets->qtconsole->jupyter) (1.12.0)
Collecting webencodings
  Downloading webencodings-0.5.1-py2.py3-none-any.whl (11 kB)
Collecting MarkupSafe>=0.23
  Downloading MarkupSafe-1.1.1-cp37-cp37m-macosx_10_6_intel.whl (18 kB)
Collecting jsonschema!=2.5.0,>=2.4
  Downloading jsonschema-3.2.0-py2.py3-none-any.whl (56 kB)
     |████████████████████████████████| 56 kB 6.5 kB/s 
Collecting wcwidth
  Downloading wcwidth-0.1.8-py2.py3-none-any.whl (17 kB)
Collecting pexpect; sys_platform != "win32"
  Downloading pexpect-4.8.0-py2.py3-none-any.whl (59 kB)
     |████████████████████████████████| 59 kB 7.4 kB/s 
Collecting jedi>=0.10
  Downloading jedi-0.16.0-py2.py3-none-any.whl (1.1 MB)
     |████████████████████████████████| 1.1 MB 9.4 kB/s 
Collecting pickleshare
  Downloading pickleshare-0.7.5-py2.py3-none-any.whl (6.9 kB)
Collecting backcall
  Downloading backcall-0.1.0.tar.gz (9.7 kB)
Requirement already satisfied, skipping upgrade: setuptools>=18.5 in /usr/local/lib/python3.7/site-packages (from ipython->jupyter-console->jupyter) (40.8.0)
Collecting ptyprocess; os_name != "nt"
  Downloading ptyprocess-0.6.0-py2.py3-none-any.whl (39 kB)
Collecting attrs>=17.4.0
  Downloading attrs-19.3.0-py2.py3-none-any.whl (39 kB)
Collecting importlib-metadata; python_version < "3.8"
  Downloading importlib_metadata-1.5.0-py2.py3-none-any.whl (30 kB)
Collecting pyrsistent>=0.14.0
  WARNING: Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ReadTimeoutError("HTTPSConnectionPool(host='
files.pythonhosted.org
', port=443): Read timed out. (read timeout=15)")': /packages/90/aa/cdcf7ef88cc0f831b6f14c8c57318824c9de9913fe8de38e46a98c069a35/pyrsistent-0.15.7.tar.gz
  Downloading pyrsistent-0.15.7.tar.gz (107 kB)
     |████████████████████████████████| 107 kB 10 kB/s 
Collecting parso>=0.5.2
  Downloading parso-0.6.1-py2.py3-none-any.whl (97 kB)
     |████████████████████████████████| 97 kB 9.5 kB/s 
Collecting zipp>=0.5
  Downloading zipp-3.0.0-py3-none-any.whl (4.8 kB)
Building wheels for collected packages: pandocfilters, tornado, prometheus-client, backcall, pyrsistent
  Building wheel for pandocfilters (setup.py) ... done
  Created wheel for pandocfilters: filename=pandocfilters-1.4.2-py3-none-any.whl size=7855 sha256=c88845458b73d1e76845eb95e2f80e6244a5c5f56c0113d867334617ac096384
  Stored in directory: /Users/crifan/Library/Caches/pip/wheels/63/99/01/9fe785b86d1e091a6b2a61e06ddb3d8eb1bc9acae5933d4740
  Building wheel for tornado (setup.py) ... done
  Created wheel for tornado: filename=tornado-6.0.3-cp37-cp37m-macosx_10_14_x86_64.whl size=412726 sha256=250f7906d8911c878f511f3e668efd25dc4b9baa939529c73b277f66bf18e726
  Stored in directory: /Users/crifan/Library/Caches/pip/wheels/d0/31/2c/9406ed59f0dcdce0c453a8664124d738551590e74fc087f604
  Building wheel for prometheus-client (setup.py) ... done
  Created wheel for prometheus-client: filename=prometheus_client-0.7.1-py3-none-any.whl size=41401 sha256=7adf55cbb63ce5e5aba366c3410865960c09a43c583dc69f9e329d2559dfdffc
  Stored in directory: /Users/crifan/Library/Caches/pip/wheels/30/0c/26/59ba285bf65dc79d195e9b25e2ddde4c61070422729b0cd914
  Building wheel for backcall (setup.py) ... done
  Created wheel for backcall: filename=backcall-0.1.0-py3-none-any.whl size=10413 sha256=65a84b2f916c6cff6a253c5461dfef87b5cddd870ec5144280ffefbb3734eec4
  Stored in directory: /Users/crifan/Library/Caches/pip/wheels/9e/56/4f/da13e448a8a5b8671b2954600d5355cf36e557c7aa5020139b
  Building wheel for pyrsistent (setup.py) ... done
  Created wheel for pyrsistent: filename=pyrsistent-0.15.7-cp37-cp37m-macosx_10_14_x86_64.whl size=68883 sha256=eb2c5b3111528afcf7609f6a70582298235c902f6053457da844848299501e8b
  Stored in directory: /Users/crifan/Library/Caches/pip/wheels/57/74/e3/61db397ec89f304e49711ec9f68490f15814b80c1c0ee9b8c0
Successfully built pandocfilters tornado prometheus-client backcall pyrsistent
Installing collected packages: decorator, ipython-genutils, traitlets, wcwidth, prompt-toolkit, ptyprocess, pexpect, parso, jedi, pickleshare, backcall, pygments, appnope, ipython, tornado, pyzmq, jupyter-core, python-dateutil, jupyter-client, ipykernel, qtconsole, webencodings, bleach, MarkupSafe, jinja2, entrypoints, mistune, attrs, zipp, importlib-metadata, pyrsistent, jsonschema, nbformat, defusedxml, testpath, pandocfilters, nbconvert, jupyter-console, Send2Trash, terminado, prometheus-client, notebook, widgetsnbextension, ipywidgets, jupyter
  WARNING: The script pygmentize is installed in '/Users/crifan/Library/Python/3.7/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  NOTE: The current PATH contains path(s) starting with `~`, which may not be expanded by all applications.
  WARNING: The scripts iptest, iptest3, ipython and ipython3 are installed in '/Users/crifan/Library/Python/3.7/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  NOTE: The current PATH contains path(s) starting with `~`, which may not be expanded by all applications.
  WARNING: The scripts jupyter, jupyter-migrate and jupyter-troubleshoot are installed in '/Users/crifan/Library/Python/3.7/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  NOTE: The current PATH contains path(s) starting with `~`, which may not be expanded by all applications.
  WARNING: The scripts jupyter-kernel, jupyter-kernelspec and jupyter-run are installed in '/Users/crifan/Library/Python/3.7/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  NOTE: The current PATH contains path(s) starting with `~`, which may not be expanded by all applications.
  WARNING: The script jsonschema is installed in '/Users/crifan/Library/Python/3.7/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  NOTE: The current PATH contains path(s) starting with `~`, which may not be expanded by all applications.
  WARNING: The script jupyter-trust is installed in '/Users/crifan/Library/Python/3.7/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  NOTE: The current PATH contains path(s) starting with `~`, which may not be expanded by all applications.
  WARNING: The script jupyter-nbconvert is installed in '/Users/crifan/Library/Python/3.7/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  NOTE: The current PATH contains path(s) starting with `~`, which may not be expanded by all applications.
  WARNING: The script jupyter-console is installed in '/Users/crifan/Library/Python/3.7/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  NOTE: The current PATH contains path(s) starting with `~`, which may not be expanded by all applications.
  WARNING: The scripts jupyter-bundlerextension, jupyter-nbextension, jupyter-notebook and jupyter-serverextension are installed in '/Users/crifan/Library/Python/3.7/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  NOTE: The current PATH contains path(s) starting with `~`, which may not be expanded by all applications.
Successfully installed MarkupSafe-1.1.1 Send2Trash-1.5.0 appnope-0.1.0 attrs-19.3.0 backcall-0.1.0 bleach-3.1.1 decorator-4.4.1 defusedxml-0.6.0 entrypoints-0.3 importlib-metadata-1.5.0 ipykernel-5.1.4 ipython-7.12.0 ipython-genutils-0.2.0 ipywidgets-7.5.1 jedi-0.16.0 jinja2-2.11.1 jsonschema-3.2.0 jupyter-1.0.0 jupyter-client-6.0.0 jupyter-console-6.1.0 jupyter-core-4.6.3 mistune-0.8.4 nbconvert-5.6.1 nbformat-5.0.4 notebook-6.0.3 pandocfilters-1.4.2 parso-0.6.1 pexpect-4.8.0 pickleshare-0.7.5 prometheus-client-0.7.1 prompt-toolkit-3.0.3 ptyprocess-0.6.0 pygments-2.5.2 pyrsistent-0.15.7 python-dateutil-2.8.1 pyzmq-19.0.0 qtconsole-4.6.0 terminado-0.8.3 testpath-0.4.4 tornado-6.0.3 traitlets-4.3.3 wcwidth-0.1.8 webencodings-0.5.1 widgetsnbextension-3.5.1 zipp-3.0.0
➜  debugNotebook /usr/local/opt/python/bin/python3.7 /Users/crifan/.vscode/extensions/ms-python.python-2020.2.64397/pythonFiles/shell_exec.py /usr/local/opt/python/bin/python3.7 -m pip install -U notebook --user /var/folders/46/2hjxz38n22n3ypp_5f6_p__00000gn/T/tmp-41238d7HFbUx2l47R.log
Executing command in shell >> /usr/local/opt/python/bin/python3.7 -m pip install -U notebook --user
Requirement already up-to-date: notebook in /Users/crifan/Library/Python/3.7/lib/python/site-packages (6.0.3)
Requirement already satisfied, skipping upgrade: tornado>=5.0 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (6.0.3)
Requirement already satisfied, skipping upgrade: Send2Trash in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (1.5.0)
Requirement already satisfied, skipping upgrade: prometheus-client in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (0.7.1)
Requirement already satisfied, skipping upgrade: jupyter-core>=4.6.1 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (4.6.3)
Requirement already satisfied, skipping upgrade: nbformat in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (5.0.4)
Requirement already satisfied, skipping upgrade: terminado>=0.8.1 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (0.8.3)
Requirement already satisfied, skipping upgrade: pyzmq>=17 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (19.0.0)
Requirement already satisfied, skipping upgrade: ipykernel in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (5.1.4)
Requirement already satisfied, skipping upgrade: ipython-genutils in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (0.2.0)
Requirement already satisfied, skipping upgrade: nbconvert in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (5.6.1)
Requirement already satisfied, skipping upgrade: jupyter-client>=5.3.4 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (6.0.0)
Requirement already satisfied, skipping upgrade: jinja2 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (2.11.1)
Requirement already satisfied, skipping upgrade: traitlets>=4.2.1 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from notebook) (4.3.3)
Requirement already satisfied, skipping upgrade: jsonschema!=2.5.0,>=2.4 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from nbformat->notebook) (3.2.0)
Requirement already satisfied, skipping upgrade: ptyprocess; os_name != "nt" in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from terminado>=0.8.1->notebook) (0.6.0)
Requirement already satisfied, skipping upgrade: ipython>=5.0.0 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from ipykernel->notebook) (7.12.0)
Requirement already satisfied, skipping upgrade: appnope; platform_system == "Darwin" in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from ipykernel->notebook) (0.1.0)
Requirement already satisfied, skipping upgrade: mistune<2,>=0.8.1 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from nbconvert->notebook) (0.8.4)
Requirement already satisfied, skipping upgrade: bleach in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from nbconvert->notebook) (3.1.1)
Requirement already satisfied, skipping upgrade: entrypoints>=0.2.2 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from nbconvert->notebook) (0.3)
Requirement already satisfied, skipping upgrade: testpath in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from nbconvert->notebook) (0.4.4)
Requirement already satisfied, skipping upgrade: defusedxml in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from nbconvert->notebook) (0.6.0)
Requirement already satisfied, skipping upgrade: pygments in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from nbconvert->notebook) (2.5.2)
Requirement already satisfied, skipping upgrade: pandocfilters>=1.4.1 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from nbconvert->notebook) (1.4.2)
Requirement already satisfied, skipping upgrade: python-dateutil>=2.1 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from jupyter-client>=5.3.4->notebook) (2.8.1)
Requirement already satisfied, skipping upgrade: MarkupSafe>=0.23 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from jinja2->notebook) (1.1.1)
Requirement already satisfied, skipping upgrade: decorator in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from traitlets>=4.2.1->notebook) (4.4.1)
Requirement already satisfied, skipping upgrade: six in /usr/local/lib/python3.7/site-packages (from traitlets>=4.2.1->notebook) (1.12.0)
Requirement already satisfied, skipping upgrade: importlib-metadata; python_version < "3.8" in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from jsonschema!=2.5.0,>=2.4->nbformat->notebook) (1.5.0)
Requirement already satisfied, skipping upgrade: attrs>=17.4.0 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from jsonschema!=2.5.0,>=2.4->nbformat->notebook) (19.3.0)
Requirement already satisfied, skipping upgrade: pyrsistent>=0.14.0 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from jsonschema!=2.5.0,>=2.4->nbformat->notebook) (0.15.7)
Requirement already satisfied, skipping upgrade: setuptools in /usr/local/lib/python3.7/site-packages (from jsonschema!=2.5.0,>=2.4->nbformat->notebook) (40.8.0)
Requirement already satisfied, skipping upgrade: pexpect; sys_platform != "win32" in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from ipython>=5.0.0->ipykernel->notebook) (4.8.0)
Requirement already satisfied, skipping upgrade: jedi>=0.10 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from ipython>=5.0.0->ipykernel->notebook) (0.16.0)
Requirement already satisfied, skipping upgrade: prompt-toolkit!=3.0.0,!=3.0.1,<3.1.0,>=2.0.0 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from ipython>=5.0.0->ipykernel->notebook) (3.0.3)
Requirement already satisfied, skipping upgrade: pickleshare in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from ipython>=5.0.0->ipykernel->notebook) (0.7.5)
Requirement already satisfied, skipping upgrade: backcall in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from ipython>=5.0.0->ipykernel->notebook) (0.1.0)
Requirement already satisfied, skipping upgrade: webencodings in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from bleach->nbconvert->notebook) (0.5.1)
Requirement already satisfied, skipping upgrade: zipp>=0.5 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from importlib-metadata; python_version < "3.8"->jsonschema!=2.5.0,>=2.4->nbformat->notebook) (3.0.0)
Requirement already satisfied, skipping upgrade: parso>=0.5.2 in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from jedi>=0.10->ipython>=5.0.0->ipykernel->notebook) (0.6.1)
Requirement already satisfied, skipping upgrade: wcwidth in /Users/crifan/Library/Python/3.7/lib/python/site-packages (from prompt-toolkit!=3.0.0,!=3.0.1,<3.1.0,>=2.0.0->ipython>=5.0.0->ipykernel->notebook) (0.1.8)
【总结】
此处运行报错
Error: Jupyter cannot be started. Error attempting to locate jupyter: Data Science libraries notebook and jupyter are not installed in interpreter Python 3.7.3 64-bit.
的原因是:
notebook和jupyter都没有安装。根据VSCode的提示,点击Install,去安装(等待足够长时间)后,即可。

转载请注明:在路上 » 【已解决】VSCode中运行Jupyter报错:Error Data Science libraries notebook and jupyter are not installed

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
18 queries in 0.085 seconds, using 9.44MB memory