最新消息:VPS服务器又从fzhost.net换回Linode了,主题仍用朋友推荐的大前端D8

【未解决】升级CocoaPods:CocoaPods is available To update use

Cocoapods crifan 757浏览 0评论

折腾:

【未解决】Cocoapods去pod install版本10.2.5的ArcGIS-Runtime-SDK-iOS出错:curl 56 Recv failure: Connection reset by peer

期间,pod update出错:

➜  inquzhou_ios git:(master) ✗ pod update

Update all pods

Updating local specs repositories

  $ /usr/bin/git -C /Users/crifan/.cocoapods/repos/master fetch origin –progress

  remote: Counting objects: 433, done.

  remote: Compressing objects: 100% (240/240), done.

  remote: Total 433 (delta 286), reused 304 (delta 173), pack-reused 0

  Receiving objects: 100% (433/433), 44.17 KiB | 128.00 KiB/s, done.

  Resolving deltas: 100% (286/286), completed with 119 local objects.

  From https://github.com/CocoaPods/Specs

     599d9e7b34b..9ef3b7ea994  master     -> origin/master

  $ /usr/bin/git -C /Users/crifan/.cocoapods/repos/master rev-parse –abbrev-ref HEAD

  master

  $ /usr/bin/git -C /Users/crifan/.cocoapods/repos/master reset –hard origin/master

  HEAD is now at 9ef3b7ea994 [Add] JYModel 1.0.7

CocoaPods 1.4.0.beta.2 is available.

To update use: `sudo gem install cocoapods –pre`

[!] This is a test version we’d love you to try.

For more information, see https://blog.cocoapods.org and the CHANGELOG for this version at https://github.com/CocoaPods/CocoaPods/releases/tag/1.4.0.beta.2

Analyzing dependencies

Downloading dependencies

Using AFNetworking (2.6.3)

Installing ArcGIS-Runtime-SDK-iOS (10.2.5)

[!] Error installing ArcGIS-Runtime-SDK-iOS

[!] /usr/bin/curl -f -L -o /var/folders/46/2hjxz38n22n3ypp_5f6_p__00000gn/T/d20171212-1181-1aorp1v/file.zip http://esri.box.com/shared/static/aa3e5u04sakyshphc9ooqizvyse7b8iv.zip –create-dirs –netrc-optional

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 –:–:– –:–:– –:–:–     0

curl: (56) Recv failure: Connection reset by peer

所以还是先去升级pod试试

➜  inquzhou_ios git:(master) ✗ sudo gem install cocoapods –pre

Password:

Fetching: cocoapods-core-1.4.0.beta.2.gem (100%)

Successfully installed cocoapods-core-1.4.0.beta.2

Fetching: molinillo-0.6.4.gem (100%)

Successfully installed molinillo-0.6.4

Fetching: cocoapods-1.4.0.beta.2.gem (100%)

ERROR:  While executing gem … (Gem::FilePermissionError)

    You don’t have write permissions for the /usr/bin directory.

重新试试,问题依旧:

➜  inquzhou_ios git:(master) ✗ sudo gem install cocoapods –pre

ERROR:  While executing gem … (Gem::FilePermissionError)

    You don’t have write permissions for the /usr/bin directory.

➜  inquzhou_ios git:(master) ✗ whoami

crifan

➜  inquzhou_ios git:(master) ✗ ll /usr/

total 0

drwxr-xr-x  976 root  wheel    31K 11 30 12:02 bin

drwxr-xr-x  292 root  wheel   9.1K 11 30 12:02 lib

drwxr-xr-x  235 root  wheel   7.3K 11 30 12:02 libexec

drwxr-xr-x   27 root  wheel   864B 11 15 12:25 local

drwxr-xr-x  246 root  wheel   7.7K 11 15 12:14 sbin

drwxr-xr-x   46 root  wheel   1.4K 11 15 12:14 share

drwxr-xr-x    5 root  wheel   160B 10 26 00:33 standalone

sudo gem install cocoapods ERROR While executing gem FilePermissionError

Mac更新Ruby环境及可能遇到的问题 – 简书

安装CocoaPods遇到的问题 – 简书

➜  inquzhou_ios git:(master) ✗ sudo chmod 777 /usr/bin

chmod: Unable to change file mode on /usr/bin: Operation not permitted

算了,重装cocoapods

➜  inquzhou_ios git:(master) ✗ which pod

/usr/local/bin/pod

➜  inquzhou_ios git:(master) ✗ sudo rm -rf /usr/local/bin/pod

➜  inquzhou_ios git:(master) ✗ sudo rvm install 2.4

sudo: rvm: command not found

搜:

sudo: rvm: command not found

ruby on rails – sudo: rvm: command not found – RVM MultiUser install on Ubuntu 12.04 server – Stack Overflow

Cannot use RVM-installed Ruby with sudo – Stack Overflow

➜  inquzhou_ios git:(master) ✗ curl -L https://get.rvm.io | bash -s stable

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

100   194  100   194    0     0     98      0  0:00:01  0:00:01 –:–:–    98

100 24090  100 24090    0     0   5310      0  0:00:04  0:00:04 –:–:–  9659

Downloading https://github.com/rvm/rvm/archive/1.29.3.tar.gz

结果半天下载不下来。

ruby – cocoapods permission issue in High Sierra? – Stack Overflow

➜  inquzhou_ios git:(master) ✗ sudo gem update –system

Latest version currently installed. Aborting.

➜  inquzhou_ios git:(master) ✗ sudo gem install cocoapods -n/usr/local/bin

Successfully installed cocoapods-1.3.1

Parsing documentation for cocoapods-1.3.1

Done installing documentation for cocoapods after 3 seconds

1 gem installed

Problem with installing cocoaPods from terminal · Issue #4574 · CocoaPods/CocoaPods

-n前应该有空格:

sudo gem install -n /usr/local/bin cocoapods

➜  inquzhou_ios git:(master) ✗ sudo gem install -n /usr/local/bin cocoapods

Successfully installed cocoapods-1.3.1

Parsing documentation for cocoapods-1.3.1

Done installing documentation for cocoapods after 3 seconds

1 gem installed

问题依旧:

➜  inquzhou_ios git:(master) ✗ pod update

Update all pods

Updating local specs repositories

  $ /usr/bin/git -C /Users/crifan/.cocoapods/repos/master fetch origin –progress

  remote: Counting objects: 72, done.

  remote: Compressing objects: 100% (68/68), done.

  remote: Total 72 (delta 45), reused 0 (delta 0), pack-reused 0

  From https://github.com/CocoaPods/Specs

     9ef3b7ea994..3ebb02b0969  master     -> origin/master

  $ /usr/bin/git -C /Users/crifan/.cocoapods/repos/master rev-parse –abbrev-ref HEAD

  master

  $ /usr/bin/git -C /Users/crifan/.cocoapods/repos/master reset –hard origin/master

  HEAD is now at 3ebb02b0969 [Add] ToastCommon 0.0.1

CocoaPods 1.4.0.beta.2 is available.

To update use: `sudo gem install cocoapods –pre`

[!] This is a test version we’d love you to try.

For more information, see https://blog.cocoapods.org and the CHANGELOG for this version at https://github.com/CocoaPods/CocoaPods/releases/tag/1.4.0.beta.2

Analyzing dependencies

Downloading dependencies

Using AFNetworking (2.6.3)

Installing ArcGIS-Runtime-SDK-iOS (10.2.5)

[!] Error installing ArcGIS-Runtime-SDK-iOS

[!] /usr/bin/curl -f -L -o /var/folders/46/2hjxz38n22n3ypp_5f6_p__00000gn/T/d20171212-1876-16tqurg/file.zip http://esri.box.com/shared/static/aa3e5u04sakyshphc9ooqizvyse7b8iv.zip –create-dirs –netrc-optional

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 –:–:– –:–:– –:–:–     0

curl: (56) Recv failure: Connection reset by peer

直接运行也不行:

➜  inquzhou_ios git:(master) ✗ /usr/bin/curl -f -L -o /var/folders/46/2hjxz38n22n3ypp_5f6_p__00000gn/T/d20171212-1876-16tqurg/file.zip http://esri.box.com/shared/static/aa3e5u04sakyshphc9ooqizvyse7b8iv.zip –create-dirs –netrc-optional

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 –:–:– –:–:– –:–:–     0

curl: (56) Recv failure: Connection reset by peer

算了。放弃。

转载请注明:在路上 » 【未解决】升级CocoaPods:CocoaPods is available To update use

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
59 queries in 0.286 seconds, using 12.04MB memory