最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【已解决】Xcode9.2编译出错:ld library not found for -lMobClickLibrary

Xcode crifan 3842浏览 0评论

ld: library not found for -lMobClickLibrary

clang: error: linker command failed with exit code 1 (use -v to see invocation)

去换成Xcode9.1试试

问题依旧。

搜:

ld: library not found for -lMobClickLibrary

貌似没有人遇到这个库缺少的

项目中搜:

MobClick

在项目的配置中

Other Linker Flags中找到了:

所以很明显是缺少了这个库文件

OTHER_LDFLAGS = $(inherited) -ObjC -l”APOpenSdk” -l”LWApiSDK” -l”SocialAlipayShare” -l”SocialFacebook” -l”SocialInstagram” -l”SocialLaiWang” -l”SocialLine” -l”SocialQQ” -l”SocialSinaSSO” -l”SocialTumblr” -l”SocialTwitter” -l”SocialWechat” -l”SocialWhatsapp” -l”UMSocial_Sdk_5.0″ -l”UMSocial_Sdk_Comment_5.0″ -l”WeChatSDK” -l”WeiboSDK” -l”iconv” -l”sqlite3″ -l”stdc++” -l”z” -framework “AFNetworking” -framework “Accounts” -framework “CoreData” -framework “CoreGraphics” -framework “CoreTelephony” -framework “FBSDKCoreKit” -framework “FBSDKLoginKit” -framework “FBSDKShareKit” -framework “Fabric” -framework “ImageIO” -framework “MBProgressHUD” -framework “MJRefresh” -framework “MobileCoreServices” -framework “RaptureXML” -framework “Realm” -framework “SDWebImage” -framework “SSZipArchive” -framework “Social” -framework “SystemConfiguration” -framework “TCBlobDownload” -framework “TencentOpenAPI” -framework “TwitterCore” -framework “TwitterKit” -framework “UMMobClick” -framework “YYModel”

也是需要这个UMMobClick的framework

去看看旧的可以运行的项目,对比发现,其实之前和现在的项目都有对应的库文件,但是之前是 .a现在是framework:

而且UMAnalytics的sdk:

  • 旧项目中旧版本sdk:3.6.6
  • 新项目中新版本:4.1.0

所以要去重新更新配置文件,或许就可以找到了。

看新项目中pods中的结构:

好像是:

新版本的友盟统计把social和analytics分开了:

  • 统计功能的Analytics
  • 社交功能的Social

所以库名字也改了,所以去试试,把之前的:

-l”MobClickLibrary”

改为:

-framework “UMMobClick”

注意到双引号是中文的,去改为英文的:

然后再去编译试试,这个问题消失了。

【总结】

此处Xcode编译出现:

ld library not found for -lMobClickLibrary

的链接错误,原因是:

友盟统计SDK版本升级了,从之前:

UMAnalytics_Sdk_3.6.6的静态库:libMobClickLibrary.a

改为了social和analytics分开了:

  • 统计功能的Analytics
  • 社交功能的Social

且是动态库:

umsdk_IOS_analyics_idfa_v4.1.0的UMMobClick.framework

所以,把配置:

Build Settings-》Linking-〉Other Linker Flags

中的:

-l”MobClickLibrary”

改为:

-framework “UMMobClick”

即可:

注:

然后又出现其他错误:

【已解决】Xcode链接友盟统计库出错:UMSCommentDetailController.xib global error Compiling IB documents for earlier than iOS 7 is no longer supported

转载请注明:在路上 » 【已解决】Xcode9.2编译出错:ld library not found for -lMobClickLibrary

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
62 queries in 0.091 seconds, using 18.72MB memory