最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

【已解决】Xcode中运行React Native iOS的app到iPhone真机出错:Could not locate device support files

iOS crifan 782浏览 0评论

折腾:

【已解决】React Native iOS的app如何运行到iPhone真机中

期间,选择了Target设备为自己的用USB插入到Mac的iPhone6

然后Xcode中去运行,结果出错:

Could not locate device support files.
This iPhone 6 is running iOS 10.2.1 (14D27), which may not be supported by this version of Xcode.

所以去:

升级iPhone中的iOS版本?

React Native iOS iPhone Xcode Could not locate device support files 

could not locate device support files | Apple Developer Forums

[iOS] RCTWebSocket does not build on Xcode Version 8.0 beta (8S128d) · Issue #8108 · facebook/react-native · GitHub

iPhone中版本信息是:

想要去更新iPhone中iOS版本,结果显示:

iOS 10.2.1

您的软件是最新版本

-》所以没有更新版本可以供更新。

React Native iOS iPhone Xcode This iPhone 6 is running iOS  which may not be supported by this version of Xcode

react-native cli cannot start iPhone simulator [Xcode 8] · Issue #9900 · facebook/react-native · GitHub

Xcode中,去clean后:

重新编译

错误依旧。

此处,再去试试,把iPhone中的Wifi设置为和Mac中一样:

此处,去Mac中的AppStore中看,没看到Xcode的版本更新,只看到iTunes的版本更新:

去更新试试,然后看看,或许,能解决Xcode无法识别 不支持 iPhone的问题?

点击了更新,弹出:

-》貌似的确还是会影响到的Xcode的。

退出Xcode,然后才可以继续:

结果出错:

发生错误

未能验证“iTunes”。(311)

再去试试

结果问题依旧。

不过后来看到,此Xcode项目中,设备code sign出错:

所以估计是这个原因。

所以点击Team换成自己,然后自动去修复

结果再去细看,结果还有其他错误:

好像是自己的账户过期了???

登录到Apple Developer Center去看看

https://developer.apple.com/account/

果然是:

自己的苹果开发者账号过期了。。。

暂时先不不去管了

换用另外的开发账号

就可以code sign了。

但是问题依旧:

继续看帖:

could not locate device support files | Apple Developer Forums

然后此刻才注意到:

自己的Xcode是Version 8.0 (8A218a)

而不是8.1

看来只能去根据提示去:

Xcode 8.1 Gold Master

下载最新的8.1的Xcode了?

【记录】Mac中下载和安装最新版8.3的Xcode

然后再去试试:

貌似是可以的,不过先要等待解析完毕symbol才可以:

然后去Xcode中设置目标设备为iPhone6后,再去运行,即可正常编译和运行了:

然后,此处,才算真的解决了上述的问题。

【总结】

Xcode中,此处想要运行app到iPhone真机中,结果提示错误:

Could not locate device support files.
This iPhone 6 is running iOS 10.2.1 (14D27), which may not be supported by this version of Xcode.

其中,此处Xcode版本是8.0,iPhone6的iOS版本是10.2.1

原因是:

Xcode 8.0,就根本无法支持iOS 10.2.1

而8.1之后,貌似就支持iOS 10.2+的版本了。

解决办法是:

下载最新版本的Xcode,此处Xcode的最新版已经(不是之前的8.1)而是8.3

具体步骤:

去官网:

https://developer.apple.com/download/

下载最新版本的Xcode,会得到一个xip文件,比如:

Xcode_8.3_beta_5.xip

然后解压后,得到Xcode.app,直接拖动到Finder-》应用程序 -》提示中,选择“覆盖”安装-》即可。

8.3版本的Xcode,就可以支持此处iOS 10.2.1的iPhone6了。

说明:

1.换句话说:

此处和React Native的app,是没有关系的。

就是Xcode版本太低。

2.而之所以苹果官方没有把Xcode的升级放到Mac的App Store中提示大家升级,则不得而知。。。

转载请注明:在路上 » 【已解决】Xcode中运行React Native iOS的app到iPhone真机出错:Could not locate device support files

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
59 queries in 0.128 seconds, using 18.61MB memory