最新消息:20190717 VPS服务器:Vultr新加坡,WordPress主题:大前端D8,统一介绍入口:关于

[未解决]linphone-iphone编译出错:The document ShopView.xib requires Xcode 8.0 or later

Xcode crifan 937浏览 0评论
The document “ShopView.xib” requires Xcode 8.0 or later.
This version does not support documents saved in the Xcode 8 format. Open this document with Xcode 8.0 or later.

但是此处已经把:target从6.0改为8.0了:

结果还是报同样的错误

搜:

linphone-iphone The document  xib requires Xcode 8.0 or later

有效解决 iOS The document “(null)” requires Xcode 8.0 or later. – 张无忌! – 博客园

This version does not support documents saved in the Xcode 8 format. Open this document with Xcode 8 – W_C__L的博客 – 博客频道 – CSDN.NET

Re: [Linphone-developers] Building linphone-iphone w/ XCode4.2 / SL 10.6

The document Main.storyboard requires Xcode 8.0 or later,ios,objective-c,storyboard,ios10,xcode8 – howtoprogram.eu

ios – The document Main.storyboard requires Xcode 8.0 or later – Stack Overflow

    <dependencies>
        <deployment identifier="iOS"/>
        <plugIn identifier="com.apple.InterfaceBuilder.IBCocoaTouchPlugin" version="11161"/>
        <capability name="documents saved in the Xcode 8 format" minToolsVersion="8.0"/>
    </dependencies>

结果导致Xcode崩溃

重新去编辑另外的:

里面没有8.0的约束

然后Xcode还是崩溃

改为:

        <capability name="documents saved in the Xcode 7 format" minToolsVersion="7.0"/>

去编译,结果出错:

CompileXIB Classes/Base.lproj/ShopView.xib
    cd /Users/crifan/dev/dev_src/swift/SIP/linphone-iphone/linphone-iphone
    export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"
    export XCODE_DEVELOPER_USR_PATH=/Applications/Xcode.app/Contents/Developer/usr/bin/..
    /Applications/Xcode.app/Contents/Developer/usr/bin/ibtool –errors –warnings –notices –companion-strings-file en:/Users/crifan/dev/dev_src/swift/SIP/linphone-iphone/linphone-iphone/Classes/en.lproj/ShopView.strings –companion-strings-file fr:/Users/crifan/dev/dev_src/swift/SIP/linphone-iphone/linphone-iphone/Classes/fr.lproj/ShopView.strings –module linphone –output-partial-info-plist /Users/crifan/Library/Developer/Xcode/DerivedData/linphone-fpmhvyuynipgurfwvnohpykaouei/Build/Intermediates/linphone.build/Debug-iphonesimulator/linphone.build/ShopView-PartialInfo.plist –auto-activate-custom-fonts –target-device iphone –target-device ipad –minimum-deployment-target 8.0 –output-format human-readable-text –compile /Users/crifan/Library/Developer/Xcode/DerivedData/linphone-fpmhvyuynipgurfwvnohpykaouei/Build/Products/Debug-iphonesimulator/linphone.app/Base.lproj/ShopView.nib /Users/crifan/dev/dev_src/swift/SIP/linphone-iphone/linphone-iphone/Classes/Base.lproj/ShopView.xib
2016-09-08 17:08:55.938 ibtoold[20984:1861464] [MT] DVTAssertions: ASSERTION FAILURE in /Library/Caches/com.apple.xbs/Sources/IDEInterfaceBuilder/IDEInterfaceBuilder-10117/InterfaceBuilderKit/Document/Archiving/IBDocumentUnarchiver.m:231
Details:  Failed to unarchive an instance of IBUIScreenMetrics
Object:   <IBDocumentUnarchiver: 0x7fe1cc3bc600>
Method:   -unarchiveObjectFromElement:
Thread:   <NSThread: 0x7fe1c9521f80>{number = 1, name = main}
Hints: None
Backtrace:
  0   -[DVTAssertionHandler handleFailureInMethod:object:fileName:lineNumber:assertionSignature:messageFormat:arguments:] (in DVTFoundation)
  1   _DVTAssertionHandler (in DVTFoundation)
  2   _DVTAssertionFailureHandler (in DVTFoundation)
  3   __51-[IBDocumentUnarchiver unarchiveObjectFromElement:]_block_invoke (in IDEInterfaceBuilderKit)
  4   -[IBDocumentUnarchiver recurseWithElement:kind:invokingBlock:] (in IDEInterfaceBuilderKit)
  5   -[IBDocumentUnarchiver unarchiveObjectFromElement:] (in IDEInterfaceBuilderKit)
  6   -[IBDocumentUnarchiver unarchiveObjectForKey:defaultValue:] (in IDEInterfaceBuilderKit)
  7  0x0000000114d2da7f (in IDEInterfaceBuilderCocoaTouchIntegration)
  8   IBUIUnarchiveSimulatedMetric (in IDEInterfaceBuilderCocoaTouchIntegration)
  9  0x0000000114d2d032 (in IDEInterfaceBuilderCocoaTouchIntegration)
 10  0x0000000114d2b47a (in IDEInterfaceBuilderCocoaTouchIntegration)
 11   __51-[IBDocumentUnarchiver unarchiveObjectFromElement:]_block_invoke (in IDEInterfaceBuilderKit)
 12   -[IBDocumentUnarchiver recurseWithElement:kind:invokingBlock:] (in IDEInterfaceBuilderKit)
 13   -[IBDocumentUnarchiver unarchiveObjectFromElement:] (in IDEInterfaceBuilderKit)
 14   -[IBDocumentUnarchiver unarchiveObjectForKey:defaultValue:] (in IDEInterfaceBuilderKit)
 15   -[IBDocument unarchivePlatformIndependentDataWithUnarchiver:error:] (in IDEInterfaceBuilderKit)
 16   -[IBDocument unarchiveDocumentWithUnarchiver:error:] (in IDEInterfaceBuilderKit)
 17   __48-[IBDocumentUnarchiver unarchiveDocument:error:]_block_invoke (in IDEInterfaceBuilderKit)
 18   -[IBDocumentUnarchiver recurseWithElement:kind:invokingBlock:] (in IDEInterfaceBuilderKit)
 19   -[IBDocumentUnarchiver unarchiveDocument:error:] (in IDEInterfaceBuilderKit)
 20   __61-[IBDocument decodeContentsOfURL:ofType:decodingStyle:error:]_block_invoke (in IDEInterfaceBuilderKit)
 21   -[IBDocumentAutolayoutManager ignoreAutolayoutStatusInvalidationDuring:] (in IDEInterfaceBuilderKit)
 22   -[IBDocument ignoreAutolayoutStatusInvalidationDuring:] (in IDEInterfaceBuilderKit)
 23   -[IBDocument decodeContentsOfURL:ofType:decodingStyle:error:] (in IDEInterfaceBuilderKit)
 24   __39-[IBDocument readFromURL:ofType:error:]_block_invoke (in IDEInterfaceBuilderKit)
 25   -[IBDocument suppressAndResetUndoManagerDuring:] (in IDEInterfaceBuilderKit)
 26   -[IBDocument readFromURL:ofType:error:] (in IDEInterfaceBuilderKit)
 27  0x0000000109242fe7 (in ibtoold)
 28  0x000000010923c007 (in ibtoold)
 29  0x00000001092446ab (in ibtoold)
 30  0x00000001092485c8 (in ibtoold)
 31  0x0000000109248c5a (in ibtoold)
 32  0x0000000109248b2d (in ibtoold)
 33  0x000000010923795b (in ibtoold)
 34  0x00000001092481c3 (in ibtoold)
 35  0x0000000109247274 (in ibtoold)
 36   start (in libdyld.dylib)
Command /Applications/Xcode.app/Contents/Developer/usr/bin/ibtool failed with exit code 255. The tool may have crashed. Please file a bug report at http://bugreport.apple.com with the above output and attach any crash logs for ibtool, ibtoold, Xcode, and Interface Builder Cocoa Touch Tool created around the time of this failure. These logs can be found in ~/Library/Logs/DiagnosticReports or /Library/Logs/DiagnosticReports.

Interface Builder Document

如何打开 Interface Builder Document

linphone-iphone The document requires Xcode 8.0 or later

官网也发现了此问题:

BelledonneCommunications/linphone-iphone – Travis CI

BelledonneCommunications/linphone-iphone: Linphone.org mirror for linphone-iphone (git://git.linphone.org/linphone-iphone.git)

-》

看到一个最近的提交的版本,是通过CI编译的:

https://github.com/BelledonneCommunications/linphone-iphone/commit/280bed6affba63650760cfa2446c352da6dd254c

所以想办法去下载这个,编译通过的版本

[未解决]如何从github中用git命令下载指定的版本

转载请注明:在路上 » [未解决]linphone-iphone编译出错:The document ShopView.xib requires Xcode 8.0 or later

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
61 queries in 0.127 seconds, using 18.64MB memory