最新消息:VPS服务器又从fzhost.net换回Linode了,主题仍用朋友推荐的大前端D8

【已解决】Xcode8中carthage update出错:Required plug-in compatibility UUID for plug-in at path RealmPlugin.xcplugin not present in DVTPlugInCompatibilityUUIDs

Xcode crifan 326浏览 0评论

在Xcode升级到8.0之后:

折腾:

【已解决】Xcode中导入Carthage编译的库报错:Module compiled with Swift 2.3 cannot be imported in Swift 3.0

等期间,看到Carthage update出现:

xcodebuild MT PluginLoading Required plug-in compatibility UUID 8A66E736-A720-4B3C-92F1-33D9962C69DF for plug-in at path RealmPlugin.xcplugin not present in DVTPlugInCompatibilityUUIDs

*** Building scheme "XCGLogger (iOS)" in XCGLogger.xcodeproj
2016-10-15 22:37:10.123 xcodebuild[28351:1959314] [MT] PluginLoading: Required plug-in compatibility UUID 8A66E736-A720-4B3C-92F1-33D9962C69DF for plug-in at path ‘~/Library/Application Support/Developer/Shared/Xcode/Plug-ins/WCGitTagsPlugin.xcplugin’ not present in DVTPlugInCompatibilityUUIDs
2016-10-15 22:37:10.123 xcodebuild[28351:1959314] [MT] PluginLoading: Required plug-in compatibility UUID 8A66E736-A720-4B3C-92F1-33D9962C69DF for plug-in at path ‘~/Library/Application Support/Developer/Shared/Xcode/Plug-ins/RealmPlugin.xcplugin’ not present in DVTPlugInCompatibilityUUIDs
2016-10-15 22:37:10.124 xcodebuild[28351:1959314] [MT] PluginLoading: Required plug-in compatibility UUID 8A66E736-A720-4B3C-92F1-33D9962C69DF for plug-in at path ‘~/Library/Application Support/Developer/Shared/Xcode/Plug-ins/Alcatraz.xcplugin’ not present in DVTPlugInCompatibilityUUIDs
2016-10-15 22:37:33.157 xcodebuild[28445:1959609] [MT] PluginLoading: Required plug-in compatibility UUID 8A66E736-A720-4B3C-92F1-33D9962C69DF for plug-in at path ‘~/Library/Application Support/Developer/Shared/Xcode/Plug-ins/WCGitTagsPlugin.xcplugin’ not present in DVTPlugInCompatibilityUUIDs
2016-10-15 22:37:33.157 xcodebuild[28445:1959609] [MT] PluginLoading: Required plug-in compatibility UUID 8A66E736-A720-4B3C-92F1-33D9962C69DF for plug-in at path ‘~/Library/Application Support/Developer/Shared/Xcode/Plug-ins/RealmPlugin.xcplugin’ not present in DVTPlugInCompatibilityUUIDs
2016-10-15 22:37:33.158 xcodebuild[28445:1959609] [MT] PluginLoading: Required plug-in compatibility UUID 8A66E736-A720-4B3C-92F1-33D9962C69DF for plug-in at path ‘~/Library/Application Support/Developer/Shared/Xcode/Plug-ins/Alcatraz.xcplugin’ not present in DVTPlugInCompatibilityUUIDs

参考自己之前的:

[已解决]Xcode编译程序出现PluginLoading: Required plug-in compatibility UUID for plug-in at path WCGitTagsPlugin.xcplugin not present in DVTPlugInCompatibilityUUIDs

licrifandeMacBook-Pro:~ crifan$ defaults read /Applications/Xcode.app/Contents/Info DVTPlugInCompatibilityUUID
ACA8656B-FEA8-4B6D-8E4A-93F4C95C362C
licrifandeMacBook-Pro:~ crifan$ XCODEUUID=`defaults read /Applications/Xcode.app/Contents/Info DVTPlugInCompatibilityUUID`
licrifandeMacBook-Pro:~ crifan$ for f in ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins/*; do defaults write "$f/Contents/Info" DVTPlugInCompatibilityUUIDs -array-add $XCODEUUID; done

结果竟然出现另外的错误:

【已解决】Xcode8中carthage update出错:WARNING: Failed to load plugin at path Error Domain=NSCocoaErrorDomain Code=3587 no suitable image found

终于就彻底干净,没有报错了:

➜  FreeShadowsocks carthage update –platform iOS
*** Fetching SwiftHEXColors
*** Fetching SwiftHTTPStatusCodes
*** Fetching XCGLogger
*** Fetching SwiftyJSON
*** Fetching Alamofire
*** Fetching Cartography
*** Checking out Alamofire at "3.5.1"
*** Checking out SwiftHTTPStatusCodes at "3.1.0"
*** Checking out SwiftHEXColors at "f4b98e298528fd9d88b10ab55e806d29ce497daa"
*** Checking out XCGLogger at "2fd27c92eb102bcf09f3176a230e42e38cacd4a2"
*** Downloading SwiftyJSON.framework binary at "3.1.1"
*** Checking out Cartography at "1.0.1"
*** xcodebuild output can be found in /var/folders/46/2hjxz38n22n3ypp_5f6_p__00000gn/T/carthage-xcodebuild.jkF4ZT.log
*** Building scheme "Alamofire iOS" in Alamofire.xcworkspace
*** Building scheme "Cartography-iOS" in Cartography.xcworkspace
*** Building scheme "SwiftHEXColors" in SwiftHEXColors.xcodeproj
*** Building scheme "HTTPStatusCodes" in HTTPStatusCodes.xcodeproj
*** Building scheme "XCGLogger (iOS)" in XCGLogger.xcodeproj

【总结】

Xcode 升级到8之后,出现:

PluginLoading Required plug-in compatibility

解决办法是:

和之前:

[已解决]Xcode编译程序出现PluginLoading: Required plug-in compatibility UUID for plug-in at path WCGitTagsPlugin.xcplugin not present in DVTPlugInCompatibilityUUIDs

一样,去执行:

defaults read /Applications/Xcode.app/Contents/Info
XCODEUUID=`defaults read /Applications/Xcode.app/Contents/Info DVTPlugInCompatibilityUUID`
for f in ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins/*; do defaults write "$f/Contents/Info" DVTPlugInCompatibilityUUIDs -array-add $XCODEUUID; done

即可。

转载请注明:在路上 » 【已解决】Xcode8中carthage update出错:Required plug-in compatibility UUID for plug-in at path RealmPlugin.xcplugin not present in DVTPlugInCompatibilityUUIDs

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
15 queries in 0.206 seconds, using 10.31MB memory